Photoshop: Displays image weird when zoomed out or at 100%

  • 2
  • Problem
  • Updated 7 years ago
  • Solved
  • (Edited)
My photoshop looks weird when I have an image zoomed out or at 100%. It does this: (see attached screenshot).


I have a Thinkpad T60p running Windows 7. The graphics card is an ATI FireGL V5250. It was fine when I had Windows XP, but now it does this.
Photo of Robin

Robin

  • 4 Posts
  • 0 Reply Likes
  • concerned

Posted 7 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
You need to update your video card driver, because the driver has a bug.
If you can't find an updated driver from the GPU maker's web site, then you could also try disabling OpenGL drawing in preferences.
Photo of Robin

Robin

  • 4 Posts
  • 0 Reply Likes
I've actually tried updating my driver before, because the screen resolution wasn't working right. I'm not sure if that worked, but I downloaded ATI display driver software and I got my screen resolution to work right. I just tried updating my driver through the device manager and windows says my driver software is up to date.

I disabled OpenGL drawing and it works fine now. However, won't this be a performance decrease?

Anyway, thanks!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14123 Posts
  • 1761 Reply Likes
What version of the driver do you have? If it's 11-3, you may need to downgrade to 11-2:

http://feedback.photoshop.com/photosh...
Photo of Robin

Robin

  • 4 Posts
  • 0 Reply Likes
Device manager tells me its version is 4.36.00, dated 4-3-2011. Did you mean the date?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14123 Posts
  • 1761 Reply Likes
That looks like a generic driver from Lenovo. I'd go directly to the ATI/AMD site and get the "Catalyst 11.2" driver.

Are you running Win 7 64bit or 32bit?

http://support.amd.com/us/gpudownload...

http://support.amd.com/us/gpudownload...
Photo of Zeno Bokor

Zeno Bokor, Champion

  • 6 Posts
  • 1 Reply Like
You might want to check your Device Manager again as that looks to me like the driver for the display itself and not the video card
Photo of Robin

Robin

  • 4 Posts
  • 0 Reply Likes
Ah I see. Running 32bit. Thank you very very much!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13996 Posts
  • 1709 Reply Likes
Robin, let me know if using the "Catalyst 11.2" driver fixed this for you.