Photoshop: CS6 shuts down, no error log no warning (Win)

  • 2
  • Problem
  • Updated 6 years ago
  • (Edited)
CS6 sometimes just decides to quit in the middle of doing something - no common reason; one minute it's working on type or using some other tool.

There's no error in the Windows event viewer (or entry at the time it occurs). One minute it's open and I'm working, the next - *poof* I'm staring at my desktop and wondering when I last saved.

Some software! Glad my work pays for this and not me (I wouldn't stand for it).

As it is, I'm still using CS5; at least that's stable.
Photo of lister.belfast


  • 15 Posts
  • 5 Reply Likes
  • PO'd

Posted 7 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 849 Reply Likes
What are you doing just before it disappears?

Do you have any third party plugins installed?

Is your video card driver up to date?
Photo of lister.belfast


  • 15 Posts
  • 5 Reply Likes
This time I was tweaking the vertical scale of a font (Caecilia LT Std).
Previously, it happened (I think) when I was using the clone brush (show overlay unchecked) and also with with the quick selection tool.

No plugins installed.

AMD driver v12.6 (the latest I think).
Photo of Lorena Sanchez

Lorena Sanchez

  • 3 Posts
  • 0 Reply Likes
The same thing has been happening to me! I thought it was Topaz Labs (I was using 'Clean'), but when I uninstalled those plugins, I received the same error message of "Windows has encountered a problem with PsCS6" and it closes without me being able to save at all! Please help out, I hope there is a simple solution to this!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
So you're not seeing the same behavior at all. You experienced a crash, not a shutdown without an error.

Please create a new topic with details about your system and the crash (especially the name of the faulting module).
Photo of Lorena Sanchez

Lorena Sanchez

  • 3 Posts
  • 0 Reply Likes
My apologies! Yes, I'll create a new thread right now.
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
This is the most annoying of all things. I don't even like to use PS any more because I am always waiting for the other shoe to drop when I create a file. I've posted about this before in another thread, and had some things to try, but nothing has seemed to do the trick.

I do not use plug-ins at all, I've cleared the preferences, I've uninstalled and reinstalled using a second downloaded file for a completely new install. I've checked and unchecked boxes in preferences related to reducing the load on my graphics card (which I chose with high-end gaming and photoshop in mind, so it's not crap), and I've updated the graphics driver. I've tried unplugging my bamboo tablet and restarting the computer and NONE of it has worked.

I never once had a problem with Beta version of CS6. This all started when I installed the regular, paid-for version, which really irks the heck out of me. Auto-Save is great, unless you work very fast and have a terrible memory for what you just did to get an effect--which I do.

Just like the OP, I am working along, and all of a sudden, everything just closes. A lot of times it is when I am trying to open a file from my Downloads folder (it's where I save photos/graphics I want to use in a project) and a lot of times it is as I am going to save my work, and I click Save As, and at random points in the process of choosing a location/typing a filename/clicking on the Save button the whole thing just closes completely. I have tried the things that have been suggested to me to this point and none are working. I DREAD opening the program now, because I am so tired of having to click Save As and cross my fingers that I am not losing everything I have done in the last 10 minutes.

I do run PS at the same time as I have other programs open, like Firefox. I have 8G of RAM in my PC and I run Windows 7. I am willing to upgrade my memory, but I want to know that it is going to FIX the problem and frankly, I don't think it will, because this stupid thing isn't getting any error messages or events in the log when this happens, it is just there one second and gone the next. For instance, on Monday night, I was making a file, and I had spent a good deal of time on it and then just to be safe, I tabbed over to my browser because I figured if I spend 5 minutes doing something else, the autosave will save a copy before I go back to save the file and lose my work due to this shut-down. I went to click back on the PS window to save my work, and it was just gone. GONE. GOOOONNNNNEEEEE! How am I supposed to work like this?!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 848 Reply Likes
Please understand that for most people, Photoshop is very stable.
The majority of the crashes we see are caused by OS bugs, driver bugs, and bugs in third party plugins.

If Photoshop is disappearing without an error like the topic says, something odd is going on. Most of the time if something goes wrong, you should at least get a crash alert.

The fact that you're crashing in the OS save dialog could be a clue -- it could be an OS bug, or a problem with a third party system extension (like a explorer icons extension, antivirus, etc.). If whatever OS level problem you're hitting calls exit() instead of crashing or calling abort() - then you wouldn't get an error message (and no Windows Error Reporting details for us to examine!).

So, we need to troubleshoot your system: what utilities do you have installed, and what other oddities might be showing at the OS level?
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
Thanks, Chris, now we are getting somewhere. When I go home tonight, I will write down all the programs that run on startup (that I can see...). I know that Avast Free antivirus is running, and I did have Ad-Aware by Lavasoft going as well. I have shut off most other programs from running at startup, but there may be more. Would it be a good idea to check the task manager for processes or would that not help? I appreciate your help, this has been driving me bananas for a long time.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 848 Reply Likes
That might help, but I don't know exactly what is causing this, so I don't know exactly where to look. On MacOS we had a similar bug caused by a corrupt OS preference file (and that took a while to figure out). So another test that might help is logging in as a different user and seeing if you have the same problem.
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
And during the save/open file process is not the ONLY time this happens, it is just the most prevalent time.
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
Haha, and just for the record, I love that Chris has got this HUGE green smiley face. That's pretty funny when the rest of us are all *grumble grumble*.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 848 Reply Likes
Glad you like it!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15947 Posts
  • 2484 Reply Likes

It may help if we could see your Photoshop System Info. Directions for sharing your system info from Photoshop:
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
Thank you, I didn't realize I could do this!
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
Adobe Photoshop Version: 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00) x64
Operating System: Windows 7 64-bit
Version: 6.1 Service Pack 1
System architecture: AMD CPU Family:15, Model:10, Stepping:0 with MMX, SSE Integer, SSE FP, SSE2, SSE3
Physical processor count: 6
Processor speed: 3311 MHz
Built-in memory: 8190 MB
Free memory: 4832 MB
Memory available to Photoshop: 7254 MB
Memory used by Photoshop: 80 %
Image tile size: 132K
Image cache levels: 4
OpenGL Drawing: Enabled.
OpenGL Drawing Mode: Basic
OpenGL Allow Normal Mode: True.
OpenGL Allow Advanced Mode: True.
OpenGL Allow Old GPUs: Not Detected.
Video Card Vendor: NVIDIA Corporation
Video Card Renderer: GeForce GTX 460/PCIe/SSE2
Display: 1
Display Bounds:= top: 0, left: 0, bottom: 1080, right: 1920
Video Card Number: 1
Video Card: NVIDIA GeForce GTX 460
OpenCL Unavailable
Driver Version:
Driver Date: 20130314000000.000000-000
Video Card Driver: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Video Mode: 1920 x 1080 x 4294967296 colors
Video Card Caption: NVIDIA GeForce GTX 460
Video Card Memory: 1024 MB
Video Rect Texture Size: 16384
Serial number: 95478848590745228248
Application folder: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\
Temporary file path: C:\Users\Heather\AppData\Local\Temp\
Photoshop scratch has async I/O enabled
Scratch volume(s):
C:\, 931.4G, 408.1G free
Required Plug-ins folder: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Required\
Primary Plug-ins folder: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Plug-ins\
Additional Plug-ins folder: not set

Installed components:
A3DLIBS.dll A3DLIB Dynamic Link Library
ACE.dll ACE 2012/06/05-15:16:32 66.507768 66.507768
adbeape.dll Adobe APE 2012/01/25-10:04:55 66.1025012 66.1025012
AdobeLinguistic.dll Adobe Linguisitc Library 6.0.0
AdobeOwl.dll Adobe Owl 2012/06/26-12:17:19 4.0.95 66.510504
AdobePDFL.dll PDFL 2011/12/12-16:12:37 66.419471 66.419471
AdobePIP.dll Adobe Product Improvement Program
AdobeXMP.dll Adobe XMP Core 2012/02/06-14:56:27 66.145661 66.145661
AdobeXMPFiles.dll Adobe XMP Files 2012/02/06-14:56:27 66.145661 66.145661
AdobeXMPScript.dll Adobe XMP Script 2012/02/06-14:56:27 66.145661 66.145661
adobe_caps.dll Adobe CAPS 6,0,29,0
AGM.dll AGM 2012/06/05-15:16:32 66.507768 66.507768
ahclient.dll AdobeHelp Dynamic Link Library 1,7,0,56
aif_core.dll AIF 3.0 62.490293
aif_ocl.dll AIF 3.0 62.490293
aif_ogl.dll AIF 3.0 62.490293
amtlib.dll AMTLib (64 Bit) (BuildVersion: 6.0; BuildDate: Mon Jan 16 2012 18:00:00) 1.000000
ARE.dll ARE 2012/06/05-15:16:32 66.507768 66.507768
AXE8SharedExpat.dll AXE8SharedExpat 2011/12/16-15:10:49 66.26830 66.26830
AXEDOMCore.dll AXEDOMCore 2011/12/16-15:10:49 66.26830 66.26830
Bib.dll BIB 2012/06/05-15:16:32 66.507768 66.507768
BIBUtils.dll BIBUtils 2012/06/05-15:16:32 66.507768 66.507768
boost_date_time.dll DVA Product 6.0.0
boost_signals.dll DVA Product 6.0.0
boost_system.dll DVA Product 6.0.0
boost_threads.dll DVA Product 6.0.0
cg.dll NVIDIA Cg Runtime 3.0.00007
cgGL.dll NVIDIA Cg Runtime 3.0.00007
CIT.dll Adobe CIT
CoolType.dll CoolType 2012/06/05-15:16:32 66.507768 66.507768
data_flow.dll AIF 3.0 62.490293
dvaaudiodevice.dll DVA Product 6.0.0
dvacore.dll DVA Product 6.0.0
dvamarshal.dll DVA Product 6.0.0
dvamediatypes.dll DVA Product 6.0.0
dvaplayer.dll DVA Product 6.0.0
dvatransport.dll DVA Product 6.0.0
dvaunittesting.dll DVA Product 6.0.0
dynamiclink.dll DVA Product 6.0.0
ExtendScript.dll ExtendScript 2011/12/14-15:08:46 66.490082 66.490082
FileInfo.dll Adobe XMP FileInfo 2012/01/17-15:11:19 66.145433 66.145433
filter_graph.dll AIF 3.0 62.490293
hydra_filters.dll AIF 3.0 62.490293
icucnv40.dll International Components for Unicode 2011/11/15-16:30:22 Build gtlib_3.0.16615
icudt40.dll International Components for Unicode 2011/11/15-16:30:22 Build gtlib_3.0.16615
image_compiler.dll AIF 3.0 62.490293
image_flow.dll AIF 3.0 62.490293
image_runtime.dll AIF 3.0 62.490293
JP2KLib.dll JP2KLib 2011/12/12-16:12:37 66.236923 66.236923
libifcoremd.dll Intel(r) Visual Fortran Compiler 10.0 (Update A)
libmmd.dll Intel(r) C Compiler, Intel(r) C++ Compiler, Intel(r) Fortran Compiler 10.0
LogSession.dll LogSession
mediacoreif.dll DVA Product 6.0.0
MPS.dll MPS 2012/02/03-10:33:13 66.495174 66.495174
msvcm80.dll Microsoft® Visual Studio® 2005 8.00.50727.6195
msvcm90.dll Microsoft® Visual Studio® 2008 9.00.30729.1
msvcp100.dll Microsoft® Visual Studio® 2010 10.00.40219.1
msvcp80.dll Microsoft® Visual Studio® 2005 8.00.50727.6195
msvcp90.dll Microsoft® Visual Studio® 2008 9.00.30729.1
msvcr100.dll Microsoft® Visual Studio® 2010 10.00.40219.1
msvcr80.dll Microsoft® Visual Studio® 2005 8.00.50727.6195
msvcr90.dll Microsoft® Visual Studio® 2008 9.00.30729.1
pdfsettings.dll Adobe PDFSettings 1.04
Photoshop.dll Adobe Photoshop CS6 CS6
Plugin.dll Adobe Photoshop CS6 CS6
PlugPlug.dll Adobe(R) CSXS PlugPlug Standard Dll (64 bit)
PSArt.dll Adobe Photoshop CS6 CS6
PSViews.dll Adobe Photoshop CS6 CS6
SCCore.dll ScCore 2011/12/14-15:08:46 66.490082 66.490082
ScriptUIFlex.dll ScriptUIFlex 2011/12/14-15:08:46 66.490082 66.490082
tbb.dll Intel(R) Threading Building Blocks for Windows 3, 0, 2010, 0406
tbbmalloc.dll Intel(R) Threading Building Blocks for Windows 3, 0, 2010, 0406
TfFontMgr.dll FontMgr
TfKernel.dll Kernel
TFKGEOM.dll Kernel Geom
TFUGEOM.dll Adobe, UGeom©
updaternotifications.dll Adobe Updater Notifications Library (BuildVersion: 1.0; BuildDate: BUILDDATETIME)
WRServices.dll WRServices Friday January 27 2012 13:22:12 Build 0.17112 0.17112
wu3d.dll U3D Writer

Required plug-ins:

Accented Edges 13.0
Adaptive Wide Angle 13.0
ADM 3.11x01
Angled Strokes 13.0
Average 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Bas Relief 13.0
BMP 13.0
Camera Raw 7.3
Chalk & Charcoal 13.0
Charcoal 13.0
Chrome 13.0
Cineon 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Clouds 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Collada 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Color Halftone 13.0
Colored Pencil 13.0
CompuServe GIF 13.0
Conté Crayon 13.0
Craquelure 13.0
Crop and Straighten Photos 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Crop and Straighten Photos Filter 13.0
Crosshatch 13.0
Crystallize 13.0
Cutout 13.0
Dark Strokes 13.0
De-Interlace 13.0
Difference Clouds 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Diffuse Glow 13.0
Displace 13.0
Dry Brush 13.0
Eazel Acquire 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Embed Watermark 4.0
Extrude 13.0
FastCore Routines 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Fibers 13.0
Film Grain 13.0
Filter Gallery 13.0
Fresco 13.0
Glass 13.0
Glowing Edges 13.0
Grain 13.0
Graphic Pen 13.0
Halftone Pattern 13.0
HDRMergeUI 13.0
IFF Format 13.0
Ink Outlines 13.0
JPEG 2000 13.0
Lens Blur 13.0
Lens Correction 13.0
Lens Flare 13.0
Liquify 13.0
Matlab Operation 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Measurement Core 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Mezzotint 13.0
MMXCore Routines 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Mosaic Tiles 13.0
Multiprocessor Support 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Neon Glow 13.0
Note Paper 13.0
NTSC Colors 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Ocean Ripple 13.0
Oil Paint 13.0
OpenEXR 13.0
Paint Daubs 13.0
Palette Knife 13.0
Patchwork 13.0
Paths to Illustrator 13.0
PCX 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Photocopy 13.0
Photoshop 3D Engine 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Picture Package Filter 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Pinch 13.0
Pixar 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Plaster 13.0
Plastic Wrap 13.0
PNG 13.0
Pointillize 13.0
Polar Coordinates 13.0
Portable Bit Map 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Poster Edges 13.0
Radial Blur 13.0
Radiance 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Read Watermark 4.0
Reticulation 13.0
Ripple 13.0
Rough Pastels 13.0
Save for Web 13.0
ScriptingSupport 13.0.1
Shear 13.0
Smart Blur 13.0
Smudge Stick 13.0
Solarize 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Spatter 13.0
Spherize 13.0
Sponge 13.0
Sprayed Strokes 13.0
Stained Glass 13.0
Stamp 13.0
Sumi-e 13.0
Targa 13.0
Texturizer 13.0
Tiles 13.0
Torn Edges 13.0
Twirl 13.0
Underpainting 13.0
Vanishing Point 13.0
Variations 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Water Paper 13.0
Watercolor 13.0
Wave 13.0
WIA Support 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
Wind 13.0
Wireless Bitmap 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00)
ZigZag 13.0

Optional and third party plug-ins: NONE

Plug-ins that failed to load: NONE
Mini Bridge
Installed TWAIN devices: NONE
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15868 Posts
  • 2460 Reply Likes
Hmm. There's nothing crazy sticking out there. PS is up-to-date and it looks like your driver is good.

Try these steps to fix most issues:

I'd try starting in Safe Mode to see if there's some utility conflicting.
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
When I start it in Safe Mode, am I opening the program and creating a file to see if it does the same thing?
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
The two programs I am running in the background at all times are Ad-Aware and Avast Free AntiVirus. I tend to open my browser while Photoshopping, and I sometimes have World of Warcraft running. I have never noticed a difference between when I have other programs on, and when I do not. It seems to shut off on me just about every time I work on a file, regardless.
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
Ok, an update here:

I did a Bridge update--I don't usually use the big Bridge, just the Mini-Bridge, so I hadn't thought to check for updates on that--and I restarted the computer and when I went into CS6, Bridge wouldn't open for me. So I said, to myself, "well, just for s&g let's try this and see what happens." I opened a file, worked on it, no problems at all while working and no shut down when saving. I did this with 3 files in that same session and it didn't shut down on me. Coincidence? Maybe. But then last night, I clicked to open mini-bridge and it worked, somehow, and then when I clicked to save my file, GUESS WHAT? Yep, Photoshop gone from my screen, everything lost except my first three steps. This happened THREE TIMES in a row! I could put that layout together in my sleep, I've done it so many times now, lol.

So does this raise any red flags to any of you?

Thanks for all your advice. :)
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 848 Reply Likes
Sounds like it is definitely related to MiniBridge. That means that something related to the communication, or the rendering of the Flash Panel is bad. But neither of them directly affect the save dialog AFAIK.

Reinstalling (then reupdating) might work.
Or you could work without minibridge and use the Bridge application directly.
Photo of Heather Haigh

Heather Haigh

  • 21 Posts
  • 0 Reply Likes
So just an update. I MAY have figured out what the problem is, but only time will tell. I had previously used the beta, which worked great on my system. Then I bought and installed CS5.5, and got the upgrade to CS6, which I then installed without getting rid of CS5.5, with the mindset that it was an upgrade, rather than a standalone program. So when I restored my whole machine this weekend to try and fix the problem, I realized that I didn't need to install CS5.5 first, I could just install my CS6 "upgrade" and that would be that. So far, whether that was the problem, or it was something else, it appears to be working. But we shall see. I have yet to use Bridge or Mini-Bridge yet, because I'm so afraid of losing work. I'll get brave soon and try it.

Anyway, I just wanted to let you all know, in case you were losing sleep over my issue. :)