Photoshop: CS6 saves in wrong file format on MacOS when trying to load obsolete plugins

  • 27
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
bug in Photoshop CS6:

File save dialogue doesn't show any default filetype (not sure if it is meant to in CS6, but this is different from what I see in CS5).

When trying to save as JPG, I actually get Dicom

When trying to save as Dicom (out of curiousity), the program tries to save as GIF.

I started by opening a JPG. Opened in CS6 and used iris/field blur, curve layer, smart sharpen, and Viveza plugin. Hit save, closed the file. Then realized I'd caused it to save as layered TIF. Did a quick open and accidently selected CS5 (CS6 still running). Opened in CS6, and when I tried to save found this bug.

My computer had shutdown earlier tonight for some reason I can't explain (is on UPS, so not a brownout), so computer has been running with a proper reboot and may be in some strange state.

I'm running beta dated March 5th. Build 415 if I'm interpreting the shorthand correctly.
Photo of Greg Benz

Greg Benz

  • 48 Posts
  • 10 Reply Likes

Posted 6 years ago

  • 27
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 766 Reply Likes
Official Response
Not a bug, but user error.

As noted on the CS6 forums, in several similar topics, this is caused by you trying to load plugins from an older version of Photoshop in CS6.

Go delete the plugins you copied, or turn off the additional plugins folder preference that you mistakenly set to an older version of Photoshop.

Once you get rid of the duplicated plugins from an older copy of Photoshop, the save menu will work just fine.