Photoshop CS6 | Alt+Backspace issue on some keyboard localizations

  • 1
  • Question
  • Updated 6 years ago
  • Answered
  • (Edited)
Hi all,

Currently when I hit Left Alt + Backspace I fill the layer with foreground color.

It will be really good If I can do the same when hitting Right Alt + Backspace.

Anyone knows how to set that ?

Thanks!

SK
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
  • confused

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Photoshop treats both alt keys equally.

If one of them is not working as expected, then most likely it is being used by some other application or utility. (that, or you have one messed up keyboard :-)
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
Hi Chris,

Yes, I was thinking that the problem is in my keyboard. But just bought new keyboard and the things are the same :)

Initially I didn't mess up with any keyboard adjustments in Windows (I'm with Windows 7 x64), also didn't assigned any special keys or something ....

Do you know how I can "reset" my keyboard settings or something?

SK
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
No, I don't. But I bet you still have another application or utility that treats the right alt differently.
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
I found the problem !

Keyboard Layout have to be US.



SK
Photo of David

David, Official Rep

  • 2790 Posts
  • 387 Reply Likes
Actually, the problem is that most Eastern European keyboard layouts have the standard ALT key (the left one) but treat the right one as ALTGr. That key is used to access additional characters such as đĐłŁ in Czech or äÄíß in Hungarian. This isn't a Photoshop issue, but rather an issue with the way non-English keyboards are mapped; you will see similar behavior in other applications as well.

I hope this helps,
David