Photoshop CS6: PDF text grayed out or missing in Acrobat

  • 6
  • Problem
  • Updated 5 years ago
  • (Edited)
Photoshop CS6 64bit (Creative Cloud) .pdfs are not displaying correctly for me in Acrobat Reader or Acrobat Pro since the last update to Photoshop! The .pdf will display in Photoshop perfectly, but not in Acrobat or other PDF readers. For me, some text is greyed out and some is completely missing. I have tested saving as pdf from Photoshop CS6 with files that WERE saving as pdf with no problem, but even these no longer display correctly. Any assistance would be greatly appreciated.
Photo of Tony Barnett

Tony Barnett

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 6
Photo of Scott Schaller

Scott Schaller

  • 4 Posts
  • 0 Reply Likes
forum describes it perfectly:
http://forums.adobe.com/message/50509...

Basically any save to pdf that has more than 6 lines of text causes the pdf to not export all the text. See below transcript also:

Sumitra: As I understand you are unable to export the text file to PDF from Photoshop, Is that correct?
Soctt: only if it is in a text box and is more that 6 lines. Did you see the forum thread I posted?
Sumitra: Thank you for confirming.
Sumitra: Yes I saw.
Sumitra: I will be glad to check and help you with this.
Soctt: Is this something Adobe is aware of and fixing?
Sumitra: May I know if you are getting any error message?
Soctt: no
Soctt: I have a macbook pro retina on mountain lion at home with CS6 and at work I have a 27"iMac with CS6 and both machines do this
Soctt: the iMac has lion
Sumitra: Okay
Sumitra: Could you please walk me through the steps you are performing to export the files?
Soctt: I go File--Save As--Photoshop PDF and then it doesn't matter what settings, I've tried lots of different configurations. They all do it.
Sumitra: Okay
Sumitra: Would you mind waiting for 2 - 3 minutes while I research on this issue?
Soctt: sure
Soctt: take your time
Sumitra: Thank you for your patience.
Soctt: no problem
Sumitra: Are you unable to see the text other than 6 lines in PDF?
Soctt: Can you open that link I sent?
Sumitra: No, we do not have the option to check the link you have sent
Soctt: Some of the text comes through accurate. Some comes through just white (not the right color). Some comes through just outlines. And some doesn't come through at all.
Soctt: I can grab the text tool and highlight any of the different variations except the stuff that doesn't come through obviously.
Sumitra: Okay
Soctt: All other text comes through perfect by the way. Just not what is in that box that has more than 6 lines.
Sumitra: May I know if you have installed the updates for Photoshop CS6?
Soctt: Yes
Soctt: I read on that forum post if you do a fresh install and don't update it doesn't do this.
Soctt: I have not personally tried that though as I don't want to do a fresh install.
Sumitra: Just to confirm, are you facing this issue after updating Photoshop?
Soctt: I only found out of its exsit
Soctt: I only found out of its exsititance after I had already done all updates
Soctt: I didn't know about it beforehand
Soctt: So yes. After all updates
Sumitra: Okay
Sumitra: We will try to reset the Preferences and check if it works.
Sumitra: Please close all the Adobe Applications
Soctt: Will this reset preferances for all adobe products or just PS?
Sumitra: It is just for Photoshop
Soctt: ok
Sumitra: Open Mac Finder
Soctt: Still closing. Hang on a second.
Sumitra: Sure
Soctt: You can go ahead and keep sending instructions if you want
Sumitra: Open Mac Finder
Sumitra: Click on Go > Go to folder
Sumitra: Type in ~/Library and click on Go.
Sumitra: You will get Library folder open.
Sumitra: Then open Preferences folder.
Soctt: ok
Sumitra: Search for the folder in name Adobe Photoshop CS6 Settings folder.
Sumitra: Let me know if you find it.
Soctt: ok
Soctt: got it
Sumitra: Please delete the folder
Soctt: the whole ps settings folder?
Sumitra: Yes
Soctt: ok
Soctt: done
Sumitra: Please launch Photoshop now, export a PDF file with more than 6 lines and check if it working
Sumitra: *it is
Soctt: ok
Soctt: nope
Soctt: didn't work. still getting the same problem
Sumitra: Okay
Sumitra: May I know if you are using any third party plug-ins or Fonts?
Soctt: no
Soctt: it seems like from the other users on the forums that a bug is introduced in one of the updates. If they do a clean install and don't update then they don't have this problem
Sumitra: Okay.
Sumitra: Please allow me 2 minutes.
Soctt: ok
Soctt: You can always do a convert text to shape and it will come though. But I mainly want to know if this bug is on the radar to be fixed.
Sumitra: May I know the format of the file you are using?
Soctt: what do you mean?
Soctt: psd
Soctt: to pdf
Sumitra: Please try with any other file format and check if it works.
Soctt: you mean like export to jpeg or something?
Sumitra: Yes,
Soctt: came out perfect
Sumitra: Try with the different psd file and check.
Soctt: I've actually had this problem with two totally differant files on two differant machines
Soctt: one was a large book cover and this current one is a flyer
Sumitra: Okay.
Sumitra: Can you just give a try with different PSD file?
Soctt: yes
Soctt: just did, same problem.
Sumitra: Okay
Sumitra: Launch Photoshop
Soctt: I actually tried it two ways, one with the text in a text box. the other with the text just where you click and start typing (Not draw a box) both ways messed up.
Sumitra: Okay
Sumitra: Please launch Photoshop.
Soctt: ok
Sumitra: Click on Photoshop CS6 menu > Preferences
Sumitra: Then click on Performance
Soctt: ok
Soctt: im there
Sumitra: You will see a check box named Use Graphics Processor
Sumitra: Let me know if that option is checked or unchecked
Soctt: That is checked.
Sumitra: Please uncheck that option
Sumitra: Click on Ok
Sumitra: Re-launch Photoshop
Sumitra: Try to export a Psd file now, let me know if it works
Soctt: exporting now
Soctt: didn't help
Sumitra: Okay
Soctt: got the same thing
Sumitra: Okay
Sumitra: May I know the Save as Pdf Settings you are using when you save the file?
Soctt: As I said before I tried lots of different settings. Right now I am using the default Press Quality setting
Soctt: The default Smallest File Size does it too.
Sumitra: Okay
Sumitra: In this case, you will have to un-install and re-install the product once.
Soctt: and never update?
Sumitra: After re-install, please try to export and check if it is working
Sumitra: If you still face the same issue, you can install the updates and check
Sumitra: I will leave this case open for your convenience.
Sumitra: If need further help you can contact us back, we will be glad to help you.
Soctt: So I need to do this on my two seperate machines?
Sumitra: Are you facing the same issues on your 2 machines ?
Soctt: Yes, exactly.
Soctt: As with the whole list of people on the forum post
Sumitra: Then you will have to do the same for 2 machines
Soctt: I am sure it will work fine after reinstall and the stop working after I update, just as all the other people on the forum have said. What I want to know is will this bug be forwarded onto the development team to be fixed?
Sumitra: Yes, you can also report the bug on feedback.photoshop.com
Soctt: Okay. So you are reporting it from you end then?
Sumitra: Yes, I will
Soctt: okay. thanks for your help
Sumitra: You are mostw elcome.
Sumitra: *most welcome.
Sumitra: Is there anything else I can help you with?
Soctt: no that's all
Soctt: thanks
Sumitra: Have a nice day.
Sumitra: Thank you for contacting Adobe. Good Bye.

This reply was created from a merged topic originally titled
Photoshop CS6 PDF Corrupts text..
Photo of Scott Schaller

Scott Schaller

  • 4 Posts
  • 0 Reply Likes
Still can't believe this hasn't been addressed.
Photo of Mark Davidson

Mark Davidson

  • 4 Posts
  • 0 Reply Likes
OK, I have the same problem. When will it be fixed?
Photo of Philip Hargreaves

Philip Hargreaves

  • 2 Posts
  • 0 Reply Likes
I'm getting the same problem with every psd I export to PDF. Thought it was an issue with different styles in a text layer. Putting each portion in it's own layer seemed to fix it until tonight and now a layer with all the same style doesn't save as pdf. Guess what it's more than six lines. I'll split into two layers and try again.
Photo of Philip Hargreaves

Philip Hargreaves

  • 2 Posts
  • 0 Reply Likes
It worked! Poor show by Adobe though :-(
Photo of Kevin Riley

Kevin Riley

  • 2 Posts
  • 0 Reply Likes
Unbelievable... This is a huge pain in the arse! What's even more frustrating, is the "customer service" offered by adobe. I started having flashbacks of my last customer service call with adobe while reading Scott's transcript.

I just found out about this issue after delivering 23 design files to a client (all missing lines of text). My bad for not double checking the files before delivery.

Adobe should be able to stay on top of these bugs with all the money they are "saving" by exporting their customer service.
Photo of Kevin Riley

Kevin Riley

  • 2 Posts
  • 0 Reply Likes
For anyone who is interested... I solved this issue by installing photoshop CC. I wasn't even aware that photoshop CC existed until I took a look at the available apps on the creative cloud. So far, I'm liking it better than photoshop CS6, which I still keep installed, as a backup option.

It's nearly identical with a few new features and has resolved the pdf display problem outlined on this page.

So, if you're already paying for it, you mind as well download it and check it out.
Photo of Matt Johnson

Matt Johnson

  • 1 Post
  • 0 Reply Likes
The description of this issue matches my own experience today although I use Photoshop CS4 and I do not have the Creative Clout update mentioned here (or any creative cloud software that I could find).