Photoshop: 13.0.1: No snap to pixel grid when Shift+Drag a shape

  • 3
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
Hi,

I'm experiencing the following issue.

1. "Snap Vector Tools and Transforms to Pixel Grid" is on
2. When I, creating a new shape (rectangle or ellipse etc ...) and hold SHIFT (to do a perfect square or circle) the shape I'm creating is not aligned to pixel grid as it should be.
3. I'm experiencing this issue after 13.0.1 update.
4. Check the video - http://screencast.com/t/kU8ErnkGp

Very frustrating issue.
Adobe please take this into consideration.

--------------------------
Photoshop cs6 x63, 13.0.1
Windows 7 x64
(ready to give full details if need)
--------------------------

SK
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
  • frustrated

Posted 8 years ago

  • 3
Photo of Mike Shaw

Mike Shaw, Employee

  • 93 Posts
  • 58 Reply Likes
Official Response
Until this is fixed, a work around is to use Quick Create to make the initial shape ( click once on the doc with the shape tool and enter equal width and height) Transforming the resulting shape will keep snap behavior.
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
Hi Mike,

Is this an issue you are going to fix with next updates?

Thanks!
SK
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
Hi,

Thanks Mike!

SK
Photo of Sean Boone

Sean Boone

  • 9 Posts
  • 1 Reply Like
Just noticed this issue today. Thanks Mike.
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
It is fixed in the new 13.0.1.1 Update!

Thanks Adobe!

SK
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 864 Reply Likes
Nope, 13.0.1.1 updates no code, just the code signing.
Photo of kckfm

kckfm

  • 35 Posts
  • 2 Reply Likes
Oh yes, just tested it again and same stuff.

Sorry all, it is not fixed really.

Waiting for it :)
Photo of Recep Kütük

Recep Kütük

  • 4 Posts
  • 0 Reply Likes
I have this issue this morning, yesterday everything was fine :(
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 864 Reply Likes
Unless you failed to install the updates, this issue was fixed over 2 years ago...
Photo of Recep Kütük

Recep Kütük

  • 4 Posts
  • 0 Reply Likes
When I check for updates it says "Your applications are all up-to-date as checked: less than a minute ago." But it is still not working properly :(
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 864 Reply Likes
Check the version number in the application (Help -> System Info gets the full version info).
Photo of Recep Kütük

Recep Kütük

  • 4 Posts
  • 0 Reply Likes
it says: Adobe Photoshop Version: 13.0.1 (13.0.1.3 20131024.r.34 2013/10/24:21:00:00) x64
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 864 Reply Likes
Then you already have the fix for this issue.
Photo of Recep Kütük

Recep Kütük

  • 4 Posts
  • 0 Reply Likes
But it is still not working properly :( It happened suddenly on last friday.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2918 Reply Likes
I don't see that you have a registered version of Photoshop.
Photo of Nokta Com

Nokta Com

  • 2 Posts
  • 0 Reply Likes
I have a registered version of Photoshop which is linked to this account and this is the Photoshop which has the problem.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2918 Reply Likes
That looks like an older version of Creative Suite register back in 2005.
Photo of Nokta Com

Nokta Com

  • 2 Posts
  • 0 Reply Likes
Nope, it is CS 6. If you need I can give you the order number, certificate id, end user id etc.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2918 Reply Likes
It just needs to be registered under your Adobe ID. It should automatically be registered with you Adobe ID when you first activate it.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2918 Reply Likes
Official Response
Fixed in CC (14.x) or later.