Photoshop CS5: Can't save to SMB network volume on MacOS 10.8

  • 7
  • Problem
  • Updated 4 years ago
  • (Edited)
Running Photoshop CS5, version 12.0.4. Just upgraded to Mountain Lion, and now I cannot save to network drives via smb connection. Photoshop gives you the error "Could not save as “filename.jpg” because of a program error. Other users are reporting this problem as well. Saving manually is not an option in my daily workflow. Other CS programs are not affected - appears to be isolated to Photoshop. Please fix!
Photo of tara.hoover

tara.hoover

  • 4 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 7
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
We are investigating the problem and filing another bug with Apple.

Until Apple can fix the SMB bugs, please save to the local disk or use a network protocol other than SMB.
Photo of Kimmo Tapala

Kimmo Tapala

  • 8 Posts
  • 0 Reply Likes
After upgrading to Mountain Lion (Mac OS X 10.8.) my Photoshop CS 5.5 can't save files to a mounted SMB or CIFS volume. All other CS 5.5 programs can save to these volumes. This problem exists in PS CS 5 as well.

This is a major showstopper for our company as every single PSD is always stored on a network volume. Please, fix this ASAP!!

Edit:
Found a workaround for this problem: disabling image previews in the file saving options fixes this.

This reply was created from a merged topic originally titled
PS CS 5-5.5 on Mountain Lion: can't save to a mounted network volume.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
We're still trying to document the problem, and we have no idea how long it'll take Apple to fix it.
Photo of tara.hoover

tara.hoover

  • 4 Posts
  • 0 Reply Likes
Kimmo - thank you SO MUCH for the workaround! I enjoyed the image previews, but not having them is a much better option than having to save locally then copy over. Hopefully this will be resolved soon in the first update. Thanks again!
Photo of Ryan Sweet

Ryan Sweet

  • 2 Posts
  • 0 Reply Likes
Thanks for the workaround. Disabling image previews allowed me to save my PSD file to our SMB server once, but after I edited the file and tried to re-save, the file was deleted off of the server and I had to save the file as if it was brand new.
Photo of Lesley Hoops

Lesley Hoops

  • 1 Post
  • 0 Reply Likes
This worked for my issue as well. PSD was saying that I do not have permission to save to the network drive when in reality I have full access to open and save. AI worked fine. PSD now works fine with previews turned off. Thank you!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
You may want to check out the solutions found in this thread: http://forums.adobe.com/thread/104112...
Photo of Kimmo Tapala

Kimmo Tapala

  • 8 Posts
  • 0 Reply Likes
It's created in the /etc/ directory. The easiest way to create the file is to use command line (Terminal.app) and run the following command:

sudo nano /etc/nsmb.conf

After this, you are presented with a warning message and prompted to give your password. Type your password and press enter. Copy and paste the relevant lines and hit Ctrl+o (save) followed by Ctrl+x (exit). Reboot and rejoice.

Please note that you have to be signed in as an administrator to be allowed to use sudo.
Photo of tara.hoover

tara.hoover

  • 4 Posts
  • 0 Reply Likes
Rejoicing!!! Thank you both!
Photo of Ryan Sweet

Ryan Sweet

  • 2 Posts
  • 0 Reply Likes
After I typed Ctrl+o, I couldn't type Ctrl+x. Instead I was prompted with 8 other menu options (see here: http://cl.ly/image/0c0Z032u3L03). Suggestions?
Photo of Kimmo Tapala

Kimmo Tapala

  • 8 Posts
  • 0 Reply Likes
Sorry, I guess you have to press enter after hitting Ctrl+o. It's just prompting for a file name and you can accept the (correct) suggestion by hitting enter.
Photo of Kimmo Tapala

Kimmo Tapala

  • 8 Posts
  • 0 Reply Likes
Just a heads-up:

Disabling named streams (that's what we're doing here) seemed to cause some weird behavior with our file server. Writing large files would often fail resulting in the files to be (seemingly) deleted from the network volume. This could be a bug in our file server software and we can't confirm if the files were actually deleted from the volume when the write operations failed.

Anyway, we decided to re-enable named streams and disable image previews as this workaround seems to work pretty flawlessly for us.
Photo of Derek Holiman

Derek Holiman

  • 4 Posts
  • 4 Reply Likes
Been following this issue since updating to OS X 10.8 Mountain Lion.

Photoshop CS5 and CS6. Both had the save error to the Windows server.

Updated to OS X 10.8.2 today. Preliminary usage seems to indicate it's working now.

Even turned image previews back to "always save."
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Apple thinks they fixed in 10.8.2, but we've been waiting for more testing before calling it fixed.
Photo of Derek Holiman

Derek Holiman

  • 4 Posts
  • 4 Reply Likes
Would love to know what Apple did in 10.8.2. I know 10.8.1 didn't help it.

I'm jumping through hoops now trying to get it to break, but it appears to be working fine. Multiple Macs, multiple files, all good.
Photo of Pete Green

Pete Green, Customer Advocate

  • 710 Posts
  • 134 Reply Likes
Great, thanks for that input Derek.
The fix for this was in their change logs, good to know it's working for you.
Photo of R Barratt

R Barratt

  • 3 Posts
  • 0 Reply Likes
I JUST upgraded to Photoshop CS6 and it takes 15-20 minutes to save on my networked drive. Brand new Macbook Pro running OS X 10.8.3.

CS5, on the same system had NO problems with this.

Any ideas?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14123 Posts
  • 1761 Reply Likes
Do you have Adobe Drive installed? If so, disable it.