Photoshop: CS4 - Marquee and zoom tool draw random boxes

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
Anyone else experiencing this bug in CS4 - when starting a new selection (Marquee Tool), random sized boxes will appear BEFORE dragging and releasing the mouse button to define a selection. The boxes will often extend from the first mouse click to an image edge, but it's unpredictable. I need to release the mouse button, deselect (left click), and then start over again. Once this behavior begins, it can recur repeatedly, making marquee selections VERY frustrating.

It also occurs with the zoom tool.

I ́m running Photoshop CS4 on a brand new Dell Latitude (integrated Intel graphics) on Windows 7. The CS4 is also a brand new installation. I ́ve tried a couple of different mice and also disabling Open GL. I had the same issue on other laptops I used over the years but not on all of them.

Actually there was a thread on this issue a while ago but it seems to be closed now and no satisfactory answer was provided. http://forums.adobe.com/thread/373520
Photo of Rob Goris

Rob Goris

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
We've seen that happen with bad video card drivers -- updating the drivers always fixed the problem.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
Try this:

Determine what video card you have and go directly to the manufacturers website (nVidia or ATI/AMD) and download the latest driver. GPU and OpenGL support | Photoshop CS4, CS5: http://adobe.ly/OpenGL
Photo of Rob Goris

Rob Goris

  • 2 Posts
  • 0 Reply Likes
Jeffrey, thanks for the suggestions but trust me, I have tried this already to no avail. Also, as this is my 3rd computer in two years, it ́s really not a problem with the video card (all 3 computers had different video cards). It ́s clearly a bug. Bugs can happen, I ́m just looking for a workaround. I installed a trial of CS6 and the issue does not occur there, but obviously I don ́t feel like shelling out the extra money just for one bug.

Also tried all possible permutations of the Enable GL settings in Preferences, there is no logic there either. The problem just comes at random and restarting PS is all you can do (and hope for the best). A real productivity killer.