photoshop CC tools not responding on Win 7

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
I'm using PS CC on Windows 7 with a Wacom tablet.

For a couple of days now, my tools have stopped responding at irregular intervals, whether I select with with a shortcut or from the toolbox, and their cursors are mixed up -- for instance, the Move tool displays a brush.

I found what looks like a similar problem for Macs in the forum, but not for Windows.

Help
Photo of helen sotiriadis

helen sotiriadis

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
The cursor mix up sounds like a video card driver issue.
Update your video card driver from the GPU maker's website (not Microsoft).
Photo of helen sotiriadis

helen sotiriadis

  • 2 Posts
  • 0 Reply Likes
My driver is up to date. it's not just a cursor mix up -- the tool functionality doesn't start, as in the Move tool won't move.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Did you update the driver from the GPU maker's website (AMD, NVidia, or Intel)? Something on your system is messing up the cursor updates, and the video card driver is the most likely suspect (plus we've seen similar driver bugs in the past).
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
But if the tools aren't actually changing, then something may be messing with event handling. That could be a wacom tablet driver, another driver, utility software, or any number of things on your system.