Photoshop CC: Lighting Effects Filter Not Working

  • 4
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
Adobe CC Filter:

When I go to Filter -> Render -> Lighting effects, I get the panel on the right with all the options, but nothing happens to the main image (which I guess is a preview). I move all the handles on all the options, but NOTHING happens.

And, when I try to "reset workspace" from this filter, NOTHING happens. The lighting effects panel doesn't go away, and my tools and layers etc don't come back. The Only way back is to restart PhotoShop.

What am I doing wrong?
Photo of Allan 101250953 - Main BP

Allan 101250953 - Main BP

  • 3 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 4
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Have you installed the 14.1.2 update?

What OS version are you using?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
I would suspect the video card driver being old/out of date. Please go directly to the card manufacturer's website to install the latest driver: http://blogs.adobe.com/crawlspace/201...
Photo of Allan 101250953 - Main BP

Allan 101250953 - Main BP

  • 3 Posts
  • 0 Reply Likes
OS 10.7.5 is running a MacPro 3GHz Dual-Core Intel Xeon with a NVIDIA GeForce 7300 GT - ROM Revision: 3011

Only 14.0 is installed and when we try to install it returns: Update Failed Updates could not be applied You are already running the Adobe Application Manager. Please close all instances of Adobe Application Manager before applying updates. If the problem persists, please contact Customer Support for further assistance. Where does the Application Manager Live? I thought the Application Manager automatically updated PhotoShop CC? How do we get 14.1.2 installed?
Photo of Allan 101250953 - Main BP

Allan 101250953 - Main BP

  • 3 Posts
  • 0 Reply Likes
Update - I was able to install 14.1.2...the Creative Cloud Application was uninstalled and reinstalled and PS CC successfully updated.

The Render/Lighting Effects filter is still, however, not functioning. Any ideas/recommendations?
Photo of Jenny D

Jenny D

  • 1 Post
  • 0 Reply Likes
I am using CC, complete with latest updates. Adobe - what is the solution to this post that is now 5 months old? i.e. "When I go to Filter -> Render -> Lighting effects, I get the panel on the right with all the options, but nothing happens to the main image (which I guess is a preview). I move all the handles on all the options, but NOTHING happens."
With no solution, Creative Cloud has lost lighting effects functionality completely.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 744 Reply Likes
There are 2 common problems like that: people who have hidden all the controls by accident (check View->Show), and people with outdated (and buggy) video card drivers.
Photo of Beth Rosengard

Beth Rosengard

  • 4 Posts
  • 0 Reply Likes
Thank you, Chris. Turning on Smart Guides in View-Show did it for me. The thing is, I don't remember having turned them off in the first place. In fact, I don't recall having gone to View-Show since installing PS CC.
Photo of Zorro Gamarnik

Zorro Gamarnik

  • 1 Post
  • 0 Reply Likes
THANKS CHRIS !!!!!!!!!
Photo of Marc Choquette

Marc Choquette

  • 1 Post
  • 1 Reply Like
I had the same problem, and selecting "View ----> Show ----> All" fixed it. I think at some point I wanted to turn off some grids and accidentally turned off something that made the light guides off.

Why they make a view option that can turn off the basic functionality of the Lighting and Blur effects is baffling.

Thanks you for those who contributed to this thread and helped.
Photo of Richard Garner

Richard Garner

  • 2 Posts
  • 0 Reply Likes
THANKS!!
The < VIEW > -- < show all > tabs did the trick.

That was a hard-to-solve problem if you don't know where to look.
I guess that's life in the world of PS. :)
Photo of Kortni

Kortni

  • 2 Posts
  • 0 Reply Likes
I too am having trouble. When I go to the lighting effects, it is grayed out and I cannot use it. My photo is RGB/ 8-bit and flattened with no layers or masking. Cannot figure out how to get that option to be available! Any advice??
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13917 Posts
  • 1649 Reply Likes
You need 512MB of dedicated VRAM, a compatible video card and up-to-date driver for Lighting Effects to work.
Photo of Kortni

Kortni

  • 2 Posts
  • 0 Reply Likes
thanks
Photo of Zhan Shi

Zhan Shi

  • 1 Post
  • 0 Reply Likes
I'm having similar issue. I'm using CS6. The panel and preview works perfect but after I hitting OK nothing really happens to the image. Both regular and smart filter are not working. It's my first time trying applying lighting on this laptop though. I've used it on another one before. Any ideas please?
Photo of Evan Tran

Evan Tran

  • 1 Post
  • 0 Reply Likes
It's also a problem here where I click on lightning effects, panel on the right side shows, but the top panel (where you would normally find "presets" such as blue omni, and the light bulb" remain unchanged. Is there a reason for that?
Photo of Judith Brown

Judith Brown

  • 3 Posts
  • 0 Reply Likes
I haven't been able to get this effect since I "upgraded" and PAID for CC. Running windows 7 and have an expensive (Sapphire Radeon HD 5770 1GB DDR.) recently upgraded driver with 1 GB of vRAM. I get a CC error that I have less than 512 MB. This &*())&) CC version of PS is an expensive piece of &*)&)).
Very angry at not being able to get this lighting.
Photo of Judith Brown

Judith Brown

  • 3 Posts
  • 0 Reply Likes
This problem had a strange solution. My driver had been updated as I said above. But solution was to RESET PREFERENCES for any of you who might be suffering from the same problem. Wierd!!! But it works. Thank you Adobe support whom I finally called.
Photo of Joost Bert

Joost Bert

  • 2 Posts
  • 0 Reply Likes
How do you reset the preferences? I seam to have the same problem...
Photo of Joost Bert

Joost Bert

  • 2 Posts
  • 0 Reply Likes
Nevermind, I found it, and it did the trick for me too!
Thanks!
Photo of Judith Brown

Judith Brown

  • 3 Posts
  • 0 Reply Likes
Great!   It's an Adobe miracle.   But I often have to reboot the computer  to get it to keep working.
Photo of win collection

win collection

  • 1 Post
  • 0 Reply Likes
When i select lighting effect.. all tools and windows disappear and this is h ow it looks...
I have tried < VIEW > -- < show all > but im getting the same result 
if anyone knows how to fix it plx reply ASAP.
Thanks in advance 
Photo of Gevorg Nazeyan

Gevorg Nazeyan

  • 1 Post
  • 0 Reply Likes
I have the same probleme. But when I using WIndows 8.1 lightning effects working but in Windows 7 not.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13949 Posts
  • 1658 Reply Likes
Update your graphics card/driver on the Windows 7 machine: https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html