Photoshop CC: PDF Smart objects still render badly (with jags) when transformed

  • 3
  • Problem
  • Updated 1 year ago
Here's the original post: http://feedback.photoshop.com/photosh...

I'm having a similar problem, but I'm in Photoshop CC, and that other problem is marked as solved.

This looks like a less severe problem that may or may not be related.

In Illustrator CC, I have a PDF open with a simple black rounded rectangle, in this case with text and other shapes inside of it (but the text doesn't seem to be part of the problem). There is no background, the rounded rectangle is the outermost-outline of the vector image.

I copy these shapes and paste them into Photoshop CC. I'm prompted to choose Smart Object, Pixels, etc. After choosing, I'm allowed to transform before applying the import.

If I choose Smart Object or Pixels and rotate the object, I get the same jagged result, with aliased edges surrounding the rounded rectangle.

Shape Layer works properly in terms of aliasing. Attached is a comparison image. Left is the problematic Smart Object, and right is the shape that looks correct.

If you bring my example image into Photoshop and superimpose the two, you'll more clearly see the difference in the aliasing.



Edit: hopefully get satisfaction doesn't shrink my sample image down this time.
Photo of Tim K

Tim K

  • 9 Posts
  • 0 Reply Likes
  • sad

Posted 5 years ago

  • 3
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
The bug that was fixed involved images in EPS or PDF content.
That just looks like you have antialiasing turned off for that smart object.
Photo of Tim K

Tim K

  • 9 Posts
  • 0 Reply Likes
Anti-aliasing is on for that smart object. When it's off, the white text is unreadable. I'm only noticing slight aliasing around the edges of the object.

If I get in close, there are some gray pixels there surrounding the smart object. It's definitely getting anti-aliased, just not as well as I'd expect.

Could this be a strange interpolation artifact? It seems like the default interpolation method is Bicubic Sharper with shrunken Smart Objects. But I don't know for sure because there's no way to see/modify this interpolation when transforming smart objects.
Photo of Dave Gregurke

Dave Gregurke

  • 1 Post
  • 1 Reply Like
Hey all,

I know this is an old thread, but this is definitely still happening in CC 2015.

The Smart Object rendering in general seems ok, then if you paste a Vector Smart Object you have to additionally "Save as Smart Object" in order to free or warp distort.

The jagged rendering seems to kick in on quite distorted angles but not to minor distortions.

Chris I see you've been on a few threads on various sites about this, I've tested anti-aliasing (which is greyed out anyway) and screwed around with the interpolation settings both Bilinear, Bicubic variations, not seeing a difference.

Example is creating cube with 3 visible sides. Each side is a smart object so it can be updated. Overlaying the front and right side of the cube the angle isn't too acute, things are going well and the rendering is smooth and anti-aliased. But the top side is more acute where you can only see a little slice of the image, and this is where it gets jagged. It essentially renders correctly just without anti-aliasing. 

My only conclusion is there appears to be a threshold for what it is able to render with anti-aliasing. 

Not a spec issue surely @ 32GB RAM, 4GHz i7?

I can start a new thread/create a comparison PSD to highlight the results if you need...?
(Edited)
Photo of Lorenzo Orlandi

Lorenzo Orlandi

  • 1 Post
  • 0 Reply Likes
I was about to start a new thread, but this is the exact same problem...

While googling I've found many instances of this problem, which has existed for years. but sadly no solution.
This is clearly a bug and it should be fixed... 

I can provide context and examples for my case (Photoshop CC 2015) if needed!
Thanks to anybody looking into this :/
(Edited)
Photo of Olivier Heckendorn

Olivier Heckendorn

  • 11 Posts
  • 0 Reply Likes
Still having problem
I posted a descrption here as well

 https://feedback.photoshop.com/photoshop_family/topics/smart_objects_render_badly_with_jags_when_bei...


Here is a screenshot the problem looks quite obvious
Photo of Olivier Heckendorn

Olivier Heckendorn

  • 11 Posts
  • 0 Reply Likes
I made some more test :

- Create an image 2500 px high

- Write some text/ rasterize (it easier to spot on text)

- create a smart obect with the rasterized text layer

- Transform the smart object 

- duplicate the smart object and rasterized the duplicate

- You have to identical layer one smart object the othe rasterize

 

THEN resize 33% both in one step and compare ... you should have the same result and it is not the case...

PS : Resize parameter in the general parameter and the in the resize windows are identical 

Here are the result seen at 100% ZOOM 

The original TIF before resize is here https://drive.google.com/file/d/0B77cs7YZMbxcMGttU2k5b250WXc/view?usp=sharing

I am on MacOs photoshop CC2017 last version - tested on cc2015,5 with identical result



(Edited)
Photo of eartho

eartho

  • 864 Posts
  • 242 Reply Likes
A big part of what you're seeing is that the SO is using the interpolation set in General Prefs and the raster layer is using the Image Size interp. Makes little sense, but that's how it's been programmed for whatever reason...
Photo of eartho

eartho

  • 864 Posts
  • 242 Reply Likes
But even when you set both to be the same interpolation, they still render differently in a way that can't be explained. I get the same results as above when set to Bicubic Smoother in both pref and image size...
(Edited)
Photo of Olivier Heckendorn

Olivier Heckendorn

  • 11 Posts
  • 0 Reply Likes
Thanks for testing as i said in my post i was awware of the setting and 
Resize parameter in the general parameter and the in the resize windows are identical 
Hence we both agree there is a problem and the result is ugly. Are you working on Mac or PC

Morover when you do web design and use the "export as" if you do resize at this stop you get the same result because resizing is applyed before the raster in the export workflow. If you use the legacy "save for the web" this does not happen beacause the resize take place after the raster in the workflow

This is ver very enoying because it crippled all the Web design workflow using smart object.
Photo of eartho

eartho

  • 864 Posts
  • 242 Reply Likes
I'm on a mac and i generally don't use Export As since it's an unusable and incredibly slow mess which was never finished.
Photo of Olivier Heckendorn

Olivier Heckendorn

  • 11 Posts
  • 0 Reply Likes
Yep the same here but i came across that problem when trying to use the artboard and the export as. 

But now it is a real issue when placing smart object. If the resize is not accurate you can't rely on smart object aswell.
I have donne a very big projet with all sort of embed of smart object and if the result is actually worse than if using raster it's a very bad news for me.

You also got bad result just resizing by using the transform tools on a smart object and this is just not acceptable