Photoshop CC: Paste path automatically creates Vector Mask.

  • 5
  • Problem
  • Updated 7 months ago
  • (Edited)
There were some changes introduced to Path operations in Photoshop CC.

1. Pasting Path automatically adds a Vector Mask to a selected layer. The work around is to create new Path, then paste. But, is there a way to paste Path without the auto Vector Mask Creation?

2. Once the Feather Radius and Anti-alias in Make Selection dialog box is set, It will always ad the same values to selections made out of the same OR any new Path. This is different from previous versions and it does present issues.

Is there anyway a preference can be set for these two occurrences?

Thanks
Photo of Roman_the_Finisher

Roman_the_Finisher

  • 30 Posts
  • 0 Reply Likes
  • excited to see what Adobe rep says.

Posted 4 years ago

  • 5
Photo of Don van der Zaan

Don van der Zaan

  • 1 Post
  • 1 Reply Like
I have the same question about pasting paths into Photoshop. Is there a way to turn this of? I regularly want to paste paths as smart objects but this seems impossible now
Photo of Sasha Agapov

Sasha Agapov

  • 1 Post
  • 1 Reply Like
This is very very frustrating.
Photo of steveflydeals

steveflydeals

  • 1 Post
  • 0 Reply Likes
try cntr+shift+alt when starting photoshop
Photo of lora cawkins

lora cawkins

  • 4 Posts
  • 1 Reply Like
I've been using PS for 25 years now and the vector mask automatic is very frustrating. If PS gives you the option to paste as a path then it should do just that and NOT a layered mask. That being said, the work around is to deselect all the layers and whatever you want as a path will come in as such whether it's PS to PS or IL to PS.  

In regards to 2. when you set a feather radius / anti-alias in the Make Selection dialog box the only way to change this is to go back into the dialog box and remove. This has been consistent with every PS version that I've used. Hope this helps. 
Photo of Glen Gilmore

Glen Gilmore

  • 1 Post
  • 0 Reply Likes
Hello,
My Intern was recently experiencing the exact same problem which forced me to try and remember how to remedy this situation.  I thought a simple google search would jog my memory but I see the fix is still not posted.  So I thought I'd offer up how to get this to work.

I think the setting actually isn't in Photoshop it's in Illustrator.  I know it seems counter intuitive but give this a try.  It seems to have worked for me.  I will also add that I'm on a 64bit Windows 10 machine running Adobe CC.  

Edit>Preferences>File Handeling & Clipboard

Go down to the clipboard section and checkmark the AICB box, then select the preserve paths button.  Click ok at the bottom. 

Relaunch your PS and AI and try to copy a path out of Illustrator ctrl+c and paste  ctrl+v it into a PS document there should be a dialogue box in PS that asks what you want to paste as.... choose path.    

For me the path is then put onto a path layer as a work path.

I hope this helps.

If not... delete this post.  
Photo of lora cawkins

lora cawkins

  • 4 Posts
  • 1 Reply Like
Funny part about this whole mess is I have never had a problem with this until the Cloud versions. Really do not like it when the developers seem to assume what the customer is going to want without actually asking them. 

Your suggestion is interesting, but the ultimate decision should be instead of messing with the prefs, is simply to not have any layer selected, then paste the path. Changing prefs could mess something else up instead of solving the problem. We are looking for a vector path and not a path layer. By not having any layer selected this can be accomplished.
Photo of Michael

Michael

  • 1 Post
  • 0 Reply Likes
I agree!  Why alter it - I write this a YEAR later and STILL I cannot paste a path into Photoshop without it become a mask!  This is ridiculous!!
Photo of Rob F

Rob F

  • 2 Posts
  • 1 Reply Like
Before pasting the path, make sure you have no layers selected in your layers panel.. That works for me..