Photoshop CC making computer very slow

  • 1
  • Problem
  • Updated 4 years ago
I have been using Photoshop CC and Bridge after upgrading from CS5. I have had a lot of problems with PS CC being very slow to react and to load files, also many times I have had to give up and start again as the little coloured wheel is on my screen more than me working in CC. I have not loaded up Lightroom as I have never used it and I load my files from Bridge. I have just started back onto my PS CS5 and it works great, so I may have to cancel my CC subscription as PS is making my whole computer very slow. If you have a soloution then be glad to hear it.
Photo of Gerry Coe

Gerry Coe

  • 3 Posts
  • 0 Reply Likes
  • Fed up

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Ok, something is wrong with your system to make it that slow.
Do you have any third party plugins installed in Photoshop CC? Have you tried disabling them?
Have you tried updating your driver software?
Have you tried disabling any utility software you have running (antivirus, font managers, etc.)?

Also, what OS version are you using?
Photo of Gerry Coe

Gerry Coe

  • 3 Posts
  • 0 Reply Likes
Chris, Can I get back to you a bit later with info?
Photo of Gerry Coe

Gerry Coe

  • 3 Posts
  • 0 Reply Likes
Chris, Been looking at the Plugins,
Adobe PS Camera Raw
Embed Watermark
Open Exr.
Perfect Effects suite
Digimarc

I have not updated any driver software, but all looks up to date.
And I had not disabled any utility software.
I am using OS X 10.9.2
2.66 GHz intel core i5
8gb Ram 1067 MHz DDR3
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
With MacOS you can't update the drivers so easily - most updates come with the OS. But we also haven't seen that many slowdowns on MacOS (but many on Windows caused by third party software).

Try disabling all the third party plugins and see what happens.
And try disabling utility software (sometimes antivirus or backup software has problems with Photoshop's scratch files).
And we have seen font managers cause slowdowns as well.

Something else you might try is turning off font previews (Type menu -> Font Preview Size -> None ). That would rule out corrupt fonts or a corrupt OS font cache causing the slowdown.