Photoshop CC: Changing Foreground Color give program error

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
If I try to change color by clicking the default icon, reset the color to Default, (Black and White), select the Color picker and change the foreground color I get the following message and the foreground color doesn’t change.

"Could complete your request because of a program error "

If I select the Background color icon and change its color, it will change to the selected color but it will not cycle to the Foreground color swatch. It works the same way in all of the photography and painting Workspaces.

I have used Photoshop for twenty years.
Photo of Ken Teghtmeyer

Ken Teghtmeyer

  • 1 Post
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1734 Reply Likes
Hi Ken,

Sounds like you may be missing an update. Please make sure you have 14.2.1 installed: http://adobe.ly/PS-Up-To-Date
Photo of Deborah Jackson

Deborah Jackson

  • 1 Post
  • 0 Reply Likes
My PS CC is up to date and I'm having the exact same fault. Any help?
Photo of chris franklin

chris franklin

  • 6 Posts
  • 0 Reply Likes
Worked for me. Now my workspace option has vanished :-/
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1734 Reply Likes
Workspaces are part of your prefs. If you saved your workspaces as files to the default location, you can find the path here: https://helpx.adobe.com/photoshop/kb/...
Photo of chris franklin

chris franklin

  • 6 Posts
  • 0 Reply Likes
No - the whole drop down bar is missing!! Vanished!! Possibly since todays update thinking about it... There is no way of swapping from say essentials to painting without going through the menu - there used to be a drop down bar in the top right hand corner. Now its just blank.
Photo of chris franklin

chris franklin

  • 6 Posts
  • 0 Reply Likes
no - still gone - i uninstalled and reinstalled and its just not there. I had a different problem earlier, reset my preferences and that's when i noticed it had gone...
Photo of chris franklin

chris franklin

  • 6 Posts
  • 0 Reply Likes
Sorted it - When I reset it, it enabled "enable narrow options bar" in workspace. Unclicked that and its fine. Now I just need to sort character animator out! Which, for some reasons works on neither of my laptops for entirely separate reasons but if I right click and run as admin - no problems at all :-/