Photoshop CC Eyedropper Tool and Colour Selection Unusable

  • 1
  • Problem
  • Updated 4 years ago
I am using an up to date version of Photoshop CC. Every time I try to use the eyedropper tool, try to select a colour while using the brush tool, or switch my foreground and background colours, it tells me I can't because of a program error. As a digital painter, this is a crippling problem. I have tried restarting Photoshop many times, and that makes no difference. Is there a fix?
Photo of Meghan Shaw

Meghan Shaw

  • 7 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Are you using Photoshop CC, or Photoshop CC 2014?
And is this after using the crop tool?
Photo of Meghan Shaw

Meghan Shaw

  • 7 Posts
  • 0 Reply Likes
Photoshop CC 2014 I think (2014.0.0).
No, it's not after using the crop tool. It starts as soon as the program is opened.
Photo of Meghan Shaw

Meghan Shaw

  • 7 Posts
  • 0 Reply Likes
Apparently there is a newer version than 2014.0.0? Based on another thread, I saw that 14.2.1 is the most recent version. I have no option to update because Photoshop is telling me I am up to date, and the desktop CC manager also says I'm up to date. How would I get the most recent updates in this case?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
No 14.2.1 is the old CC version. CC 2014 is 15.0.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Check the file PSErrorLog.txt in your Photoshop preferences directory - it should list some information about what caused the program error.
Photo of Meghan Shaw

Meghan Shaw

  • 7 Posts
  • 0 Reply Likes
What would the path be to PSErrorLog.txt, if I'm using Windows 7?
Photo of Meghan Shaw

Meghan Shaw

  • 7 Posts
  • 0 Reply Likes
Found it. This is what is looks like:

2014:06:20 17:41:27 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:20 17:41:32 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:20 17:43:04 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:20 17:43:19 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 12:38:14 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 12:38:17 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 12:38:19 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 12:38:24 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 12:40:39 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 12:40:41 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 12:40:56 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 12:41:34 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 12:41:48 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:19:41 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:19:45 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:21:44 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:21:47 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:21:51 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:31:25 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:31:33 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:31:37 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:32:19 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 13:32:25 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:28:11 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:29:51 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:32:02 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:36:48 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:36:53 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:37:00 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:37:14 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:37:25 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:37:27 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:37:33 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:37:35 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:37:43 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:17 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:30 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:33 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:36 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:44 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:46 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:49 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:51 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:53 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:47:59 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:48:03 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:48:09 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:48:13 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:48:17 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:48:18 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:48:21 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:48:48 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:48:53 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:48:56 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:51:20 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 14:53:06 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
2014:06:23 15:00:27 : ..\..\sources\USheet.cpp : 459 : REQUIRE failed
Photo of Meghan Shaw

Meghan Shaw

  • 7 Posts
  • 0 Reply Likes
I tried uninstalling and re-installing. Creative Cloud app manager re-installed the 14.0.0 version, and the colour picker is still broken in all it's forms.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Try resetting preferences, or just download and use CC 2014.
Photo of Meghan Shaw

Meghan Shaw

  • 7 Posts
  • 0 Reply Likes
I tried resetting preferences and it made no difference.

I'm pretty sure I'm using CC2014. I was using CC prior to a few days ago, and the problem started after I updated everything onto a new computer. According to the Creative Cloud Desktop manager, I am using CC 2014 and everything is up to date.