Photoshop: CS6 brush size hotkeys randomly stop working.

  • 4
  • Problem
  • Updated 4 months ago
  • (Edited)
When using Photoshop CS6 the bracket keys to change brush size will randomly stop working after doing something like choosing a new color. After searching this issue online it looks like it has been a noted bug in photoshop since CS5.
Photo of acnxyz

acnxyz

  • 6 Posts
  • 0 Reply Likes
  • annoyed

Posted 5 years ago

  • 4
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
No, that isn't a known bug.

Do you have all the updates installed?
Photo of acnxyz

acnxyz

  • 6 Posts
  • 0 Reply Likes
I have all the updates available (I have single license not cloud). My current version is 13.0.4 x64

My setup:
MacbookPro Retina
Wacom Intuos4 wireless (most recent driver -Feb2013)
OSX 10.8.2

If you google something like "photoshop brush size keys stop working" there are several threads over the last few years similar to this one:

http://www.polycount.com/forum/showth...

Thanks for the quick reply :)
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 743 Reply Likes
Yes, for CS6 on MacOS - we're still trying to figure out the cause of that (and some other dropped events). The ones we've seen appear to be due to something outside the app causing the event target to be mis-set, but we still aren't sure what is causing it (may be an OS bug, may be a browser bug, could be our bug but it's bloody inconsistent for an app bug).

For CS5 and Windows - very few reports, mostly resolved as user error: keyboard switches (as the polycount user found), triggering third party utilities, switching apps, etc.
Photo of acnxyz

acnxyz

  • 6 Posts
  • 0 Reply Likes
I've noticed other hotkeys randomly not responding on occasion recently too. Actually just now I was using R to rotate canvas and was unable to switch back to B for brush for a minute or so. I could still paint and do anything else no problem, but the hotkeys wouldn't respond.

For now I've set the Ctrl+Option brush size hotkey to my Wacom pen button as a workaround, but something with hotkeys in CS6 seems off.

Hope this can be resolved, Thanks again.
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
What sort of mouse, trackball, and/or keyboard are you using? Anything third party or unusual? Are you running any supporting apps for such devices? I've seen this happen before and usually cuz a stylus or other device has some setting which is intercepting the PS commands.

Thanks,
David
Photo of acnxyz

acnxyz

  • 6 Posts
  • 0 Reply Likes
Hi David,

I am running on a 15" MacbookPro retina with just the default keyboard and trackpad. I am using a Wacom Intuos4 wireless tablet with the latest driver (Feb 2013). I have restarted and reset photoshop prefs a couple times and still had the issue with random non-responsive hotkeys.

OSX 10.8.2
16GB RAM

Thanks for the help,
Andrew
Photo of David

David, Official Rep

  • 2485 Posts
  • 304 Reply Likes
Howdy Andrew,

I would be willing to bet it's your Wacom tablet; I've seen this before. There's a couple of commands which intercept keyboard input. You can access them under your System Preferences. If you'd like, I can do a web-hosted conference and walk you through it. Just let me know.

Thanks,
David
Photo of acnxyz

acnxyz

  • 6 Posts
  • 0 Reply Likes
I just realized I have japanese input enabled, would that make a difference? Yeah, whenever you are able I would definitely appreciate it if you could point me to the preferences to change or show me through a web-hosted conference. Thanks!
Photo of David

David, Official Rep

  • 2485 Posts
  • 304 Reply Likes
If you have Japanese input enabled, then that's where your problem is. The OS reports a keystroke and we act on it. The shortcuts are based on US keys in the English app.

Thanks,
David
Photo of acnxyz

acnxyz

  • 6 Posts
  • 0 Reply Likes
it wasn't active when I was having problems (just in the top toolbar). I have turned it all the way off and will try again for a while to see how it behaves. Hopefully this helps. :)
Photo of brett gilmour

brett gilmour

  • 30 Posts
  • 5 Reply Likes
I've had this problem on MAC and PC computers across various OS's, for at least the past 5-7 years. It is a known bug because I have worked closely with all levels of Adobe support right up to the engineering team in California to resolve this bug.

My conclusion is that it's a bug in my Wacom Intuos 3 tablet, it doesn't happen when my newer tablet is connected. I've also worked extensively with Wacom to resolve this bug but their answer has been to suggest I just keep buying new tablets from them.

Let us know if you are running an Intuos tablet.
Photo of Till X

Till X

  • 1 Post
  • 0 Reply Likes
i think it's a problem with the way photoshop handles keyboard input, in the edit keyboard shortcut i tried to delete and add the shortcut again, but photoshop tells me that the key combination Opt+[key] is not a valid shortcut, this happens with any combination keys, maybe a miscommunication between the OS and photoshop ?????
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13972 Posts
  • 1664 Reply Likes
If you're on a Mac, do you have this plug-in installed?

http://helpx.adobe.com/photoshop/kb/p...

If not, install it and let us know if the problem goes away.
Photo of Robin Leck

Robin Leck

  • 1 Post
  • 0 Reply Likes
I just came across this thread as I had the same issue using my Wacom Intuos 3 with CS6 on a Mac - the plugin worked a treat. Thanks.
Photo of brett gilmour

brett gilmour

  • 30 Posts
  • 5 Reply Likes
I have this problem on MAC, Windows 7, and had it on Windows XP. It's been there since at least PS CS3 and is still there on PS CC.

The only common denominator is a Wacom Intuos 3, and Wacom Bamboo Create.
Photo of Rebecca King

Rebecca King

  • 2 Posts
  • 1 Reply Like
This might sound crazy, but if on a PC, Try switching the keyboard input language. I was just having this problem with my keyboard in Canadian Multi-lingual Standard. I don't seem to have this problem when in US English. It started to work again after I changed it. Might not be the problem, but it worked for me!

Running PS CC on Windows 8 with a Wacom Bamboo Create.
Photo of Jason Rouleau

Jason Rouleau

  • 1 Post
  • 0 Reply Likes
I had my green keys = french quick keys enabled. I finally figured out how to switch back to normal keys now it work fine.   to switch back for me was "left control + right shift". I had to press shift twice because it toggles between two different versions.
Photo of Stephen Kennedy

Stephen Kennedy

  • 3 Posts
  • 0 Reply Likes
I have had this problem both on mac and pc. No tablet plugged in. Even on laptop it occurs.

Changing keyboard language worked for me to but has to be on at intermittent intervals
Photo of David

David, Official Rep

  • 2151 Posts
  • 200 Reply Likes
Are you sure that you're not accidentally changing keyboard layouts?  In most cases, I think that's actually what's going on.  Also, I'm assuming that you're running CS6 still and not a more modern version.  Please let me know if that's incorrect.
Photo of Stephen Kennedy

Stephen Kennedy

  • 3 Posts
  • 0 Reply Likes
No it happens now and then. If I change from English to Thai it's resolved.
Photo of David

David, Official Rep

  • 2151 Posts
  • 200 Reply Likes
Hi Stephen,

Photoshop actually doesn't officially support Thai.  That said, I just checked it on both Win and Mac and it works.  Because Thai uses an alphabet that PS doesn't recognize, PS uses the equivalent keys on the US keyboard -- but the point is, if it works for one, it should work for both.  There's something else going on with your setup where English keystrokes are being hijacked (almost certainly by another app you have) while Thai keystrokes are going through.  Honestly, I could understand the opposite happening, particularly if Thai is similar to Indic languages where you have composed characters which could then effectively act like dead-keys.  But if you're not having the problem in Thai and only English, there's something with your system that's odd.  You should probably check what other apps and settings you have active.

Thanks,
David
Photo of brett gilmour

brett gilmour

  • 30 Posts
  • 5 Reply Likes
Rebecca, I'm in Canada so that could be the problem. Thanks for the suggestion. I really dislike switching the keyboard to USA settings though, we beat them in our war.
Photo of Anthony Redoblado

Anthony Redoblado

  • 1 Post
  • 1 Reply Like
I found the solution on Window's 10. If you press the Windows key and space you switch Keyboards. For me this was the case. I right clicked and went into language properties then removed the Canadian QWERTY keyboard. Now I have no issues if I accidentally press Windows Space. Hopefully this works for you all.

Cheers.
Photo of Bev Rogan

Bev Rogan

  • 2 Posts
  • 0 Reply Likes
Thank you!!! I struggled for over half an hour with this and you nailed the fix!
Photo of Desmond Desmarais

Desmond Desmarais

  • 1 Post
  • 0 Reply Likes
I still get this EVERY time I work in photoshop. Using CC 2014
Photo of Cristian Iordache

Cristian Iordache

  • 1 Post
  • 0 Reply Likes
Its SO EASY! change keyboard input language to english and it will work. LOL
Photo of David

David, Official Rep

  • 2151 Posts
  • 200 Reply Likes
Yes.  If you're running the English version of the app, then yes, you need to have an English keyboard for the shortcuts to work.  If you're running the French version of the app, then you need the French keyboard for the shortcuts to work.  Since all these shortcuts are customizable, we record the actual character and NOT the location.

David
Photo of Stephen Kennedy

Stephen Kennedy

  • 4 Posts
  • 0 Reply Likes
You don't understand lol

I change language to fix the problem. I only use English never any other language Thai was just a language I added to resolve the problem when someone told me that this would work
Photo of David

David, Official Rep

  • 2151 Posts
  • 200 Reply Likes
Yeah, I hear you.  That's actually NOT how the function works, so there's almost certainly another app or even piece of hardware periodically interfering.  Tablets are a common culprit as are non-standard keyboards or layouts.  If switching to Thai and then back solves the problem, that actually is pretty compelling evidence that you have the issue I'm describing.

Does that make sense?
Photo of Stephen Kennedy

Stephen Kennedy

  • 4 Posts
  • 0 Reply Likes
No tablet or add ons

Minimal software as the machine used only for photoshop and web use.

It happens on my MacBook as well as pc.

From what I have read it looks more like a bug

But I have a solution so
I'm happy :)
Photo of Nate Lake

Nate Lake

  • 1 Post
  • 1 Reply Like
Downgrade previous gen Wacom driver: MacOSX 6.3.21-8 to resolve Brush resize and hardness with Ctrl + Alt.
http://www.wacom.com/en/support/produ...
Photo of Lisa Champagne

Lisa Champagne

  • 1 Post
  • 1 Reply Like
Had this issue. I also use a Wacom tablet and had this issue with the tablet, but right now I'm using just a keyboard without the tablet plugged in. Turns out the issue was the keyboard I currently had enabled; it was Canadian Multilingual Standard, rather than US. So my square brackets, while they'd type out normally everywhere else, in photoshop they were showing up as a ^ and a Ç. Only learned this because I went into Photoshop Edit > Keyboard Shortcuts and tried to change the shortcut to something else, and when I typed the square brackets, it did that.

So the fix (Windows): Control Panel > Clock, Language, and Region/Change keyboards or other inputs methods > Keyboards and Languages > Change keyboard... > choose a US keyboard.

Or if you see a little keyboard in your task bar, click on it and quickly change it without going through all those steps.

I'm willing to bet that, when I plug my tablet in, I won't have this issue with the tablet either anymore.

EDIT: After changing the keyboard, it somehow switched again. Probably the best course of action is just removing all keyboards you have, other than the US keyboard. Will update if anything else funky happens.
(Edited)
Photo of David

David, Official Rep

  • 2467 Posts
  • 288 Reply Likes
Howdy Lisa,

Thank you very much for your info and update.  There is a shortcut for switching the virtual keyboard on both Mac and Win.  I think a lot of users hit it on accident, don't realize it, and then are concerned when their shortcuts quit working.

Have a great weekend,
David
Photo of Anson Yap Grayson

Anson Yap Grayson

  • 2 Posts
  • 0 Reply Likes
Im using win 10 and updated photoshop 
driver is the latest, when i use my brush size shortcut key, it goes to eyedropper(color pick), i try reinstall back the previous version wacom driver but still doesnt work. HELP
Photo of Šárka Valentová

Šárka Valentová

  • 1 Post
  • 0 Reply Likes
I tried Edit -> Keyboard Shortcuts -> Shorcuts for: Tool and when you scroll down you will se Decrease brush size -> I used: / (at czech keyboard ú)
and below Increase brush size -> I used: )
 And it works for me
Photo of Chris Rosati

Chris Rosati

  • 1 Post
  • 0 Reply Likes
try pressing [CTRL] + [SHIFT]
sometimes you press those by accident and it changes a bunch of keys. To see if this is the reason, open notepad or Word and see what the key actually shows when you press it. If it shows '^' icon or any others then you've switched the keys.