Photoshop CC 2019: I have no text cursor/highlight, no bounding boxes, or selection edges working on CMYK documents

  • 88
  • Problem
  • Updated 3 weeks ago
  • Solved
  • (Edited)
I just updated photoshop to 2019 20.0 and now the text tool is misbehaving. I see no cursor and I can't select tpe. There is just nothing. I obviously disabled the stupid lorum ipsum nonsense, so when I click with the text tool, there is absolutely no indicatation that anything is happening. My coworker has the same problem and reset his preferences which fixed nothing.
Running Sierra 10.12.6
Photo of Quackyboy


  • 3 Posts
  • 2 Reply Likes

Posted 1 year ago

  • 88
Photo of Jose Guerra

Jose Guerra

  • 1 Post
  • 0 Reply Likes
adobe is doing very bad thing with the user interface..... Transform tool
change with Shitf key thats is STUPID after a lot of versions u change that. AMAZING just waiting for a new patch without those trash changes 

Photo of RF


  • 17 Posts
  • 17 Reply Likes
After 20 years of pro use. These latest ‘updates’ are making me consider abandoning Adobe completely. It’s all bugs, no real working advantages. The 2019 release of PS is shameful.
Photo of Evert Krooswijk

Evert Krooswijk

  • 2 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Photoshop CC 2019: Tool display bugs.

Just upgraded to Photoshop CC 2019 and i'm noticing some display bugs with a range of tools.


  • The lasso tool doesn't display your selection while drawing. When adding to the selection, you can see the selection you're drawing. The quick work around is draw a small selection and then draw your real selection by shift-dragging. But it's just annoying.
  • When using the brush tool you very quickly get a 'spinning balls' cursor, instead of your brush size. This makes precision painting a real pain, as you can no longer see the edge of your brush.
  • Then there is the free transform tool. You used to get a bounding box with points around it from where you can drag the different transforms. Now you have to go and guess where to place your cursor to do anything. It makes the transform tool quite unusable. The 'fix' is to turn off graphics acceleration in your preferences, but this used to work just fine in previous versions with GPU acceleration.


My guess is that Adobe has changed the way tools are rendered on-screen (The rectangular marquee selector is now coloured, for instance), but clearly more work needs to be done.  These problems persist along a range of iMacs and MacPro's at my office, all are running macOS Mojave and are no older than 5 years.


Below is the system info for my particular iMac

Thank you,

Photo of Ruth J. Morrison

Ruth J. Morrison

  • 1 Post
  • 0 Reply Likes
Same issue here, I can't add a photo credit using the type tool, so I decided to not waste any more time looking for a simple solution from Adobe. I decided to Canva or RelayThat to the add text.
Photo of Gareth Noyes

Gareth Noyes

  • 7 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Mojave Photoshop CC19: selections & transform control tools not showing.

I updated to MacOS Mojave last weekend, and now none of my selections are highlighted or outlined, and transform controls (the little boxes you can select to stretch or re-size objects) are no longer showing. I can guess where the control boxes are, and then resize objects, but it's hit and miss. Same for text selections; selected text is not highlighted but I can edit text by typing after guessing the selection.

For example, if I select a layer, select the move tool, make sure the "Show Transform Controls" is selected, there is no visual prompt in my edit window to show that any item is selected. Yet I can move the object (with no visual clues or guides for the selection), or I can select a corner by guessing where the small box selection would be, then scale or stretch the object. Again, other than the object changing shape, there are no guides or lines to show me bounding boxes, alignment to other objects etc.

I'm running Mac OS 10.14.1 and Photoshop CC 20.0.1. I've tried switching between Mojave light and dark modes, but this has no impact. I've also rebooted several times.

Help, this is a pretty fundamental problem; I'm running blind!


Photo of Glenn Davy

Glenn Davy

  • 93 Posts
  • 22 Reply Likes
This reply was created from a merged topic originally titled Outline not showing in CMYK.

I'm using Photoshop V20.0.4 on an iMac with the latest version of Mojave. While working on a CMYK document, I was attempting to draw a selection with the Polygonal Lasso Tool. The outline does not appear as I'm drawing however, so it's impossible to know where your outline is. To "fix" I have to open an RGB document first, then switch back to the CMYK document in order to draw the outline. I know this was reported previously, possibly as far back at v20.0.0. I just wanted to confirm that it is *still* broken. As I'm working more and more with CMYK documents, I'd like to ask if there is any chance of a fix for this within the foreseeable future.

Thank you.
Photo of Megan


  • 2 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Photoshop: Can't see text selection.

the selection "highlight" is not visible - I can hope that I'm selecting by double clicking or dragging the cursor and can make changes but I can't see what I'm selecting

this has happened before - can't remember the fix - this time I removed the prefs.psp file but nothing changed
Photo of Josh Beckman

Josh Beckman

  • 1 Post
  • 0 Reply Likes
Yes. That did it. Thank you.
Photo of A K


  • 9 Posts
  • 3 Reply Likes
A year later, still broken.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16411 Posts
  • 2616 Reply Likes
Official Response
This issue should be fixed in the current version, Photoshop 2020 v21.x or later. Let us know if you're still having trouble.
Photo of jan aarts

jan aarts

  • 1 Post
  • 0 Reply Likes
The latest Illustrator CC 2020 has now this problem which looks the same.
There was no problem in Illustrator CC 2019.
The cursor disappears when trying to change text. Selecting text becomes not visible. You have to change it 'blind' and see what happens. 
The tip to open a new document briefly solves this problem and then it comes back.
I have Chrome open at the same time.

The work around seems to be to enable the option "GPU performance" and "Animated zoom".

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16411 Posts
  • 2616 Reply Likes
You can report issues with Illustrator to the their team here: