Photoshop Trial Keeps Crashing When I Open It (out of date video card driver)

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
I just started a Photoshop CC 2014 trial, and after installing everything (including the Adobe Creative Cloud), every time I open it, it remains open for about 10 seconds and then this happens:



I've looked at all of the other threads on this subject and tried all of the other suggestions:

- Restarted my computer
- Uninstalled and then reinstalled both Photoshop and Adobe Cloud
- Signed out and then back in on Adobe Cloud
- Updated all my drivers
- Updated graphics drivers from the suggested site (in another thread)
- Resetting preferences (although I couldn't get this to work - I'm on a PC?)

Anyone have any other suggestions as to why this might be happening?

Also, here are the details I'm given in the description:

Problem signature:
Problem Event Name: APPCRASH
Application Name: Photoshop.exe
Application Version: 15.1.0.148
Application Timestamp: 53d97a8f
Fault Module Name: aticaldd64.dll
Fault Module Version: 6.14.10.1646
Fault Module Timestamp: 4edef3ed
Exception Code: c0000005
Exception Offset: 000000000042d4c2
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: dd55
Additional Information 2: dd55198a6a1e8431eebab190b03ca471
Additional Information 3: ca4f
Additional Information 4: ca4f5ce3a452fb49fefd25853f6bb1d7

Also, I'm using Windows 7, 64-bit.
Photo of Jane Haynie

Jane Haynie

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
As you can already see in the crash details - your ATI video card driver is crashing.
Update the driver from AMD/ATI's website (not Microsoft or a system builder who have out of date drivers).
Photo of Jane Haynie

Jane Haynie

  • 2 Posts
  • 0 Reply Likes
Ok - I don't know how to read crash reports. I already installed the video card driver, but I thought maybe I installed the wrong one so I went back to the AMD website and selected the option that detects the video card driver and then updates. Now it's working! Thanks for your help!