Photoshop: Tools shortcuts - Changed to allowing single characters only

  • 1
  • Question
  • Updated 2 years ago
  • (Edited)
Ex: My previous shortcuts for decreasing and increasing brush sizes was cmd + alt + , and cmd + alt + .

This is no longer possible because I can only have single characters as shortcuts for tools. 
I really can't see any reason for limiting this. It is difficult enough already to find unused shortcuts.

Hope there are some reasons or arguments I haven't thought of that can help me understand why this was changed.
Photo of Winsnes

Winsnes

  • 9 Posts
  • 0 Reply Likes
  • confused

Posted 2 years ago

  • 1
Photo of John Maguire

John Maguire

  • 398 Posts
  • 84 Reply Likes
Why aren't you using the original default of, "[ and ]"
Photo of Winsnes

Winsnes

  • 9 Posts
  • 0 Reply Likes
That don't work very well on a Macbook Pro. It selects the eyedropper tool. 
Photo of John Maguire

John Maguire

  • 398 Posts
  • 84 Reply Likes
That doesn't make sense. adobe should keep them the same as they are standard keys on a keyboard. Adobe, are you listening!!!!!!!!!!!!!!
Photo of Winsnes

Winsnes

  • 9 Posts
  • 0 Reply Likes
Not sure if I remember wrong or if it has changed, but I can use Shift + / .
Photo of Max Johnson

Max Johnson, Champion

  • 488 Posts
  • 235 Reply Likes
On a Win10 PC running Photoshop CC 2017, I am still able to create key shortcuts with multiple modifiers such as alt-ctrl-, or shift-alt-ctrl-k

Is this a Mac issue maybe?
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Hi there,

As long as I've worked with keyboard shortcuts for Tools in Photoshop, they've always only accepted single characters.  This has been a limitation for at least a decade.  Now, sometime SHIFT will work, but only if it yields a different, valid character for the keyboard layout in question -- remember, this functionality has to work the same on both platforms for 20-something languages, which includes nearly a dozen different writing system (Latin, Cyrillic, Greek, Arabic, Japanese, Korean, etc).

The default shortcuts for Increase and Decrease Brush Size are [ and ] in English -- if these are selecting the Eye Dropper tool, then there is either an issue with your setup or you're not using a recognized keyboard.  What kind (language, layout and manufacturer) of keyboard are you using?  Are you using a virtual keyboard for another language or layout?  Have you tried resetting your shortcuts to the default set?  How about changing to a generic US (or whatever language) layout?  Also, keep in mind, that if you're running Photoshop in a language other than English, your shortcuts will change to reflect that language's keyboard layout -- for instance, German and French don't HAVE [ and ] as single-character options so there you have (as I recall) ' and # and : and !, respectively.

Keyboard shortcuts for menu entries and panel commands do allow for multiple key-combos.

When it comes to things like keyboard shortcuts, we try VERY HARD not to change things on users while giving them as much latitude as possible.

Thanks,
David