Photoshop: Open CL greyed with current Nvidia driver (417.71)

  • 1
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
Open CL functionality is greyed in Photoshop CC (both 2018 v19.1.7 and 2019 v20.0.2) with the latest Nvidia driver version 417.71 for Geforce GPUs (I use a GTX1080).

Stepping back through Nvidia's previous drivers shows that 416.34 works with Open CL in Photoshop but Open CL is greyed when switching to the next driver 416.81 and remains greyed on the current driver 417.71

I will raise a parallel report with Nvidia

Dave
Photo of David Richardson

David Richardson

  • 107 Posts
  • 36 Reply Likes

Posted 2 months ago

  • 1
Photo of eartho

eartho, Champion

  • 1029 Posts
  • 301 Reply Likes
which OS?
Photo of David Richardson

David Richardson

  • 107 Posts
  • 36 Reply Likes
Hi
Windows 10 Pro (version 1803) 64 bit
Dave
(Edited)
Photo of eartho

eartho, Champion

  • 1021 Posts
  • 295 Reply Likes
I'm running a 2070 with 417.35 and not having any issues... unfortunately i'm in the middle of a few projects, so i'm not able to test the update.
Photo of Rosa

Rosa

  • 338 Posts
  • 182 Reply Likes
Just to note and yes different graphics card from David's, mine is GTX 970 with driver version 417.71 and is working fine on my Windows PC. 
Photo of Bill Broughton

Bill Broughton

  • 18 Posts
  • 9 Reply Likes
Running 417.71 with a 1050Ti on Win 10 and all is well. OpenCL option is available and checked.
Photo of David Richardson

David Richardson

  • 107 Posts
  • 36 Reply Likes
Interesting and thanks all for your helpful feedback.

This afternoon I tried a few things. I went back through a series of NVidia driver updates and tested each .

398.11 Works with openCL
416.16 works with openCL
416.34 works with openCL
416.81 OpenCL greyed out - all other GPU functions OK
416.94 OpenCL greyed out - all other GPU functions OK
417.35 OpenCL greyed out - all other GPU functions OK
417.71 OpenCL greyed out - all other GPU functions OK

Disabling the GPUSniffer (by renaming it to ~sniffer.exe) made no difference.

The specific card is a Gigabyte GTX1080 Windforce OC 8G

For the time being I've stepped back to 416.34

Dave


Photo of David Richardson

David Richardson

  • 107 Posts
  • 36 Reply Likes
Finally - cracked it.

I once again updated to 417.71 but this time, in the Nvidia installation dialogue  chose "Advanced options" and checked "Clean install". It updated to the latest driver but this time Open CL is working correctly.

Thanks to all who fed back on their own systems - without that I would not have persisted with this. I hope the above helps anyone else who experiences something similar.

Dave
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15204 Posts
  • 2176 Reply Likes
Uff-da. Those drivers can be pesky. Thanks for sharing the solution.
Photo of Rosa

Rosa

  • 338 Posts
  • 182 Reply Likes
That's so good David and good to know for the rest of us. Thanks.