Photoshop CC 2017.1.1: Shortcut doesn't work correctly in Liquify

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)

If I enter the Liquify tool via keyboard shortcut Shift+Ctrl+X then I cannot use the shortcut F to select the Freeze tool.
If I enter via the menu Filter - Liquify then the F key can be used as a shortcut.

This is in CC2017.1.1 on Windows 10 64 bit.

Dave

Photo of David Richardson

David Richardson

  • 87 Posts
  • 29 Reply Likes

Posted 1 year ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Hi Dave,

I can't seem to repro this problem.  Can you tell me more?  Do W, R, E, C, S, B, O, D, A, H, and Z also work or fail?  Are the keystrokes simply ignored?  Do you get a beep?  Something else?

Finally, any chance you have a tablet or other device attached?  How about a companion app that grabs keyboard input, particularly screen capture or audio/video editor?

Thanks,
David
Photo of David Richardson

David Richardson

  • 87 Posts
  • 29 Reply Likes

Hi David
Thanks for responding.  The issue was raised on the Photoshop Forum earlier today and I was able to replicate it - hence my post here.

It is strange in that it only happens if entering Liquify via the shortcut Shift +Ctrl+X.     F and B are then ignored (the others are OK) . No message, no beep. 

Entering Liquify via the menu then both  F and B keys work correctly

I do have a WACOM tablet but I tried disconnecting and made no difference. I did originally have SNAGIT running - again I've closed it down and the behaviour is the same.  Anything else I can do to test/help please let me know.

Dave


Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Howdy Dave,

Well, I know it sounds like a cop-out, but I'd a feeling a WACOM tablet was involved.  I'd say 95% of the time that keyboard input is going wrong, it's the fault of such a tablet or the side-car apps that go with it.  Not what owners of these devices want to hear, but nonetheless accurate.  Clearly something that the QE department of that firm should hear more frequently...  Based on history, the controls just don't play well with others...

The use of a shortcut to enter Liquify actually kinda points to another app, particularly a side-car, as the culprit.  The SHIFT+CTRL could easily be part of the command that brings that other app to focus.  That only some keys work similarly points to this as well -- those are the ones the other app responds to and others that work are "ignored" and thus "let through."  From the OSes perspective, the companion app has pushed to the "front of the line" or otherwise taken "cuts" and is now making it all about itself, rather than the application which is supposed to have focus (in this case, Photoshop).

Try this -- remove the tablet and uninstall ALL related software.  You might want to do that with SNAGIT too if it intercepts keyboard input.  Or, a quick logical test is, do either of those apps use F or B as part of their shortcuts for anything ever?  I'll bet they do...  Reboot the OS to make sure any lingering code is flushed.  Now try it.

Keep in mind, it works fine on a clean machine...

Thanks,
David
Photo of David Richardson

David Richardson

  • 87 Posts
  • 29 Reply Likes
Thanks David
I'll test that over the weekend (PC tied up tomorrow). Either way I will come back and confirm.
Dave
Photo of David Richardson

David Richardson

  • 87 Posts
  • 29 Reply Likes

Hi David - Apologies I have not had the chance to try uninstalling the other software yet but ...I did get feedback from the other Photoshop forum member who originally  raised the issue on the Photoshop forum. He has no tablet and no screen capture, or similar, software installed or running.

What I did find today whilst using the software was this:

Going into Liquify  via the menu works OK until the Alt key is pressed.  At that point, the liquify properties under "View Options" show F underlined as the shortcut for Show Face Overlay and B underlined as the shortcut for Show Backdrop. So pressing F or B is now switching those options on and off rather than the tools. I could not find a way to turn that back off again once Alt had turned it on.

This is not the actual Alt key stuck as that Alt key still works perfectly for going from Cancel to Reset and back or for reversing the direction of the pucker /bloat tools.


I hope that helps


Dave



(Edited)