Photoshop/Lightroom stopped working with my Geoforce GT540M. worked last week

  • 1
  • Question
  • Updated 3 years ago
PhotoshoP CC 2104 Geoforce GT540M. All of a sudden Photoshop does not recognize my graphics card pops up with a message "you card is not support, if there are problems uncheck the use graphics card check box" but then it show that the card is an Intel graphics card. Why does may car hove problems all of a sudden? Lightroom ^ says my card has been disabled due to errors? It worked last week, whats up? thanks for your help
Photo of John Dillworth

John Dillworth

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Something changed in your system configuration or video card drivers.
You probably have both an Intel and NVidia GPU in your system, and for some reason the system thinks Photoshop should use the Intel GPU instead of the NVidia GPU.

First, update your video card drivers from NVidia and Intel's websites.
Then see if you can set Photoshop to use the NVidia GPU via NVidia's controls, or the system BIOS.
Photo of John Dillworth

John Dillworth

  • 2 Posts
  • 0 Reply Likes
thanks. I disabled the Intel driver, restarted, enabled it and then it read the Nvidia. Weird, but its all good. What changed? Lightroom 5 updated to Lightroom 6. Old, but stable, laptop. It's all good now
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Not sure what changed, but something changed with the drivers or configuration at the system level.

Glad to hear that it's all working again.