Photoshop: Layers Masks changing by themselves?

  • 2
  • Question
  • Updated 5 months ago
  • (Edited)
I've been having problems with 'blocks' appearing out of nowhere in layer masks that I am not even working on. I have to then select the mask and edit out these unwanted areas effecting the mask which is an absolute pain. For example, I've just been working on a hue/saturation layer, when suddenly blocks appeared in a mask on another layer. They appear without warning. They are always flat edged and random in shape and size. If left, they will change shape as I work on other layers. They are a total pain!

The screen grab below shows what the mask looked like in the layers palette before the blocks appeared. It's a very small area, thus you can't actually see the active area of the mask.


 

Then whilst working on another layer, the 'blocks' appeared on the mask for the tv layer as below.



The effect on the image being edited was large areas of the layer were now visible - area shown by red arrows.



Can anyone tell me what may be causing this to happen?

In addition to being very frustrating, I'd prefer to edit photographs without random inputs to layer masks!!

Any help will be much appreciated.


Regards,


Phil
Photo of Philip Giles

Philip Giles

  • 2 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 2
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2085 Posts
  • 859 Reply Likes
You do not mention the Photoshop version, so first make absolutely sure that you use the latest version and report back here (mention the version number and your OS) if updating does not resolve the issue.

Also try if checking the "Legacy Compositing" option in Preferences - Performance helps.
Photo of Amy Boring

Amy Boring

  • 4 Posts
  • 0 Reply Likes
Delete all old versions from your applications
Photo of Joel Sigerson

Joel Sigerson

  • 34 Posts
  • 27 Reply Likes
I get the same thing. Sometimes it's not really changed, it's just a screen drawing artifact (even though it shows up in the layer mask thumbnail) and zooming in to 100%, or turning layers off and on, forcing the screen to redraw will temporarily return things to normal. 

However, other times the mask is permanently altered, and I have to jump through hoops to restore it, if it's even possible.

I've experienced this in every iteration of Photoshop 20, on a late 2015 iMac with a 4GB AMD Radeon R9 M395X, and a 2010 Mac Pro with Nvidia GTX 680. Legacy compositing makes no difference.

Deleting old versions is not an option, since I frequently have to go back to 19 or 18 to get some broken feature to work. 
Photo of eartho

eartho, Champion

  • 1095 Posts
  • 330 Reply Likes
This issue has been around for quite a few years and randomly pops up from time to time. Usually it's just a visual artifact related to video driver weirdness, but in the past the masks actually get saved with the chunks!
Only advice i can offer is a reinstallation of your video drivers. Maybe try a Ps pref wipe too.
Photo of Philip Giles

Philip Giles

  • 2 Posts
  • 0 Reply Likes
Thanks for all the suggestions. Sorry should have mentioned OS and version of PS.  I'm working with PS CC2019 running on OS 10.14.2

Johan, I have tried using Legacy Compositing and it made no difference.

Amy, I have no older versions of PS installed.

Joel, I have wondered if it is something to do with the video card. I too have a Nvidia GTX 680 in a 2010 MacPro. When I first bought the machine in 2014 I never had this problem, it has only been the past couple of years it has appeared, and it seems to be getting steadily worse. Bad enough to make editing a real pain at the moment. In the past I sort of lived with it. 

I have turned off 'Use Graphics Processor' altogether in the hope of solving the problem, but it appears just the same and PS runs far slower, so it was a lose lose. As you mention, I also note that the blocks on the masks will change as I zoom in and out, but it rarely gets rid of them by zooming in to 100% and then zooming back out; as I zoom out either the same blocks appear or new blocks appear. Do you just try and work round them or have you found a solution??

Eartho, I have also tried a preference wipe and it made no difference. The blocks appeared straight away as if nothing had changed. Due to the Apple Nvidia spat, the card is using the OS X default graphics driver so there is no way to update it. Having said this, the problem was the same when I was running CC2018 and previous versions under El Capitan and using the Nvidia drivers.  

It's getting to the point whereby it's almost impossible to edit with multiple adjustment layers because I simply can't see what the image looks like when blocks appear on multiple layer masks. 

Any further help/suggestion will be most welcome.