Photoshop CC 2015 is all of a sudden SLOW on my machines

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
Latest update of Photoshop CC 2015 is VERY slow and impeding workflow which is costing MONEY!!!!!!! Please fix it or roll back the update!!!!
Photo of Mark Conrad

Mark Conrad

  • 6 Posts
  • 1 Reply Like

Posted 3 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
Photoshop CC 2015 is not running slowly for most users, especially after they have applied the update.

What we have seen are slowdowns due to corrupt fonts, bugs in third party plugins, bugs in external applications, and sometimes unavoidable OS issues (missing network devices, bad network servers, etc.).

What OS version are you using?
Are you using any third party plugins? If so, have you tried disabling all of them?
Have you tried setting font previews to "none"?
What else may have changed on your system since Photoshop was last working normally?
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Hi Mark,

Please don't discuss the same topic on multiple threads -- it just creates noise and makes finding the correct thread topic difficult to find.

Assuming you want to pursue the problem you're seeing in this thread, then, as I already wrote in the OTHER thread you posted

*  FIRST try disabling some all of your third party plugins and see if your performance improves.  If it does, add the plugins back one at a time until you find the culprit and reach out to the manufacturer.

*  SECOND, do you have a lot of third party fonts installed, particularly "from some website on the Internet"?  I ask because a bad font can completely mess up PS's performance.  Try running this script to see if you've got any bad font: https://helpx.adobe.com/photoshop/kb/troubleshoot-fonts-photoshop-cs5.html Step #5.

*  THIRD, try turning off font preview.  If that solves stuff, particularly if the previous step proved fruitless, then we should talk...

Thanks,
David
Photo of Mandy Karlowski

Mandy Karlowski

  • 8 Posts
  • 0 Reply Likes
Hello I am facing the same issue and I think it is because of the many fonts I use. I want to turn off Font preview, but how do I do that?
Thank you very much in advance!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
Type -> Font Preview Size -> None.
But you should also try the font troubleshooting link that David posted.
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Howdy Mandy,

Also, if turning off the font preview has a big impact on your performance, could you please follow up with us?  I'd like to get an idea of your workflow and situation.  You can email directly at dmohr at adobe dot com.

Thanks,
David
Photo of Mandy Karlowski

Mandy Karlowski

  • 8 Posts
  • 0 Reply Likes
Hello Chris and David.
Thank you for your response. Unfortunately I couldn't find how to turn it off in the Preferences>Type Panel :S... (Below there is a picture of my preferences)

Maybe I should have mentioned, that I work with Photoshop CC 2015.

Yesterday I tried to delete bunches of fonts on my PC.
I work with Windos 8, 32GB Ram, Nvidia G-Force GTX 770, Intel Core i/-4790K CPU (4GHz) and a SSD

After deleting my fonts it worked a little better but is still lacking.

Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Hiya Mandy,

From the main Photoshop windows, click Type > Font Preview Size > None.

G'dnight,
David