Elements says it requires IE5 or above in Windows 10

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Photoshop Elements 10 says that it requires Internet Explorer 5 to operate properly but there is IE5 or higher in Windows 10. How do I correct this?
Photo of Wayne Frerichs

Wayne Frerichs

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Francisco Marin

Francisco Marin

  • 1 Post
  • 0 Reply Likes
I am getting this same issue and believe that is the reason it's also preventing me from signing in once in Elements 10.