Elements: Brush/eraser hangs in Yosemite MacOS 10.10

  • 87
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Photoshop Elements hangs now when I use brush/eraser tools following the installation of Mac Yosemite OS on my Mac. Others have reported this problems on other feeds. I hope that Adobe will give priority to fixing the apparent incompatibility of Printshop Elements with Yosemite OS.
Photo of David Chubb

David Chubb

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 87
Photo of StevethePoet

StevethePoet

  • 7 Posts
  • 5 Reply Likes
Rather than finger-pointing back and forth between Apple and Adobe, seems to me that both Adobe and Apple need to collaborate and find a solution. Adobe: you need to do your utmost. Your user community expects no less.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 738 Reply Likes
We'd like to - but Apple needs to get information from customers affected by the MacOS 10.10 bugs so they can figure out the cause. And we cannot debug MacOS 10.10, because we don't have Apple's source code. We can only help Apple debug it, once more is known about the nature of the OS bug.
Photo of tigershark

tigershark

  • 5 Posts
  • 0 Reply Likes
This is fine, but you should be telling them that you're aware.

Also, this doesn't trigger a crash report as it hangs rather than crashes and it doesn't go into a "stopped responding state".

The Apple forums are well known as a place to get help from other users but not to report problems to Apple themselves, who do not monitor them (at least certainly not officially).
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 738 Reply Likes
We are telling them, but we're still gathering information on a variety of problems introduced in MacOS 10.10 (in addition to trying to maintain our own software).
Photo of Michael Heinz

Michael Heinz

  • 13 Posts
  • 3 Reply Likes
As others have reported, switching to a mouse resolved the hang on my machine - although I haven't tested all features yet.