Elements 7 asks for my serial number, but I can't find it

  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I've been using PSE7 for years without issue, both the Organizer and the Editor having over 10,000 pictures cataloged. I recently ran into a problem where it would not load (I believe a result of my running a PC cleaner program that broke something). After many attempts to resolve the issue, I had no choice but to reload the software. The software was in my downloads folder, not on a CD. The good news is that this fixed the problem, as I can see my catalogs. Unfortunately, it asks for the serial number before getting true access, which I have have no record of as this goes back many years and my email records only go back to 2012. While old, I know this software well and it meets my needs. I don't want to buy new software just because of a technical problem. Any suggestions?
Thanks, Bob
Photo of Bob Hardcastle

Bob Hardcastle

  • 3 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of Bob Hardcastle

Bob Hardcastle

  • 3 Posts
  • 1 Reply Like
Problem solved. For anyone with this problem, as noted above, the Windows uninstall routine doesn't clean out everything. I did a uninstall using Revo Uninstaller, which can do a deep clean uninstall of PSE registry and system files (make a System Restore point before doing this, just in case). Then restarted the PC, then installed the PSE software from the disk, entered the requested serial number, and all works fine. The mystery to me is the PSE organizer maintained my photo catalogs, which I was not expecting but a nice surprise. Anyway, I thought I'd pass it along.