Elements 13 will not stop trying to generate thumbnails ever. Nearly all my thumbnails are hourglasses.

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
Photoshop Elements 13 will not stop generating thumbnails ... only it doesn't seem to be generating thumbnails.

Please note that I am running PSE 13 on a fairly high-end Lenovo notebook with an 3200x1800 display and upgraded to the latest version of PSE 13 because this version adds additional support for systems with that resolution. Unfortunately, I have found it unusable.

My catalog of nearly 60,000 photos which has been painstakingly maintained over a number of years and through faithful and challenging PSE upgrades is now useless. I cannot view my photos because the thumbnail generation process never seems to make it past about 10%. 90% of my images show the hourglass, but never get thumbnails generated. I have tried the following:

1 - repeated attempts to both repair and optimize which ultimately generate a message indicating the thumbnail cache is corrupt and eventually asks whether I want to recreate ... I reply yes restarts the whole process again.
2 - manual deletion of the thumbnail cache file and restart of Elements to restart the thumbnail generation process, but no matter what I do it ends the same way.

Please note that auto analysis features for faces et cetera have been disabled and I also tried disabling thumbnails for videos.

Here is what happens over and over again:

When the process of generating the thumbnails starts it looks encouraging generating over a thousand thumbnails in a little as 5 to 10 minutes. I can see the progress I am making by holding the mouse pointer over the swirling circle in the lower left hand corner, but at some point the progress that indicates which photo of the total (i.e. generating thumbnails 1,000 of 60,000) goes away and becomes simply "generating thumbnails." At that point, it doesn't seem that any further progress is made. I have left the system up and processing for days without the system ever successfully updating the thumbnails.

I know I am not the only one with this issue because I see other links detailing the same issue, but as far as I know there is no resolution to this issue.

Is my expectation that Photoshop Elements will handle my catalog of 60,000+ photos and growing the problem. If there are known limits to what Elements handle I would like to know. Can you provide some guidelines with regard to the maximum recommended catalog size?

If the solution is moving to Lightroom, please say so.

Last question: Is there a support number at Adobe to address issues like this? If so, I can't find it.

Photo of George Howell

George Howell

  • 1 Post
  • 0 Reply Likes
  • hugely disappointed

Posted 3 years ago

  • 2
Photo of Randi Ives

Randi Ives

  • 1 Post
  • 0 Reply Likes
Did you ever receive a reply to your question? I am having the same issue.
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 950 Posts
  • 186 Reply Likes