Photoshop: Duplicate Layer glitch

  • 1
  • Problem
  • Updated 3 weeks ago
When a smart object is the only layer you have, when you right click > Duplicate Layer > New Document, The new document does not have a duplicate of the smart object. It rasterizes the image and makes it into a full on locked background layer. 

Work around: Made another blank layer as the 1st layer and the one I want to duplicate as layer two. Duplicates fine now.

Working with Photoshop v. 20.0.3, iMac running macOS Mojave v. 10.14.2
Photo of Daniel Lane

Daniel Lane

  • 2 Posts
  • 0 Reply Likes

Posted 3 weeks ago

  • 1
Photo of Cristen Gillespie

Cristen Gillespie

  • 1562 Posts
  • 485 Reply Likes
If you create a keyboard shortcut for Image> Duplicate, you can keep your SO layer without rasterizing or adding a new blank layer. Just make sure that whenever you use it to duplicate a multi-layered document and don't want it flattened, you check that Duplicate Merged layers Only is not enabled. It won't be with a single Smart Object layer.