Photoshop CS4: Running fine on OS Sierra – BUT camera raw vers 5.0 only = no update possible ?

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
Transferred Photoshop CS4 to OS Sierra – and it works perfect.
BUT...
there's only the camera raw vers. 5.0.
All my efforts to update it (vers. 5.5., 5.7, 7.1, 9.1 ...) failed.

All the setups (downloads from Adobe site) tell "system requirements" are not okay - though Photoshop itself works fine except of using with camera raw vers. 5.0 only.

At the same time creative cloud info is telling "Camera Raw CC / up to date", but any options to change or remove that are blocked.

Any idea how I get at least camera raw 5.7 into OS Sierra and working?
Photo of Mr. Frank

Mr. Frank

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Photo of Mr. Frank

Mr. Frank

  • 2 Posts
  • 0 Reply Likes
Thank you Jeffrey Tranberry,
 
unfortunately that didn't help with  Ps CS4.
Opening the packages shows a file called "setup" but not "install".
After releasing it in Terminal the system opens a window telling "Raw Converter 5.7 not installed".
However, the update from 11.0 to 11.0.2 worked that way.

I solved the Camera Raw problem with what I had in mind as "emergency solution".
I removed  all Ps CS4 files (also plugins and others) from OS Sierra and transferred everything from my Yosemite-BackUp including Camera Raw 5.7.
It was a little work with details but now Ps CS4 / Camera Raw 5.7 works – even with vers. 11.0.2

Nevertheless it would be interesting to have a solution for CS4 with the "Terminal way".

Best,
Mr. Frank
(Edited)
Photo of Mike Duvall

Mike Duvall

  • 1 Post
  • 0 Reply Likes
He missed a few steps.  Open the DMG download
control click setup,  choose open contents folder, then open MacOS folder 
drag setup file to terminal and hit return
CS4 can be downloaded here.  
 (https://helpx.adobe.com/creative-suite/kb/cs4-product-downloads.html
(Edited)