Photoshop: Changes my custom keyboard shortcuts between launches

  • 1
  • Problem
  • Updated 11 months ago
  • Solved
  • (Edited)
When i make a keyboard shortcut for playing an action ( Ctrl+shift+< ) it is saved and I summarize and save the shortcuts but the next time I open Photoshop, the shortcut has been changed to ( Ctrl+shift+&) which is impossible to use... This is most likely a bug that should be fixed!
Photo of Simon Søgaard Vallinder

Simon Søgaard Vallinder

  • 6 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14663 Posts
  • 1951 Reply Likes
Can you confirm the OS version & language, as well as what language keyboard you're using? I'll have our localization/keyboard shortcut expert stop by and see if he can help troubleshoot.
Photo of Simon Søgaard Vallinder

Simon Søgaard Vallinder

  • 6 Posts
  • 0 Reply Likes
Windows 10. English version of photoshop but Swedish PC. Swedish keyboard.
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Howdy Simon,

Let me make sure I understand this.  You are running English Photoshop on Swedish Win10.  Now, when you say you have a Swedish keyboard, do you mean physically, digitally, or both?  In other words, is the computer set to recognize the keyboard as Swedish?

Looking over my Win10 machine with a digital Swedish keyboard, the & character is only available by pressing SHIFT+6.  Are you seeing the same thing?  And the < key's SHIFTed version is >, right?  Or are you seeing something different?

Thanks,
David
Photo of Simon Søgaard Vallinder

Simon Søgaard Vallinder

  • 6 Posts
  • 0 Reply Likes
The computer is swedish all around except for photoshop! So keyboards and everything is swedish. Your keyboard says the same as mine the key < changes to > when holding shift.
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Howdy Simon,

Okay, I've got a US keyboard set to emulate a Swedish one.  With that setup, I cannot repro your problem.  I've also tried with a Turkish keyboard (same layout) set to emulate Swedish.  Also, no problem.  Could you please verify that your keyboard settings are all set to Swedish?  Also, do you have another keyboard you can try?  I'm trying to isolate any and all variables I can for this.  I'm just not seeing it.

Thanks,
David
Photo of Simon Søgaard Vallinder

Simon Søgaard Vallinder

  • 6 Posts
  • 0 Reply Likes
Thankyou for trying. Just to be clear: I make the shortcut and accept it and save it. Everything is then working fine. But when I quit PS and then relaunch PS, the shortcut has been automatically changed from ctrl+shift+< to ctrl+shift+&
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
THAT was the secret step!  Closing PS and relaunching.  Okay, now I *AM* seeing this bug and I will log it.

VERY wEiRd....sorry for the inconvenience and great catch!

Thanks,
David
Photo of Simon Søgaard Vallinder

Simon Søgaard Vallinder

  • 6 Posts
  • 0 Reply Likes
Yeah I thought so too! Thank you very much and so sorry for not being fully clear from the beginning!
Is it possible to get an email or a notification when the bug has been fixed?
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Sure thing, Simon.  I've added your email (listed here) to the bug, so when I close it, I'll set myself a reminder to message you once the fix goes public.

Have a great day!
David
Photo of Simon Søgaard Vallinder

Simon Søgaard Vallinder

  • 6 Posts
  • 0 Reply Likes
Thank you! Same to you!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14663 Posts
  • 1951 Reply Likes
It looks like this was fixed in Photoshop 19.0 or later. Let us know if you're still having issue.