Photoshop CC2019: Slow Jagged Panning (Pan Tool)

  • 2
  • Problem
  • Updated 1 year ago
  • (Edited)
after sticking to cc2018 for almost a year because of the new transform behavior and click to commit, I decided to use the text file setting cheat to get rid of the unnecessary updates and try to use the final release of Photoshop. Now I have the direct comparison of the two versions. 

sadly I found one issue with the new version. I see and feel a noticeable lag when using the Pan tool. And I use it all of the time. In cc2018 it almost sticks instantly to the canvas, there is just a minor lag, but in cc2019 I just see the hand moving away but the canvas stays for a noticeable part of a second behind. it is just noticeable and it is quite annoying. When panning constantly there is jagged instead of smooth motion.

All settings are the same.
Flick Panning is turned off.
Use Legacy Compositing is turned off, but there is no difference when I turn it on.

MacPro late(2013)
64GB RAM
500 SSD + 4TB External RAID
Dual 27" EIZO SX270
OSX 10.12.6 (Sierra)

Obviously I need to stick further to cc2018, or try to get used to yet another performance drawback:(

Anyone experiencing the same behavior? I would be very grateful for any suggestions.

thanks!




Photo of laden m

laden m

  • 205 Posts
  • 39 Reply Likes
  • frustrated

Posted 1 year ago

  • 2
Photo of laden m

laden m

  • 205 Posts
  • 39 Reply Likes
now i made the same test on my MacBook Pro (Late 2011) 16GB RAM running on latest OSX Mojave 10.14.5. Experiencing also tha same issues. CC2019 feels in general more sluggish and with the same jagged panning compared to cc2018. Obviously CC2019 needs more Recources?


Photo of Kit Kerner

Kit Kerner

  • 113 Posts
  • 33 Reply Likes
For starters I'm using Windows and don't have this issue. I'm replying because I am having a bunch of issues and many of them are not going away. What has happened frequently is a 'preset setting' has been changed (I didn't do it) and often after I close the application. Sometimes I don't where to look for a preset, I'm not happy. Good Luck! 
Photo of laden m

laden m

  • 205 Posts
  • 39 Reply Likes
after searching further I found these two threads:

https://feedback.photoshop.com/photoshop_family/topics/photoshop-cc-2019-healing-brush-clone-stamp-t...

https://feedback.photoshop.com/photoshop_family/topics/ps-cc-2019-slow-performance-overall-slow-redr...

Obviously, there are many performance issues with cc2019. It's a mess because there are several possible reasons and it seems Adobe doesn't know which one is causing the problems. 

Turning off the Ruller makes everything smoother.

I'm not on OSX Mojave, so I'm not sure if the other solutions mentioned in the threads are concerning my setup.

Still trying to work with cc2019 but probably going back to cc2018 soon.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17043 Posts
  • 2896 Reply Likes
There is work being done for the lag with rulers shown.
Photo of laden m

laden m

  • 205 Posts
  • 39 Reply Likes
thanks Jeffrey, I hope it is resolved soon:)
Photo of Kit Kerner

Kit Kerner

  • 112 Posts
  • 33 Reply Likes
Yes! Thank you Jeffery. I don't have that problem, but others as you may have read. Most are not fixed. Some seem to be related to presets, discovered by reading this forum, but when PS signed out and then back in the presets are gone, meaning I have to start from scratch. I'm not expecting any assistance in this posting, but I wanted you and others to know that this "Family" is a good place to discover answers and new things. I get distracted with all the advice. Good Luck!