Photoshop CC 2019: "disable home screen" not working

  • 17
  • Problem
  • Updated 6 months ago
  • In Progress
  • (Edited)
in the new Photoshop cc2019 the "Disable Home Screen" setting is broken. Even when checked the Home Screen is showing after closing all documents. Photoshop was closed and started again after the setting was changed. 

all running on:
Mac Pro (Late 2013)
OS X 10.12.6

thanks!
Photo of laden m

laden m

  • 188 Posts
  • 35 Reply Likes

Posted 10 months ago

  • 17
Photo of Kevin Randall

Kevin Randall

  • 1 Post
  • 3 Reply Likes
Same problem. Huge waste of time in a production environment. I hope they fix this immediately.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15531 Posts
  • 2316 Reply Likes
Official Response
We're investigating these inconsistent behaviors: restart required, home screen coming back after closing docs even with pref checked. (I can't repro the latter off hand, but I'll try and narrow that down for our engineers)

Ann, we have a story on our backlog to potentially implement the behavior you're suggesting. I think that might be the right approach:

Replace the "Disable the Home Screen" with a new preference "Disable auto-show the Home Screen". When  "Disable auto-show the Home Screen" is unchecked, then the home screen works as it does today (in CC 2019)

When "Disable auto-show the Home Screen" is enabled then the home screen is not shown automatically. It is only shown when the user explicitly clicks the Home Screen button, or chooses the "Home..." menu item

Thank you for reporting and the feedback!
Photo of Milk_Dream

Milk_Dream

  • 30 Posts
  • 0 Reply Likes
Pallete tools  stand on home screen when Ps is open.
Photo of Brandon Adams

Brandon Adams

  • 5 Posts
  • 4 Reply Likes
This seems to only happen when the Application Frame is not used, if that helps. I never liked the Application frame, because it became more like a Windows program than a classic Mac program where you could see your desktop while still in the app and click on the desktop to quickly hide the app. Now I have to use the Application Frame if I don' want that Home screen to pop up every time I close a doc.