Photoshop CC 2019: "disable home screen" not working

  • 17
  • Problem
  • Updated 6 months ago
  • In Progress
  • (Edited)
in the new Photoshop cc2019 the "Disable Home Screen" setting is broken. Even when checked the Home Screen is showing after closing all documents. Photoshop was closed and started again after the setting was changed. 

all running on:
Mac Pro (Late 2013)
OS X 10.12.6

thanks!
Photo of laden m

laden m

  • 188 Posts
  • 35 Reply Likes

Posted 10 months ago

  • 17
Photo of Cristen Gillespie

Cristen Gillespie

  • 1697 Posts
  • 562 Reply Likes
Have you tried rebooting your computer? That worked for me. MBP running High Sierra. I haven't seen it since then. Otherwise, I have no clue how to fix it when you've disabled it in Preferences.
Photo of Olivier MULLIE

Olivier MULLIE

  • 51 Posts
  • 20 Reply Likes
Me too, Mac MOjave, long chat with Adobe, no solution for now, very annoying. I'm using Finder's windows to open pictures as fast as possible. I must click the small red button to close this screen, the time is going to garbage...
(Edited)
Photo of Bianca Alexis

Bianca Alexis

  • 1 Post
  • 0 Reply Likes
same here. mojave on one, sierra on the other. hide home screen is clicked on and it still pops up
Photo of Olivier MULLIE

Olivier MULLIE

  • 51 Posts
  • 20 Reply Likes
Small bad solution : make this home screen like a small vertical strip and put it on th right side of the main screen. When it pops up again it is less obstructive. If you quit and relaunch, boum ! It's big again and on the middle of the screen...
Photo of Kevin Randall

Kevin Randall

  • 1 Post
  • 3 Reply Likes
Same problem. Huge waste of time in a production environment. I hope they fix this immediately.
Photo of Olivier MULLIE

Olivier MULLIE

  • 51 Posts
  • 20 Reply Likes
I spent more than an hour yesterday with Adobe support's guy. He took control of my two Mac (Mac Pro 2010 an MacBook pro 2015, Mojave for each). Same result, not possible to shut off this lousy screen.
Back to CC2018 for me. Too much time lost !!!
(Edited)
Photo of Beelink GT1

Beelink GT1

  • 3 Posts
  • 1 Reply Like
i have same problem i cant close it (HS) with  apple w, only mouse shit. PLS how i disable home srceen after closing documents?
Photo of James Godden

James Godden

  • 3 Posts
  • 0 Reply Likes
Same problem here, very annoying

Photo of Beelink GT1

Beelink GT1

  • 3 Posts
  • 1 Reply Like
My solutions is downgrade to 19.1.6. for now
Photo of Cristen Gillespie

Cristen Gillespie

  • 1697 Posts
  • 562 Reply Likes
> My solutions is downgrade to 19.1.6. for now >

Just wondering, was there nothing at all in 20 that you liked enough to put up with hitting the ESC key when you landed in the Home Screen?

I'm sorry if restarting your computer after disabling the Home screen in Prefs doesn't work for you. I only had to do that the one time, and since then, I can enable or disable the Home screen with a simple restart of Photoshop, not my entire computer, and the problem doesn't return. It still shouldn't happen at all—I'm just saying it didn't turn out to be a really big problem here.

But I'm not using Mojave, only High Sierra. So maybe the biggest problem is there. It's pretty common with a brand new OS to have some bugs in our software show up that weren't huge before.
Photo of Beelink GT1

Beelink GT1

  • 3 Posts
  • 1 Reply Like
yes thanks i uncheck Home screen, ESC work to closed Homescreen, but itsn not good solutions, I need disable it forever. Thanks
Photo of James Godden

James Godden

  • 3 Posts
  • 0 Reply Likes
For me the home screen doesn't appear at startup once it's been disabled in prefs. However once all documents are closed it appears.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1661 Posts
  • 546 Reply Likes
That's exactly what happened to me. Nothing on launch, but there as soon as I closed all documents. Restarting Photoshop didn't fix it—only restarting my entire computer did. That's why I'm wondering if it's different for different versions of the OS. It sounds here like it's a Mac problem, but is it only Mojave that won't respond to a cold boot of the computer?

I haven't seen it come back at all — fingers crossed.  '-}
Photo of Ann Shelbourne

Ann Shelbourne

  • 156 Posts
  • 124 Reply Likes
I would prefer it if we had the option to allow the Home Screen to appear only when we summon it from the Home Button.

If I turn Home Screen off in the Prefs., I don't get the Home button in the Options Bar so I can't summon the Home Screen when I do need it.

Having Home Screen operational, slows down the Ps launch and can interfere with opening or  placing from Bridge.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1661 Posts
  • 546 Reply Likes
Illustrator already did that. Hopefully PS will see that as a bonus to getting users to use the Home screen and implement it. Along with the fact that Recent Files is useless if you accidentally open 20 images, or have to open a lot when you only want a few of those to hang around, etc. So if they also make the list editable, they'll have a real feature there.  '-}
Photo of Olivier MULLIE

Olivier MULLIE

  • 51 Posts
  • 20 Reply Likes
Cristen : Try this with Home Screen disabled in preferences.
Open a picture, make full screen (pretty usefull for working  with two screen, main for image, second for settings panels...).As soon as you close your picture, this damned screen is back and obstructive, you cannot choose an other picture, in Bridge or Finder (if you don't use the Application Frame for fast action !)... Pffff...
Photo of Cristen Gillespie

Cristen Gillespie

  • 1661 Posts
  • 546 Reply Likes
Oh my. You did find it! This is a definite bug. I use the App Frame. Guess what? If I hit the F key twice to go full screen, then Cmd-W to close the image, not only do I get that blasted Home Screen, the ESC key fails to work! How many exclamation points can I use?!!!!! LOL
 
No, no, no. This is terrible. I can get to Bridge, thank goodness, but I shouldn't be there at all with no ESC function, either.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1661 Posts
  • 546 Reply Likes
BTW, I tried this both with and without the Home Screen enabled. Same results, down to the ESC key not functioning. Full Screen view is to be avoided at all costs when you close an image, I guess, until they fix this.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1661 Posts
  • 546 Reply Likes
Well now you all have done it. Made me reenable that Home Screen and Adobe has gone and engraved that Home Screen in stone. Even a cold boot won't remove the dang thing. <sigh> But the ESC key works again. I guess I'll live, but it's a nuisance.
Photo of James Godden

James Godden

  • 3 Posts
  • 0 Reply Likes
Well spotted, the issue only occurs when closing the last open document when in full screen mode. I normally work in full screen so assumed it was happening all the time.
I'm running PS on Windows so it's not an issue that only effects Mac users. Hopefully a fix will be made soon. In the mean time Dale Headrick's action workaround (below) works well.
Photo of Dale Headrick

Dale Headrick

  • 7 Posts
  • 1 Reply Like
Same here, iMac 27 2017 — High Sierra 10.13.6

It's intermittent now (instead of constant) after doing several uninstalls/reinstalls, and using the Adobe ancient file killer utility.  I thought the App Frame On or Off had something to do with it, but turns out not to be the case.  I guess it's just another one of those annoyances we'll have to put up with until the next update.

NOTE:  I've come up with a quick keystroke workaround for this —if you're not having any luck getting rid of it quickly when it pops up on Save and Close— and that is to create an Action that changes your custom Workspace to one of the default Workspaces (I chose Essentials), then back to yours again.  Presto!  It's gone!
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15446 Posts
  • 2281 Reply Likes
You can hit the Esc key to quickly dismiss the home screen.
Photo of Dale Headrick

Dale Headrick

  • 7 Posts
  • 1 Reply Like
Esc doesn't work on my System for some reason—hence the weeping and gnashing of teeth...and the Action.  ;-)

Glad you guys are on it, Jeffrey.

Thanks
Photo of Olivier MULLIE

Olivier MULLIE

  • 51 Posts
  • 20 Reply Likes
When home screen is disabled in preferences, Esc key is unresponsive, uncheck it and Esc key is OK...
Thanks to Jeffrey !
Photo of Dale Headrick

Dale Headrick

  • 7 Posts
  • 1 Reply Like
Perfect!  Thx, Olivier!
Photo of Olivier MULLIE

Olivier MULLIE

  • 51 Posts
  • 20 Reply Likes
You are welcome Sir ! 
<);o)
Photo of Olivier MULLIE

Olivier MULLIE

  • 51 Posts
  • 20 Reply Likes
Thanks for this trick !
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15531 Posts
  • 2315 Reply Likes
Official Response
We're investigating these inconsistent behaviors: restart required, home screen coming back after closing docs even with pref checked. (I can't repro the latter off hand, but I'll try and narrow that down for our engineers)

Ann, we have a story on our backlog to potentially implement the behavior you're suggesting. I think that might be the right approach:

Replace the "Disable the Home Screen" with a new preference "Disable auto-show the Home Screen". When  "Disable auto-show the Home Screen" is unchecked, then the home screen works as it does today (in CC 2019)

When "Disable auto-show the Home Screen" is enabled then the home screen is not shown automatically. It is only shown when the user explicitly clicks the Home Screen button, or chooses the "Home..." menu item

Thank you for reporting and the feedback!
Photo of Milk_Dream

Milk_Dream

  • 30 Posts
  • 0 Reply Likes
Pallete tools  stand on home screen when Ps is open.
Photo of Brandon Adams

Brandon Adams

  • 5 Posts
  • 4 Reply Likes
This seems to only happen when the Application Frame is not used, if that helps. I never liked the Application frame, because it became more like a Windows program than a classic Mac program where you could see your desktop while still in the app and click on the desktop to quickly hide the app. Now I have to use the Application Frame if I don' want that Home screen to pop up every time I close a doc.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1697 Posts
  • 562 Reply Likes
I got a bit tired of the ESC key working only half the time and thought I'd try once again to get back to where the whole thing was turned off until they make the Home button work without being enabled on launch. I decided to uninstall and reinstall, but see if my 2018 Prefs would fix it, so I migrated them. So far, so good. Closing files doesn't switch to the Home Screen. Maybe if I'm lucky, this will hold. . .
Photo of Patrik

Patrik

  • 16 Posts
  • 12 Reply Likes
I also have this problem. Almost every time when closing a document the home screen appears, and the message  "Hi, Patrik. Ready to go? Try drag-and-drop." Not really funny after many hours of work. Please fix this.
Photo of Marcin Gruszczyk

Marcin Gruszczyk

  • 1 Post
  • 0 Reply Likes
Same problem here - Win10, PS CC 2019 German version.
Home Screen displays although it's deactivated in the preferences. As others here have found out, it seems to be related to the full-screen mode. Once it's being used in a PS session the Home Screen will come back, no matter the preferences settings.

This is a major privacy/security problem for me. Working in a professional environment, I NEED the Home Screen to stay disabled in order to avoid accidental NDA violation and similar 'uncomfortable' situations.

Please fix this issue as soon as possible!
Photo of Davee Le

Davee Le

  • 1 Post
  • 0 Reply Likes
I couldn't close it either. However, I was able to get around the pesky homescreen window by resizing it so it's just a skinny bar and move it to a location on the screen where I don't have to look at it. 
Photo of Olivier MULLIE

Olivier MULLIE

  • 51 Posts
  • 20 Reply Likes
Hi guys ! With the last update (Photoshop CC2019 version 20.0.1), you can check "Disable the Home Screen" in pannel "General" of preferences and this problem is forgotten. Photoshop don't open anymore the Home screen (even when you use to work in full screen).
Photo of Murat Ozgul

Murat Ozgul

  • 9 Posts
  • 0 Reply Likes
I have also this problem on Mojave and mine is greyed out. I cant even check it.
Photo of Tom Whittaker

Tom Whittaker

  • 1 Post
  • 0 Reply Likes
Windows 10, Phtotoshop version 20.0.0, this is still bugged, basically the option to disable the "Put your projects into focus" negative workflow home screen, under General->Disable Home Screen; does NOT work if you close the last document AND you have photoshop in full screen mode (eg. by pressing F key)
Photo of eartho

eartho, Champion

  • 1086 Posts
  • 327 Reply Likes
There was a 20.0.1 update a few weeks ago...
Photo of Nelson Faisca

Nelson Faisca

  • 1 Post
  • 0 Reply Likes
I cannot disable the Home Screen!! HELP!!! Nothing works...
Photo of Cristen Gillespie

Cristen Gillespie

  • 1609 Posts
  • 514 Reply Likes
I don't know the solution, but try restarting your computer if you haven't. That worked for me for whatever reason. And in the meantime, the ESC key is your friend. As soon as the Home Screen starts to load, press ESC. That definitely gets you out of there fast.