Photoshop CC 2017: Cannot add color balance adjustment layer in Lab mode

  • 9
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)

Looks like a bug in CC2017 (CS6 and CC2015.5.1 work correctly)


When in Lab image mode, a color balance adjustment layer cannot be added.
Image adjustments color balance does work - but that loses the ability to go back and re-adjust

Dave

Photo of David Richardson

David Richardson

  • 109 Posts
  • 36 Reply Likes

Posted 3 years ago

  • 9
Photo of Cameron Rad

Cameron Rad

  • 156 Posts
  • 48 Reply Likes
Crossposting from the general discussion thread:


I was wondering if anyone else was having this issue or if it's just my end.

 

I tried making a color balance adjustment layer in LAB Mode and was given this error.

"Could not complete your request because that content type is not supported for this color mode"

Screen Shot 2016-11-18 at 51119 PMpng

 

Steps Taken:

Reset Photoshop Preferences - Problem Still occurred

Reinstalled Photoshop CC2017 - Problem Still occurred

Tried using CC 2015/2015.5 - No issues.

Opened PSD in 2017 which included a Color Balance Adjustment Layer from 2015/2015.5 - Was issued the following prompt:

"This document contains unknown data which will be discarded to keep layers editable. To preserve the original appearance instead, choose Flatten to load composite data as a flattened image."

System settings:

 

Mac Pro (late 2013) - osSierra 10.12.1
3 GHz 8-Core Intel Xeon E5
64GB RAM
AMD FirePro D700 6144 MB

Photo of Cameron Rad

Cameron Rad

  • 156 Posts
  • 48 Reply Likes
Bump?
Photo of Cristen Gillespie

Cristen Gillespie

  • 1613 Posts
  • 516 Reply Likes
> When in Lab image mode, a color balance adjustment layer cannot be added.>

Looks like you're right. I rarely use that adjustment in any color mode, but it certainly doesn't add an adjustment layer in LAB mode. I'm on a Mac running Yosemite, so this isn't something we can blame on Sierra.
Photo of David Dobish

David Dobish, Senior QE Photoshop

  • 197 Posts
  • 50 Reply Likes
Thanks for the report.  I am investigating now.
(Edited)
Photo of David Dobish

David Dobish, Senior QE Photoshop

  • 197 Posts
  • 50 Reply Likes
This is indeed a bug.  Thank you for the report.
Photo of Cameron Rad

Cameron Rad

  • 156 Posts
  • 48 Reply Likes
No problem! Thank you guys for working on it! :)
(Edited)
Photo of Dashiell Rose Bark-Huss

Dashiell Rose Bark-Huss

  • 2 Posts
  • 0 Reply Likes
this is still not working. When will this bug be fixed?
Photo of Junweon Park

Junweon Park

  • 4 Posts
  • 2 Reply Likes
Anyone from Adobe, please pay attention to this issue!!!!!
Photo of Chris Beatrice

Chris Beatrice

  • 1 Post
  • 2 Reply Likes
Seriously? $240 a year, just upgraded from CS6, and now I can't open my old .psd files because they have color balance layers and I always work in Lab mode. Do you guys beta test?
Photo of Darren Richards

Darren Richards

  • 5 Posts
  • 2 Reply Likes
This still doesn't work after the most recent update ... very disappointing !
Photo of Junweon Park

Junweon Park

  • 4 Posts
  • 2 Reply Likes
Please fix it as soon as possible. I cannot work with my psd files.
Photo of Dashiell Rose Bark-Huss

Dashiell Rose Bark-Huss

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Can't Add Color Balance Adjustment to Lab Color Mode Bug.

There's a bug in my Photoshop CC that was spoken about 3 months ago, but it still hasn't been fixed.

When in Lab Color Mode I get this error "Could not complete your request because that content type is not supported for this color mode." when I try to add a Color Balance Adjustment Layer.

It was discussed here: https://feedback.photoshop.com/photoshop_family/topics/photoshop-cc2017-cannot-add-color-balance-adj...

The official response given was that it was a bug. 

This was 3 months ago and I'm still getting this error. Has this bug not been fixed? When will the issue be corrected? 3 month is a long time for a bug to exist when we are paying by the month.

Photoshop 2017.0.1 macOS Sierra 10.12.3
Photo of Darren Richards

Darren Richards

  • 5 Posts
  • 2 Reply Likes
Another update today and this still isn't fixed - very disappointed that core functionality like this doesn't merit attention.
Photo of Junweon Park

Junweon Park

  • 4 Posts
  • 2 Reply Likes
If it is true, maybe David(Senior QE Photoshop) above doesn't work at Adobe anymore. Anyone from Adobe, please pay attention to this issue!!!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15366 Posts
  • 2241 Reply Likes
Official Response
Photo of David Richardson

David Richardson

  • 109 Posts
  • 36 Reply Likes

Hi Jeffrey
Thank you. I can confirm it is working here now on v19.0

Dave

Photo of Darren Richards

Darren Richards

  • 5 Posts
  • 2 Reply Likes
This was the first thing I tested after installing PS 19 :-) Thanks for fixing, very pleased to have it back.