Photoshop CC: Why are warp, puppet warp and perspective warp greyed out?

  • 1
  • Question
  • Updated 6 months ago
  • (Edited)
I'm creating some artwork with multiple layers some of which I need to warp using the normal and/or puppet warp control. I've just brought the last layer in to finish the design and for some reason the warp, puppet and perspective warp controls are greyed out. I've reset PS and it hasn't fixed it. Why is it doing this and how do I fix it? Searching the forum just brings up a solution to do with graphics card processors, I'm using a brand new iMac which was warping fine until about an hour ago so I don't think it's a graphics card issue.
Photo of Jo Elkington

Jo Elkington

  • 1 Post
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Khazaad

Khazaad

  • 14 Posts
  • 2 Reply Likes
Are you trying to warp the background layer?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2367 Reply Likes
Is "Use Graphics Card" disabled under Preferences>Performance...?
Photo of Patrick Allen

Patrick Allen

  • 2 Posts
  • 0 Reply Likes
Thank you, rather than trying all the technical glopidy goo, I simply did what you suggested and walla my problem is fixed.
Photo of Frederik Teodor Toft

Frederik Teodor Toft

  • 1 Post
  • 0 Reply Likes
Awesome! 
Photo of Stewart McAlpine

Stewart McAlpine

  • 1 Post
  • 0 Reply Likes
Works like magic. Stewart
Photo of Denise Duran

Denise Duran

  • 1 Post
  • 0 Reply Likes
My graphics card setting was set to BASIC, when I changed it to normal PUPPET WARP was available. PERSPECTIVE WARP is still greyed (I changed the setting to advanced--still greyed). All l I needed with puppet warp, so THANK YOU!
Photo of Tomislav Brtan

Tomislav Brtan

  • 1 Post
  • 0 Reply Likes
I had the same problem. Turns out I had a work path selected. Make sure the work path is unselected.
Photo of Danny Moriarty Photog

Danny Moriarty Photog

  • 1 Post
  • 0 Reply Likes
What do you mean work path selected?
Photo of Miguel Xilo

Miguel Xilo

  • 1 Post
  • 0 Reply Likes
that was my issue as well