Photoshop CC: Slow ALT key response for setting clone sampling area

  • 2
  • Problem
  • Updated 2 months ago
  • (Edited)
While working with tools like stamp and healing brush in Photoshop CC I find that the responsiveness of the ALT key for sampling is very very slow compared to earlier versions like PS CS6. 

For retouching work it is imparative that there can be sampled and drawn consecutively very fast, which means I am sampling a different area often faster than a second. For some reason it takes Photoshop quite a long time to register the ALT command which leads to no new sampling area when it is done very fast. It often takes Photoshop longer than a second to register the use of the ALT key. For instance when I press the ALT key 10 times very fast it will only convert to the crosshair about 4 times.

Some people have already mentioned that it could have something to do with the multiple options the ALT key has, such as the shortcut for ALT Menu (a problem that goes back many years), and that this possibly might interfere with the use of the crosshair sampler. A workaround with thirdparty programs is not a route I want to take though, as I feel it is something that can be fixed by Adobe very easily if they were aware of the issue.

I am curious if other users also experience this lag or delay in the responsivness of the ALT key when sampling. And what might be a possible solution. However I feel it is an issue inside of Photoshop that came with the newer versions of Photoshop itself.
Photo of Jonathan Vorsselman

Jonathan Vorsselman

  • 2 Posts
  • 0 Reply Likes

Posted 9 months ago

  • 2
Photo of inkyneil

inkyneil

  • 2 Posts
  • 2 Reply Likes
I'm having the exact same issue even though I have a really fast PC.
Photo of Kit Kerner

Kit Kerner

  • 83 Posts
  • 24 Reply Likes

For me PS V19, V20 is slow, real slow. I was using V18, no problems and suddenly found myself with V20. Adobe Technical Support helped me back V20 out (it was  b r o k e n  ) and now V19 is what I have. I have bumped up my memory and given the scratch disk more space too (terabyte). That is the short story. PS is now running faster, but not what I was used to and many of my issues seem to be resolved. I cannot believe it was ALL me. I'm almost ready to post the rest of my story and maybe we all can post good news instead of bad. I know for a fact that Adobe reads the surveys and this page, so keep it coming. Good Luck!
Photo of Calvin Smith

Calvin Smith

  • 3 Posts
  • 1 Reply Like
ive got the same problem, cant find the fix
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2367 Reply Likes
If you hide Rules, does the response improve?
Photo of Calvin Smith

Calvin Smith

  • 3 Posts
  • 1 Reply Like
I have been testing your suggestion a little bit this morning and so far, no noticeable improvement with rules turned off, its like it takes half a second too long, before was a super quick click and the clone stamp and healing brush got the area, now I find myself having to undo as I messed up as the clone stamp didn’t catch the selected point and redo, very annoying




Photo of Warren Bernard

Warren Bernard

  • 1 Post
  • 0 Reply Likes
I have the same issue. I can move an ordinary tool (like the eraser for example) around quite easily with no lag at all. However, whenever I use a sampling tool like the clone or healing brush, the brush's movement lags as soon as I press the ALT key to sample. Which often results in me sampling an incorrect area as I move quite quickly. I've tried the disable ruler fix as well as disabling the Preserve Details Upscale option as someone suggested, but nothing helps. I've assigned more than enough memory and scratch disk space to PS  too so I'm out of options sadly. Did not have any issue like this with a previous version of PS installed on the same system with the same resources.
(Edited)
Photo of Jonathan Vorsselman

Jonathan Vorsselman

  • 2 Posts
  • 0 Reply Likes
I found a comment somewhere that related to this problem, which may have solved it for me. I am still cheking if it removes the whole issue. 

The person suggested to turn off the express keys of the tablet related to the ALT (and or SHIFT key etc.) in the Wacom settings panel. When setting the function of those keys to 'turn off' I feel there is less of a lag in the ALT click sample area.

Let me know if this also works for you. 

Be wary that with a wacom driver update the settings may automatically be set to standard again.
Photo of Calvin Smith

Calvin Smith

  • 3 Posts
  • 1 Reply Like
this happens to me with and without Wacom,

e.g. before I install the drivers and wacom tablet my mouse has the same issue,