Photoshop CC: Save (as) leads to general error

  • 1
  • Problem
  • Updated 3 years ago
It is related to "invalid" creation date of original jpg file.

How to induce:
Get some jpg with default creation date 1970-01-01 (it happened to my file when copying it thru network media center - probably not set correctly after outage)
Open it in Photoshop (no error occurs)
Make some change and try to save it.
-- General error is shown.
-- It is not possible even save the changes as .psd

Everything starts to work fine after changing all timestamps of the file to current date. It took me sometime to find out what is wrong and I lost my previous changes.

Expected behavior:
1) no error
or 2) detection of such problematic file on open
or at least 3) specific error with explanation (and solution)
Photo of Helena Panikova

Helena Panikova

  • 3 Posts
  • 0 Reply Likes
  • sad

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Can you email a file with that issue to ccox (at) adobe (dot) com? I'll try to reproduce the error and see if we can narrow down the cause.

And what OS version are you using? (sometimes the OS date functions have different bugs)
Photo of Helena Panikova

Helena Panikova

  • 3 Posts
  • 0 Reply Likes
Unfortunatelly, it is not possible to send you the file. I tried to send it to myself (both zipped and unzipped) thru email and no bug occurs. It seems that such operation "fix" the file somehow.

So here are some DETAILS.
Windows 10 (build 10240) - upgraded from win 8.1
Adobe Photoshop: 2015.0.1 20150722.r.168 2015/07/22:23:59:59 CL 1032107 x64
Double commander 0.6.0 (beta) build 5850M used for moving the file from storage

TEST FILE INFO
PSPath : Microsoft.PowerShell.Core\FileSystem::D:\temp\test.jpg
PSParentPath : Microsoft.PowerShell.Core\FileSystem::D:\temp
PSChildName : test.jpg
PSDrive : D
PSProvider : Microsoft.PowerShell.Core\FileSystem
VersionInfo : File: D:\temp\test.jpg
InternalName:
OriginalFilename:
FileVersion:
FileDescription:
Product:
ProductVersion:
Debug: False
Patched: False
PreRelease: False
PrivateBuild: False
SpecialBuild: False
Language:

BaseName : test
Target :
LinkType :
Mode : ------
Name : test.jpg
Length : 991920
DirectoryName : D:\temp
Directory : D:\temp
IsReadOnly : False
Exists : True
FullName : D:\temp\test.jpg
Extension : .jpg
CreationTime : 1. 1. 1970 1:01:15
CreationTimeUtc : 1. 1. 1970 0:01:15
LastAccessTime : 19. 8. 2015 8:24:33
LastAccessTimeUtc : 19. 8. 2015 6:24:33
LastWriteTime : 19. 8. 2015 8:24:33
LastWriteTimeUtc : 19. 8. 2015 6:24:33
Attributes : Normal

Maybe I could provide the debug logs if you tell me how to enable it?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
There are no debug logs for something like that -- I would have to debug it in VisualStudio.

But, knowing that it is Win10 gives us a place to start trying to reproduce the error.
Photo of Helena Panikova

Helena Panikova

  • 3 Posts
  • 0 Reply Likes
Well, that's a pity. But I just found there is probably something wrong with the Photoshop CC build.

I was curious so I tried to open the file on my previous laptop with win 7x64, Adobe Photoshop verze: 14.2.1 (14.2.1 20140207.r.570 2014/02/07:23:00:00) x64. The file could be saved normaly. I thought it is windows related but just to be sure I updated the Photoshop to latest build 2015.0.1 20150722.r.168 2015/07/22:23:59:59 CL 1032107 x64 and the error occurs.

I hope this will help.