Photoshop: Displays images much smaller than they are

  • 1
  • Problem
  • Updated 1 month ago
  • (Edited)
Using Photoshop CC 21.1.3 on Microsoft Surface Book 2 with Windows 10 pro. 
I tried to change the presentation preferences but it has no effect at all.



Any suggestions?





Photo of Nataly Tuvia

Nataly Tuvia

  • 6 Posts
  • 1 Reply Like

Posted 2 months ago

  • 1
Photo of Todd Shaner

Todd Shaner, Champion

  • 1957 Posts
  • 660 Reply Likes
Photo of Nataly Tuvia

Nataly Tuvia

  • 6 Posts
  • 1 Reply Like
It didn't work for me but I found another solution
Thanks :)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17056 Posts
  • 2901 Reply Likes
What you are seeing is the browser is interpolating the image up to 200%. In Photoshop, the document window always displays 1pixel equals 1 screen pixel -- and doesn't scale the contents of the document window - only the user interface.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1957 Posts
  • 660 Reply Likes
The size of the PS document window is dependent on the display resolution. On the 2nd computer check Windows 'Display Settings.' What are the 'Change the size of text, apps, and other items' and  'Display Resolution' settings? Also just below that setting click on 'Advanced scaling settings' and in the 'Custom Scaling box is there a value entered. If it's showing as 100 - 500 then no value is entered, which is what you want. Do the same on the Microsoft Surface Book 2 to compare settings and the actual display resolution. Post them here in a reply.

The all UI is smaller than any other photoshop I've worked on also.
In PS Preferences> Interface> Try changing the 'Presentation' settings for UI Scaling, UI Font Size, and Scale UI to Font. You  need to close and restart PS for the changes to be applied!
Photo of Nataly Tuvia

Nataly Tuvia

  • 6 Posts
  • 1 Reply Like
ok, I checked a third computer with the same results:

Acer Swift 3, windows 10 pro, Photoshop CC 21.1.3









my computer, same windows, same photoshop:












I also try to change the scale of my computer to 100% and 125% even it's not the recommended scale for my screen, it didn't have any effect on the image size on photoshop.

 
so by now, I compare my computer with 3 different computers, all three of them are showing the same 500px image, only my computer shows a tiny image.
Please can you tell me why is it so hard to believe the scaling is wrong? what am I missing here? 
Thanks

In PS Preferences> Interface> Try changing the 'Presentation' settings for UI Scaling, UI Font Size, and Scale UI to Font. You  need to close and restart PS for the changes to be applied!

I did that as i show at the original post, it didn't do nothing at all, no impact on the UI 
Photo of Todd Shaner

Todd Shaner, Champion

  • 1957 Posts
  • 660 Reply Likes
Please can you tell me why is it so hard to believe the scaling is wrong? what am I missing here?
As both Jeffrey Tranberry and I explained PS document window does NOT scale using Windows display scaling settings. It will always display the image as 1 to 1 pixels. So why is the 500 x 500 px image in the PS document window bigger on other computers? Let's take the two examples you showed above.

Acer Swift 3                      1920 x 1080  Screen size 500/1080 = .46 screen height
Microsoft Surface Book 2  3240 x 2160  Screen size 500/2160 = .23 screen height

So the 500 x 500 px image file will appear twice the size (.46/.23) on the Acer Swift 3. Other photo viewers may use Windows scaling settings. You have your Microsoft Surface Book 2 set to 200% Scale & Layout so images will appear in those apps twice as large.

We could save a lot of time here if you can explain exactly HOW this is causing an issue working inside PS. You can simply increase the Zoom View size (CTRL + +) or use Fit On Screen (CTRL + 0) to make the image larger onscreen. The only other option is to change the display resolution in Windows Display settings to 1920 x 1080, which would also increase the user interface size.


I tried to change the presentation preferences but it has no effect at all.
The changes only take effect when PS is restarted. After each change you made to the Presentation Preferences did you close and then reopen PS?

Try searching and posting in Photoshop forum for further help with this high dpi display user interface issue. Perhaps someone has other ideas. I suggest keeping the new post separate from the document size discussion–The two are mutually independent.

https://community.adobe.com/t5/photoshop/bd-p/photoshop
Photo of Nataly Tuvia

Nataly Tuvia

  • 6 Posts
  • 1 Reply Like
 You can simply increase the Zoom View size (CTRL + +) or use Fit On Screen (CTRL + 0) to make the image larger onscreen"

If you zoom a small image more then 100% it gets blurry, This is not best practice to work on Photoshop.


The changes only take effect when PS is restarted. After each change you made to the Presentation Preferences did you close and then reopen PS?"

Of course, I restarted PS, I opened an closed it after each change I did. it just has no effect.


My only solution for that problem is to change the display resolution to a much lower resolution (1920x1200) and not on the recommended (3240x2160).


As I say it's a known problem, you can find a lot of complaints about this issue online. it's really hard to work on images that small. I wish PS had a good solution for that.

Thank you for trying to help anyway.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1957 Posts
  • 660 Reply Likes
If you zoom a small image more then 100% it gets blurry, This is not best practice to work on Photoshop.
This is why PS and LR always display images 1 for 1 pixel. Scaling the image larger in ANY application will make it less sharp due to interpolation. Read the "Correct Answer" in the below PS discussion. It references the Mac Retina display, but is fully applicable to your Microsoft Surface Book 2 high-definition 4K display.

https://community.adobe.com/t5/photoshop/100-zoom-is-too-small-on-screen-designers-don-t-get-high-re...

My only solution for that problem is to change the display resolution to a much lower resolution (1920x1200) and not on the recommended (3240x2160).
You'll need to determine what type of display your target audience will be using to view your PS edited images. If you see them as "small" and your viewing audience is using a similar 15" or smaller high-def display they will see it as small. Of course they can upscale the images by increasing the viewer app or browser's Zoom View size to 200%, but then the images will look soft! Here's a solution for images that will be posted on the Web.

https://www.creativebloq.com/advice/4-tips-for-designing-a-4k-ready-website