Photoshop CC - black overlay appearing on Liquify when checking Use GPU

  • 1
  • Problem
  • Updated 2 years ago
So I've bought my fancy new PC specifically for Photoshop & the rest of CC (got the full subscription). Everything seemed to be working ok - I've got a GTX 970 GPU, i7 processor and 32GB RAM, so there shouldn't be anything hardware-wise that's really causing an issue. I keep my drivers up date with the Geforce Experience add-on, so this shouldn't be a problem either. 

However, when I load up Photoshop I get this when I'm using the GPU for performance enhancing: http://i.imgur.com/GN2y4eU.png (both in 2015 and the latest 2017 version). 

If the screen is minimised at all (say 3/4 of the screen) then there's a black border when I maximise. This also happens when I go into liquify every time (there's a 3/4 black "block" and I can only see a quarter of the screen). I zoom in and out, the black border remains the same size, so it's effectively cutting out the screen for me. I've changed my cache level to 8, changed cache tile size to 1028k (and every other variant) but it's still happening every time. 

If I start in fullscreen, then it can work, but still repeats the same issue every time I go into Liquify. I've tried my google-fu and couldn't find anything apart from this query.

Here's an excerpt from my PS system info (not sure what's relevant here, so let me know if there's anything else I'm missing):

Adobe Photoshop Version: 2017.0.1 20161130.r.29 2016/11/30:23:00:00 CL 1099099  x64

Number of Launches: 2

Version: 10 or greater

System architecture: Intel CPU Family:6, Model:14, Stepping:3 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, AVX, AVX2, HyperThreading

Physical processor count: 4

Logical processor count: 8

Processor speed: 4008 MHz

Built-in memory: 32692 MB

Free memory: 2 MB

Memory available to Photoshop: 29475 MB

Memory used by Photoshop: 69 %

History Thumbnails: Enabled.

This has been with me for months, and I've tried every variant I can think of - I want to be able to use the GPU additions to boost my Photoshop productivity - any suggestions would be very gratefully received, as this has been so frustrating. 

Photo of Rich Emmerson

Rich Emmerson

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Michael Madsen

Michael Madsen

  • 26 Posts
  • 4 Reply Likes
I guess you're out of luck for the time being.  2017.0.0 had horrible GPU issues with both AMD and nVidia cards. I personally had to disable GPU acceleration on 2017.0.0.

Some of the kinks got ironed out with 2017.0.1 but apparently not all. 

Again, only thing you can try is fiddling with preferences > performance and Graphics Processor Settings. 
Personally, I wouldnt bother - even if you get it to work it could be VERY unstable and causing crashes.
Just disable it. The performance gains with GPU enabled is for MOST usage scenarios not a big deal anyways.

Not to worry - for as long as Photoshop has had GPU acceleration it has been an absolute horrorshow of poor implementation. Adobe has never shown any clear direction or commitment to get it right - if thats even possible without prohibitively costly rewrite of LOTS of legacy and old code.

Hence the option to disable it altogether. 

Eventually Adobe will get it sorted in a future update.
(Edited)
Photo of Rosa

Rosa

  • 110 Posts
  • 38 Reply Likes
Hi Rich, I get the same problem when using the Camera Raw Filter in Photoshop. Like you I've got a GTX 970 GPU, i7 processor and 32GB RAM and had my PC built especially for designing graphics. So we know it's not our gear and as Michael mentioned it's a problem that Adobe is responsible for.