Photoshop CC: Automatically flattens my layered files

  • 2
  • Question
  • Updated 2 weeks ago
  • (Edited)
Photoshop CC automatically flattens my layered files. I save the psd file, flatten it and 'save as' jpg/tiff whatever I need. When I reopen the psd file, it is flattened. At first I thought I used saved and not "saved as", but I have subsequently done 4 tests with the same outcome. Can someone please help?
Photo of Alison Gouws

Alison Gouws

  • 2 Posts
  • 0 Reply Likes

Posted 6 months ago

  • 2
Photo of Serrada

Serrada

  • 9 Posts
  • 1 Reply Like
Hallo! Simply do not flatten the psd-file before 'saving as' (because in the preferences you have probably some settings that save your file in the background). When saving as 'tif' you can chose whether to flatten the file or not (box 'save image pyramid'). When saving in jpg the file is normally flattened automatically.
Alternative: Go back in history of the "psd" to the non-flattened stage and then save this stage.
Easy! No?
Photo of Alison Gouws

Alison Gouws

  • 2 Posts
  • 0 Reply Likes
I discovered this Photoshop issue only after the psd file was closed, so I couldn't go back in history. Also, it never used to do that. This is a new problem after the latest "update". I haven't touched the settings in yonks, so it's not anything I changed on my side.
Photo of Max Johnson

Max Johnson, Champion

  • 399 Posts
  • 171 Reply Likes
@PJ Coller, I appreciate you offering a workaround until a real fix can be added. 

@Adobe, that's not a "simply" solution. Any destructive action that saves over an existing file should require user input. Either manually re-saving, or a dialog that warns that it is auto-saving over top of your current file (not the same as auto-backup.. that's a recovery solution and should not be saving over your working file).

Assuming this happens to more than just Alison, having to remember a work-around every time you save-as in order to preserve your master copy is not acceptable.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1074 Posts
  • 285 Reply Likes
> I discovered this Photoshop issue only after the psd file was closed, so I couldn't go back in history. Also, it never used to do that. This is a new problem after the latest "update". >

I'm not seeing anything at all different between 2018 and 2017. If I save a file as a PSD, then flatten it and save it as a TIFF and JPEG, I have all 3 files on disk. I can reopen my layered PSD. The file that is currently open is, of course, the JPEG or TIFF, since I had chosen to save the file AS a JPEG or TIFF.

Is it possible youhave a problem with either your OS and 2018, or with corruption somewhere? Is anyone reading this able to replicate the issue?

I don't take that circuitous route to save my flattened files, though. I don't flatten the PSD first. I simply use Save As for JPEG, which always saves a copy, and Save As with Layers disabled (unchecked) in the TIFF dialog so it forces it to save a copy. My PSD is still open, still ready for me to do whatever I want, including Save Save or Save As, if I haven't, and closing it. It just feels a lot more comforting to always know I won't lose my layered file. Using the step back in History routine is for when I totally screw up.<G>
Photo of Rebecca Wong

Rebecca Wong

  • 1 Post
  • 0 Reply Likes
I have the same issue. Just opened the psd file as usual and all of my layers were flattened into the background layer when I opened it.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1074 Posts
  • 285 Reply Likes
If there are two of you having this problem suddenly and you can replicate it, we should know what OS you're using and are you also using 2018?, as well as your steps to save the file, so Adobe has something to look into. It's not an issue on my Mac running El Capitan.
Photo of Susanne Loomis

Susanne Loomis

  • 2 Posts
  • 0 Reply Likes
Any solutions? I am having the same problem. I go to save as and when I look my layers are flattened.
Photo of Laura Wahlgren Best

Laura Wahlgren Best

  • 1 Post
  • 0 Reply Likes
I also have this problem and it's terrible. It's been like this ever since I started using PSCC a few weeks ago. It kinda makes using PS almost useless if my files are automatically getting flattened every time I use it. I am on a Surface Pro 3
Photo of Trent Schumann

Trent Schumann

  • 1 Post
  • 0 Reply Likes
Same here. When I save as a JPG (even without flattening it before saving) and then save as a PSD, it also flattens the PSD.
Photo of Clinton Avery

Clinton Avery

  • 1 Post
  • 0 Reply Likes
Photoshop just did this to me and more, I "saved as" under a different file name and that new file was flattened and somehow it also saved the current state of the original file as well. I just lost all my layers after hours of painting for class, the way it just saved makes no sense and I did not make a mistake and save over it myself.
Photo of Susanne Loomis

Susanne Loomis

  • 2 Posts
  • 0 Reply Likes
Doesn't seem like they care if this is corrected.

Clinton Avery - did you close the file after saving? I found that I check everything before closing because you can undo if you need to do that. 
(Edited)
Photo of Mercedes Taylor

Mercedes Taylor

  • 1 Post
  • 0 Reply Likes
I know this has been on for two months but it recently happened to me and I found a solution. Normally I create all my files in Illustrator but I needed to create something in Photoshop. I used the layers and folders like normal. I saved it as a PSD. Then I saved a copy as a PDF and saved my document again as a PSD so no flattening would occur. Well it still flattened it, even with the layers still present and saving as a PSD.

The problem I found occured when saving as a PDF as the settings are being changed because a PDF doesn't have layers within Acrobat Reader. 

So after you save your file as a PDF or anything that could destroy the layers. Go back in and save it as a PSD, but remember to then check the layers box below the document type to keep all your layers!

I don't know why Adobe doesn't have it to be automatically triggered, or if it is something in my settings that I need to correct.

Anyways I hope this helps someone!