Photoshop CC 2020 Brush Engine Performance Bug : stroke processing lag over time

  • 1
  • Problem
  • Updated 3 months ago
Greetings guys. 
I noticed an issue as I tried Photoshop and it seems to be software related.
First here are my main specs : 
CPU : core i7 3610QM @ 2.30GHz
GPU : Nvidia GT 640M
RAM : 6 GB
OS : Windows 10 1909

Photoshop version is CC 2020, v21.0.2 release.

The issue is with the brush engine. Single stroke performance definitely needs deep optimization, because with my specs, I do the same thing in Clip Studio Paint, but in contrast to Photoshop, stroke performance is very very smooth in CSP, even when I scribble fast with a thin 9 pixels brush on a 4K canvas.

Anyway, here's how I could describe the issue : 

Over time, the processing of a single stroke becomes exponentially slow for a reason I don't understand. Legacy Compositing is on and graphics performance mode is set to Basic(i also tested in Advanced mode and it was the same).
From Photoshop 2017 up to now, I always noticed that, but it became even worse with the current version of the software.
This test that I did requires a simple 9 pixels brush, opacity set to pen pressure, spacing set to 10% and a FHD or 4K canvas. Using a single stroke, it initially starts fairly smooth, but very quickly over time, it slows down. I've been scribbling over my canvas for about 24 seconds, quite fast, and after doing so, the software spent more than 1 minute and 10 seconds processing the stroke before stopping(This is insane !).
So your devs definitely need to do something to optimize this. I don't know for you but it's bad and should not be ignored. 

I remembered about it today and thought I should report this problem which is apparently software related more than anything else. Please, see for yourself.  

It would be all for the issue. I would ask for the concept of new features like Perspective Painting tools aside from the current Symmetry painting tools, but I'm pretty sure you're already aware of it.
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
  • Indifferent

Posted 3 months ago

  • 1
Photo of Dave Grainger

Dave Grainger

  • 497 Posts
  • 92 Reply Likes
Six gigs of RAM? Do you mean video RAM, or do you mean the motherboard has six gigs for the system?

On the MB, that is an odd number. it goes 1,024 then 2,048, then 4,096, then 8,192.  If you really do have six installed, then you have added mismatched memory or you purchased a refurb from a place like Staples or Office Depot. They were for a while having refurbs for sale, posing as new, which they bought from a third party refurbisher. (I actually found a number of those from my customers that still had the prior owner's photos and documents on their drives; the refurb place hadn't actually done much more than wipe the nose prints off the screen...)

Mismatched in speed or ECC or other things can cause all sorts of program "misfires" . Legit computer manufacturers use matched RAM from the same lot number... There is a reason.

In any case you have an inadequate amount of memory to run Windows and Photoshop if you really do have six. The PC has to swap out to disc, "Virtual memory" when there is insufficient actual RAM. That is very considerably slower than it would be were the RAM  much greater.

Another question: was this a computer on which you had a prior version of Windows, and then put on 10 when Microsoft went on that heavy campaign to get people to switch up to Windows 10? That could explain why you have less RAM than Windows 10 should have as a minimum.

One more thing: it appears that you are several versions behind in updates for Photoshop.

I really doubt that your problem is software related, based on your description.

Photoshop is a very large amount of code. You appear to be trying to use a wheelbarrow sized computer to haul huge boulders of program. Swap-to-disc appears to be causing your slowness problem. I am amazed that Windows isn't crashing!
(Edited)
Photo of Dave Grainger

Dave Grainger

  • 497 Posts
  • 92 Reply Likes
Another thought: have you ruled out malware? If you are relying on Windows Defender, or something like Avast, you are essentially unprotected.  You could download a trial of MalwareBytes and run it; you might be amazed at what is lurking!

Your graphics circuit dates from 2012 and is made for a laptop. It uses system RAM, so that 6 gigs that you mentioned is shared between the CPU and GPU.
(Edited)
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
It's 6 GB of physical RAM installed. 
Also I trust none of your suggestions. Because my issue is software related I'm telling you.
After all, I'm talking about brush engine performance. Not my PC.
If you don't know much about the software code, don't "assume". 
Do you have a drawing tablet or a mouse ? 
If you do, open Photoshop and do the test.
Stroke your canvas, scribbling very fast without releasing your stroke for at least 20 seconds. And see if the brush stroke quickly catches up with your cursor.
Photo of Dave Grainger

Dave Grainger

  • 497 Posts
  • 92 Reply Likes
OK. You don't. Why did you ask for help?

FYI I have forty years experience starting with the release of the IBM PC product.

You have an underequipped computer. That's it.
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
Leave my computer for a moment. Have you made the test or not ?
Photo of Dave Grainger

Dave Grainger

  • 497 Posts
  • 92 Reply Likes
Once was a fellow who was experiencing weird symptoms, who went to the doc. After a lot of study, the MD took him into his office, sat him in a chair, and said "Sir, I am very sorry to inform you that you have cancer." The patient jumped out of his chair, and said "Doc! You are just going to have to find another diagnosis! That one is too expensive!"

Also FYI, I don't work here, am a user of Photoshop. I am not going to setup and recreate your problem. There might be another Doc that will chime in and find you another diagnosis; I hope it works out for you!
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
It's much better now ! That's the only thing you needed to answer since the beginning ! Damn !
Learn to better filter the information you provide. You waste too many words. 
Alright, have a good day.
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 2003 Posts
  • 672 Reply Likes
"Over time, the processing of a single stroke becomes exponentially slow for a reason I don't understand. Legacy Compositing is on and graphics performance mode is set to Basic (i also tested in Advanced mode and it was the same). This test that I did requires a simple 9 pixels brush, opacity set to pen pressure, spacing set to 10% and a FHD or 4K canvas. Using a single stroke, it initially starts fairly smooth, but very quickly over time, it slows down."

Using my Wacom Intuos 4 tablet with the above PS settings on my Windows 10 system with PS 21.1.2 I see no lag whatsoever. Your graphics card is very low performance. Try unchecking 'Use Graphics Processor in Preferences, close and reopen PS, and see if that helps.


Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
Nope, it didn't help.
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
The reason I assume it's a software issue is because, Clip Studio Paint and Autodesk Sketchbook which are also drawing softwares, are very smooth with my specs too.
What are your specs ?

Anyway, I suspect there might be a level of standards regarding optimization. 
Photoshop in my opinion is poorly optimized now. Minimum requirements state that a GTX 1050 is necessary to run the app. That doesn't make sense for minimum requirement ! 
Not everyone can afford a gaming laptop. 
They should go about at least 6 years in the past to better handle optimization. 
a GT 700 series nvidia gpu, in my opinion, should be the minimum requirement for Photoshop's current version.
Photo of Todd Shaner

Todd Shaner, Champion

  • 2003 Posts
  • 672 Reply Likes
I just checked  Windows Resource Monitor and PS is using 5.2 GB of  system memory (7.2 GB Total Usage) after the above test with a 4096 x 2160 canvas. You only have 6 GB, which will cause PS to use scratch disk based Virtual memory. This will slow down performance in PS. I suspect simply adding more memory should help with 16 GB minimum suggested.
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
If Photoshop needs a minimum of 16 GB before rendering smoothly a brush stroke in real time, then the software has serious optimization issues ! And it certainly has something to do with its code, something to do with the way it renders brush strokes. 
And I'm talking about rendering the stroke of a tiny 9 pixels brush. 
This is totally insane. I added 6 GB more of physical RAM memory. And guess what : no improvement at all ! 
If you don't notice anything, it might be because you have a high end specs PC. Probably one with a good GPU(GTX 900 series or better).
See, rendering performance isn't much impacted by RAM. The processing of the graphics is handled by the GPU, and you should know that. Proof to that is my test with the other drawing softwares : CSP, Sketchbook, Medibang, Krita. Especially with Krita and CSP as they use more resources, even on a big canvas(5000 x 3000), the rendering of my brush stroke doesn't lag over time. 
And this the very reason I'm still not changing my mind : Photoshop's code needs tons of optimization ! The better it's optimized, the better it will perform on older hardware. And if it better performs on older hardware, forcefully, it will perform even better on newer hardware. 
(Edited)
Photo of Dave Grainger

Dave Grainger

  • 497 Posts
  • 92 Reply Likes
That is exactly what I was trying to tell him.... Inadequate hardware, not a software issue. He blew me off... That PC may not support enough memory... As a laptop, his GPU is sharing that 6 gigs of RAM, so there is no way he could get decent performance...
(Edited)
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
To further test things out I added 6 more Gigs of RAM, and nothing changed. 
The computing of the graphics happens essentially with the GPU so I'm not surprised there were no improvement. Yes, 12 Gigs of RAM this time but no improvement at all !
One conclusion is : my GPU is just too old(I can understand when they say minimum requirement is the equivalent of a GTX 1050 GPU)...

Another conclusion would be : the software's code is not much touched regarding the brush engine, or the way it handles memory. 
Photo of Todd Shaner

Todd Shaner, Champion

  • 2003 Posts
  • 672 Reply Likes
1) I tired the same test with 'Use Graphics Processor' unchecked in Preferences with restart of PS and still no lag. Check for an update to the graphics drivers on the laptop manufacturer's website. Sometimes older drivers often don't work well with newer app versions.

2) Also check that you have PS Preferences> Performance> 'Memory Usage' set to use at least 8,000 MB. You need to restart PS for the setting changes to be applied.

3) A quick Web search for "slow brush" identified the Smoothing setting as a possible cause. Suggestion is to set it to 5% or less. Mine was set to 0% and increasing it to 50% produced brush lag of ~ 2sec catch-up after stopping, but my system specs are way higher performance than yours.

3.7 GHz i7-8700K six core
Nvidia Quadro P2000 5GB VRAM
32 GB System Memory
1 TB NVMe SSD4 TB 7200 RPM HD
Windows 10 1903
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
Thank you sir.
Wow. You do really have higher specs.
I'll have to work hard before I get a better machine myself.

When I un-checked "use graphics processor", I had a bad, nightmare-ish kind of performance. Things were even slower.
About my graphics drivers. I'm actually using the latest version provided by Nvidia. 
What I did is, uninstall then re-install Photoshop. 
After doing so, lag was reduced a little, but just a little. 
Now I have another hypothesis : aside from the fact that I use older hardware, a hidden problem in my pc is making things slow. 
I'd have to seek for it myself.  

By the way, is there any place we could fill a form to  give feedback to Adobe ?
Photo of Todd Shaner

Todd Shaner, Champion

  • 2003 Posts
  • 672 Reply Likes
This forum is monitored by Adobe Engineering so the right place to provide feedback.

Did you try setting Brush Smoothing to 5% or less?

"What I did is, uninstall then re-install Photoshop. 
After doing so, lag was reduced a little, but just a little."

A reinstall of PS retains the old Preferences file, which can get corrupted and cause these types of issues. Try resetting it by closing PS and then changing the name of the Preferences file Adobe Photoshop 2020 Prefs.psp to Adobe Photoshop 2020 Prefs.psp.OLD. at the below folder location. This will allow restoring the old Preferences file if the brush lag issue persists. Restart PS and it will create a new Preferences file with the default settings. Try the brush again.

C:\Users\UserName\AppData\Roaming\Adobe\Adobe Photoshop 2020\Adobe Photoshop 2020 Settings
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
No improvement at all after following instructions.
I'm thinking again it's because of Photoshop's code. 
The software is optimized for current-gen laptops only(ideally those with a GTX 1050 or equivalent or better; Adobe themselves claim this when you read minimum requirements to run the app; and it's bad because, they should push optimizations further for decent performance on a good 10 year old hardware.)

I'm thinking again it's because of the app's code.
Sir Todd. Have you really tested the stuff the right way ? 
Here : use a big enough canvas(at least 3000 pixels per height and width) and with a brush, stroke your canvas as fast as you can without releasing your pen for at least 1 minute and see if the stroke doesn't slow down, catching up with the cursor. 
My smoothing was actually set to 0%.
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
Good lord.
When I use a mouse, there's no such lag even after a long-held stroke over time.
The issue would be caused by my Huion tablet or its driver.
... I may have to delete this post...
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 2003 Posts
  • 672 Reply Likes
As per my reply above after testing.

"Over time, the processing of a single stroke becomes exponentially slow for a reason I don't understand. Legacy Compositing is on and graphics performance mode is set to Basic (i also tested in Advanced mode and it was the same). This test that I did requires a simple 9 pixels brush, opacity set to pen pressure, spacing set to 10% and a FHD or 4K canvas. Using a single stroke, it initially starts fairly smooth, but very quickly over time, it slows down."

Using my Wacom Intuos 4 tablet with the above PS settings on my Windows 10 system with PS 21.1.2 I see no lag whatsoever.

"Here : use a big enough canvas(at least 3000 pixels per height and width) and with a brush, stroke your canvas as fast as you can without releasing your pen for at least 1 minute and see if the stroke doesn't slow down, catching up with the cursor. 
My smoothing was actually set to 0%."

Canvas was 4096 x 2160 as you suggested (i.e. 4K). At 0% Smoothing there was no lag. Increasing Smooting to 50% produced brush lag of ~ 2sec catch-up after stopping. I brushed for well over a minute without lifting the pen and used all of the PS settings you stated.


"When I un-checked "use graphics processor", I had a bad, nightmare-ish kind of performance. Things were even slower."


When I unchecked 'Use Graphics Processor'  and restarted PS there was no difference in the brush performance. Your experience would indicate the CPU then becomes the bottle-neck.


"The software is optimized for current-gen laptops only(ideally those with a GTX 1050 or equivalent or better; Adobe themselves claim this when you read minimum requirements to run the app; and it's bad because, they should push optimizations further for decent performance on a good 10 year old hardware."


MS has dropped support for Windows 7 and Adobe will do so in the next Creative Cloud update. Most 10 year old computers can not be upgraded to Windows 10 including one I purchased in 2011, which is why I bought a new system over 18 months ago. Just a heads-up!

https://www.diyphotography.net/adobe-will-no-longer-support-windows-7-in-the-next-major-creative-clo...

https://helpx.adobe.com/download-install/kb/os-support-for-cc-2019-apps.html
One other suggestion was to turn off View> Rulers, which seems to help some users with brush lag.
Photo of Dave Grainger

Dave Grainger

  • 497 Posts
  • 92 Reply Likes
Earlier  he wrote that he had added six gigs. If that mother board (which prior dialogue gave me to believe is in a laptop, which only has two slots for RAM) is old enough that the BIOS / motherboard cannot support 12 gigs, and if he took out the two existing memory pieces and replaced them with two adding up to 12 gigs, there is a possibility that the computer ignores the additional RAM.

One quick way to find out is to go to memorystock.com from that computer, and run their free system analysis. That will tell him exactly what is in the machine and the maximum RAM that the board will support.

It is also possible that the GPU circuit inside was designed for Windows 7 or earlier and that it is not fully supported on Windows 10.

Neither Adobe, nor any software maker, can be expected to maintain perpetual compatibility for old hardware!
(Edited)
Photo of Dave Grainger

Dave Grainger

  • 497 Posts
  • 92 Reply Likes
He wrote: "
I'm thinking again it's because of the app's code.
Sir Todd. Have you really tested the stuff the right way ? 
Here : use a big enough canvas(at least 3000 pixels per height and width) and with a brush, stroke your canvas as fast as you can without releasing your pen for at least 1 minute and see if the stroke doesn't slow down, catching up with the cursor. 
My smoothing was actually set to 0%."

We are back to "That diagnosis is too expensive! You will have to find another..."
Photo of Ed

Ed

  • 30 Posts
  • 3 Reply Likes
Dave Grainer. 
It's Okay. The issue seems to be caused mostly by my drawing tablet's driver more than anything else. I do not observe any lag when I use my mouse. Even when I allocate a low amount of RAM.
So yeah, I actually have no real problem regarding my GPU performance. It's the way Photoshop communicates with the tablet driver that causes the lag.