Photoshop CC 2019: Select and mask refine tool not working properly (iMac)

  • 1
  • Problem
  • Updated 9 months ago
I have just recently updated to PS 2019, when I am in select and mask, the select and mask tool is not working properly. The + tool will take away vs. add to my selection. The - tool doesn't seem to have an issue. I have made sure that the show original is turned off and have tried turning off the Legacy Compositing, and Graphic Processor as other's suggested, those did not help either. 
Photo of Alicia

Alicia

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 9 months ago

  • 1
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2903 Posts
  • 1247 Reply Likes
I do not have any issue on my Mac with PS 2019. Are you sure you understand how this tool works? The + tool redefines the edges. That means it can add or subtract, depending on what you brush. The - tool can be used to 'undo' what you just redefined.
Photo of Alicia

Alicia

  • 3 Posts
  • 0 Reply Likes
Hi, yes, I understand the tool, I selected the person, opened up select and mask and wanted to grab some more of the whispy hairs and the top of her head, but when I had it on the + brush and brushed over the top of her head and the whispy hairs, etc. it took away areas vs. adding the area of the top of head and the whispy hairs. 
Photo of eartho

eartho, Champion

  • 1472 Posts
  • 496 Reply Likes
Alicia, your selection was probably inverted... just click the invert button in s&m.
Photo of Alicia

Alicia

  • 3 Posts
  • 0 Reply Likes
Thank you! Finally had to get Adobe involved. It was PS itself, they had to do some things in the library and set back preferences to finally get it resolved.