Photoshop CC 2019: Masks not applying to smart filters

  • 7
  • Problem
  • Updated 1 week ago
  • Solved
  • (Edited)
I often run dust and scratches as a smart filter and fill the mask with black and just bring it back where needed.  Since updating to 2019, if I save a file, then re-open it, or batch process flat files, the filter is applied to the whole image, rather than just what it is masked to.  I have to turn the mask off, then back on for it to apply.  I had to re-open 160 images and render the smart object layer to fix them.
Photo of Alan Donnelly

Alan Donnelly

  • 10 Posts
  • 12 Reply Likes

Posted 3 months ago

  • 7
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15078 Posts
  • 2142 Reply Likes
Sorry you're running into this. Thanks for reporting. We're investigating this issue.

The work around is to go to Preferences > Performance... and check "Legacy Compositing"
(Edited)
Photo of TangCanada

TangCanada

  • 137 Posts
  • 65 Reply Likes
Bugs on top of bugs.
You realize that most of this is new bugs?

Why dont you guys just pull cc2019 altogether, admit its a mistake and pick up from there. Adobe may very well find favour wit its customers if they admit the screwup.

But to dump a piece of unfinished buggy nonsense on us and call it a an upgrade then stay silent as though nothing happened is making most of us rethink our subscription.

Unlike you and those at Adobe with a pension coming, most of us work photoshop for a living and are not on salary, wasted time means no income.

Photo of mayzoon

mayzoon

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Mask of Smartfilter embedded in SmartObject doesnt Work in 20.0.1.

I've got a SmartObject. I edit its content which is another SmartObject. There I do some adjustments with SmartFilters and edit the mask. Save.
Back in the main document, after PS auto-refreshing the SmartObject's content, my adjustments are visible all over. The mask doesn't do it's job.
Still works as it should in the previous PS CC version

Photo of NerveBand

NerveBand

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Linked Smart Object's mask on Smart Filter is ignored in parent Photoshop documen....

In existing Photoshop versions, if you include a linked smart object, that layer's appearance shows whatever is the state of the smart object itself. However, in Photoshop CC 2019, version 20.0.1, this doesn't seem to be the case anymore. Instead, masks on Smart Filter are ignored in parent Photoshop document.

To replicate the issue:
  1. Create a blank photoshop file
  2. Insert a Linked Smart Object (.psb) from File > Placed Linked
  3. Edit the Linked Smart Object
  4. Apply a Smart Filter (e.g. Gaussian Blur)
  5. Apply a mask to the Smart Filter
  6. Go back to the parent photoshop file that you created and update the Smart Object. Notice how the Smart Filter applies to the entire image, not just the mask.
I have attached a screenshot of the issue. The Linked Smart Object is the desired outcome in the parent Photoshop File. 
(Edited)
Photo of thefatalmallet

thefatalmallet

  • 1 Post
  • 0 Reply Likes
This is a hugely frustrating bug. I'm a GD in marketing, and there's nothing more frustrating than placing a retouched image into my email template for slicing, only to find that the image is just SLIGHTLY soft because of the Dust & Scratches mask. Because the blur is so slight (I mean, we're just getting rid of dust ya know?), I'm actually not noticed it on occasion until the email is sent out. This is a PROBLEM that we should NOT have to worry about. The world of marketing is insane, and that's just one more step that graphic designers have to do in order to avoid mistakes. This "update" is awful. Don't even get me started on the inconsistent aspect ration Shift key debacle.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15078 Posts
  • 2142 Reply Likes
Official Response
Please update to 20.0.2 which was released late last night. It should fix this issue.

Thanks for reporting!
Photo of Alan Donnelly

Alan Donnelly

  • 10 Posts
  • 12 Reply Likes
Thanks!  Just updated, will check now...
Photo of Alan Donnelly

Alan Donnelly

  • 10 Posts
  • 12 Reply Likes
looks good so far!  
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15078 Posts
  • 2142 Reply Likes
Excellent. Thanks for confirming!
Photo of Christian Patock

Christian Patock

  • 1 Post
  • 0 Reply Likes
Still does not seem to work for me...im on version 20.0.3