Photoshop CC 2019: Healing brush & clone stamp tools lagging

  • 49
  • Problem
  • Updated 1 week ago
  • In Progress
  • (Edited)
I just recently updated to Adobe Photoshop CC 2019, and my healing brush tools and clone stamp tool lags when I use it.  I had no prior issues with CC 2018.  What gives?
Photo of Anthony Nguyen

Anthony Nguyen

  • 1 Post
  • 0 Reply Likes

Posted 8 months ago

  • 49
Photo of dlewandowski

dlewandowski

  • 3 Posts
  • 1 Reply Like
I'm also now having this problem... PLUS when I try to click a clone a single spot and then move my mouse to the next spot and click, it clones an entire line between the first and second. I'm not holding the shift key down which does that as expected. It's as if Photoslop isn't recognizing that there's no keys pressed. HELP!

I'm hiding rulers, disabled technology previews, touchbar, normal drawing mode, enabled legacy compositing...even ran this terminal 

defaults write -g PhotoshopForceLegacyPaintMode -bool Yes

Running:
MacOS 10.14.3
MacBook Pro (Retina, 15-inch, Mid 2015)
2.2 GHz Intel Core i7
16 GB 1600 MHz DDR3
Intel Iris Pro 1536 MB

Photoshop 20.0.3
(Edited)
Photo of Simon Avsec

Simon Avsec

  • 1 Post
  • 0 Reply Likes
I'm also having a problem. When I use clone stamp, healing brush or brush tool, I can't see the tool. When I press  mouse key to use any of this tool, the circle dissapears. It is very hard to work like that. What would solve this problem? Anyone knows?
Photo of Jerry Syder

Jerry Syder

  • 284 Posts
  • 139 Reply Likes
@simon, regarding the visibility of the tool, try hitting the caps lock key
Photo of Pierre Alberti

Pierre Alberti

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Photoshop cc 2019 makes my MacBook Pro 15" 2018 run very hot in simple tasks and ....

Everything is very slow. Applying a drop shadow and tweaking it is very laggy. My 2013 iMac does all of that very smooth.

When I am drawing just simple things, the MacBook Pro gets very hot very fast and the fans go crazy.

In the 2015 Version it is a bit better but after a few minutes, the MBP gets hot as well.

What I tried so far:
  • reinstalled all Adobe software
  • created a new user and testet all of it again
  • changed resolutions and disabled true tone
  • smc, pram reset
  • formatted the hard drive and reinstalled macOS
Here tried to capture the issues:
https://www.youtube.com/watch?v=3JJHQvAIMOs


I am on a
MacBook Pro (15-inch, 2018)2,6 GHz i7
32 GB 24000 MHz DDR4
Radeon Pro 560X
Photo of FLYINGFOX

FLYINGFOX

  • 1 Post
  • 1 Reply Like
I have the same problem. PS is on 20.0.4. When using brush or stamp I can not draw fluently. The tool is drawing dots instead of lines. ADOBE PLEASE FIX THIS. 2019 Version is totally useless for me. I am working on mac pro (black one) power horse.

Photo of Ole Lund Andersen

Ole Lund Andersen

  • 4 Posts
  • 0 Reply Likes
I had prob. with lagging clone tool but noticed that if I turned of the rulers everything would be working fine....
Photo of Eric Tadsen

Eric Tadsen

  • 10 Posts
  • 4 Reply Likes
I'm on 20.0.4 and on all my machines the healing stamp tool is almost useless. It doesn't just lag it hangs and I need to toggle away from photoshop and back again to make it continue working. This is the most annoying bug I can remember experiencing in a while. It's infuriating. I need to work on fabric all the time and this has slowed me down by maybe 50% FIX IT. 
Photo of Mark Davidson

Mark Davidson

  • 11 Posts
  • 0 Reply Likes
I have had all the problems listed above. I have downgraded to 2018 and that did not work. I have tried all the fixes mentioned and they do not work.

HEY ADOBE! This is a serious and widespread problem that has gone unanswered.
For whatever reason the app is slow as molasses on very important processes and does not seem to be limited to Mac users as a number of Windows users have reported the same problems.