Photoshop CC 2019: Healing brush & clone stamp tools lagging

  • 53
  • Problem
  • Updated 4 days ago
  • In Progress
  • (Edited)
I just recently updated to Adobe Photoshop CC 2019, and my healing brush tools and clone stamp tool lags when I use it.  I had no prior issues with CC 2018.  What gives?
Photo of Anthony Nguyen

Anthony Nguyen

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 53
Photo of Ed Baile

Ed Baile

  • 3 Posts
  • 1 Reply Like
I agree, it is ridiculous. I have the same problems on pc with win 10
Photo of davide bozzetti

davide bozzetti

  • 17 Posts
  • 17 Reply Likes
I updated to CC 2019 on my iMac 5K with A4wacom  but I have got none of the problems you guys are having..

Great performances actually, just the healing brush seems to render the healing a bit different than before, less smooth somehow.

Note that I did not update to Mojave as I usually wait for a v .0.2  from Apple, still running on Sierra High
(Edited)
Photo of jasper goodall

jasper goodall

  • 2 Posts
  • 1 Reply Like
Yes - I would say that it is Mojave. Cos I have updated to Mojave and not CC19 and did get the odd brush activity. After I switched off rulers it went away though.
Photo of Alexander DiMauro

Alexander DiMauro

  • 9 Posts
  • 5 Reply Likes
Yes, it's already been determined that the issue is with Mojave. Although the 10.14.1 update was just released, and the issues appear to be mostly solved. I don't notice much lag at all, even with the rulers enabled.
Photo of davide bozzetti

davide bozzetti

  • 17 Posts
  • 17 Reply Likes
Alexander you tempting me.. have been closing daily the 'Do yo want to update now?" window for quite while already...  but I guess might stick to my rule "always wait for .02" :):)
Photo of Alexander DiMauro

Alexander DiMauro

  • 9 Posts
  • 5 Reply Likes
It's up to you. I had no choice. I was still on 10.11 when the CC2019 update came out, so it forced me to update before I could install it. If 10.13 is working for you, there's no reason to rush. While 10.14.1 seems to be working much better, I've only had it since yesterday, so I can't tell you with certainty that there won't be issues. I still have to play with it a lot more. But, so far it is much better since the update.
Photo of davide bozzetti

davide bozzetti

  • 17 Posts
  • 17 Reply Likes
thanks for the info Alex
Photo of chris mcgrath

chris mcgrath

  • 11 Posts
  • 6 Reply Likes
I actually just did the Mojave update....unfortunately the spinning cursor problem still exists on PS 2019.    I'm using 2018 at the moment which is working decently.
I hope they resolve this soon.   Can't remember such a big bug in a photoshop release.  They're usually pretty good.
Photo of Jordan Bartee

Jordan Bartee

  • 12 Posts
  • 3 Reply Likes
yep, i've also updated to the beta but the spinning cursor problem persists
Photo of chris mcgrath

chris mcgrath

  • 11 Posts
  • 6 Reply Likes
It is crazy.   It's actually cost a few days of work and is slowing down everything.
   Even 2018 is a little buggy but the brushes work
Photo of Alexander DiMauro

Alexander DiMauro

  • 9 Posts
  • 5 Reply Likes
What I've noticed on 10.14.1 is that the spinning cursor still shows up, but the response of the brush is much faster than before the update. It went from almost unusable to at least usable. But it's definitely still buggy. Of course, I didn't just update the OS, there was also a driver update for my Wacom tablet. So maybe that helped, too. Still has issues, but, I'm dealing with it because that new content aware fill has already helped me a lot!
Photo of chris mcgrath

chris mcgrath

  • 11 Posts
  • 6 Reply Likes
Yes.  The Wacom update definitely helped.   It is a bit faster at first, but if you keep using it, you'll notice it slow again.    Adobe seems to blame Apple, but Mojave was out weeks before PS 2019...you figured they would have noticed the problem
Photo of Jordan Bartee

Jordan Bartee

  • 12 Posts
  • 3 Reply Likes
it's really a bummer. the busy animation is driving me nuts but i'm unimpressed with the cursor latency overall as well, although the mojave beta update has perhaps improved the situation marginally. but i mean, cursor input is the single most fundamental thing this program has to do correctly other than render an accurate preview.
(Edited)
Photo of Ben Zweifel

Ben Zweifel

  • 3 Posts
  • 3 Reply Likes
I'm now frequently getting the busy cursor with most brushes, even with the rulers hidden. Frankly ridiculous.
Photo of Jordan Bartee

Jordan Bartee

  • 12 Posts
  • 3 Reply Likes
yeah it's pretty unreal tbh. i've had to almost completely stop painting in photoshop. i know there's probably a million issues but this is so fundamental and so "forward" from a ux standpoint, i mean it's right in front of my face every time i try to draw anything expressive

also, this is a subscription based product. what have i been paying for the last month? i can't use the app lol
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15409 Posts
  • 2260 Reply Likes
Does hiding the rulers while painting help?
Photo of Jordan Bartee

Jordan Bartee

  • 12 Posts
  • 3 Reply Likes
hiding rulers improves latency but does nothing for the busy cursor, in my case
Photo of Jose Paredes Blanco

Jose Paredes Blanco

  • 13 Posts
  • 3 Reply Likes
after update mojave 10.14.1.... the bug is not  fixed.... at least not  for me. Let see what Adobe does about it.
(Edited)
Photo of simon unwin

simon unwin

  • 3 Posts
  • 3 Reply Likes
I've just updated to Mojave 10.14.1 and the bug (busy cursor when painting) is not fixed when using Photoshop2019. However, it still goes away (or at least improves) with rulers hidden. Have not had any of the problems using Photoshop on my Windows 10 machine; only on my Mac using my Wacom Cintiq Pro. Not sure where the problem is. My guess would be in Mojave.
Photo of Kevin Jordan

Kevin Jordan

  • 7 Posts
  • 1 Reply Like
We updated our Wacom tablet driver.  Solved the problem!

Photo of davide bozzetti

davide bozzetti

  • 17 Posts
  • 17 Reply Likes
anyone here having problems with gradients too? I am  having a lot of banding when using gradients on mask.... getting quite visible lines have to say, on both circular and linear gradient


Photo of davide bozzetti

davide bozzetti

  • 17 Posts
  • 17 Reply Likes
8bits files, always had light banding on long gradients yes, but before cc19 I never noticed this issue as much..
Photo of Alicia Teixeira

Alicia Teixeira

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Loading Wheel when Drawing in Photoshop with Mojave-Accesibility does not resolve....

Loading Wheel instead of brush/pencil tip while drawing. Not lagging, just replacing the normal tip. This known issue is not resolved with re-installation of Creative Cloud, Photoshop or Mojave. Adobe's solve of System Preferences>Accessibility being checked for Photoshop does not work. Using most recent version of Adobe CC/PS 19. 

Mac has run multiple tests of my system to ensure no issue with the hardware or OS. Seems to be a problem many users are facing, and only temporarily resolved with so-called "fix"

Has anyone found a permanent solution? Will there be an update to address this?
Photo of Deh Andre

Deh Andre

  • 2 Posts
  • 0 Reply Likes
Hiding the Rules worked for me, with the busy cursor when using the erase tool....
Photo of Pere Larrègula

Pere Larrègula

  • 9 Posts
  • 5 Reply Likes
Same problem; Mojave 10.14.1, Adobe Photoshop CC 2019, and my healing brush tools and clone stamp tool lags when I use it.  I had no prior issues with CC 2018.

Adobe Photoshop: 20.0.0 20180920.r.24 2018/09/20: 1193433  x64



Photo of Sahil Chawla

Sahil Chawla, Community & Social Support Consultant - Digital Imaging

  • 13 Posts
  • 1 Reply Like

Hi all,

 

We are happy to announce the release of Photoshop CC 20.0.1

This update includes fixes to some of the top customer reported issues among other bug fixes. 

See what’s fixed

To update Photoshop CC to 20.0.1, click "Update" in the Creative Cloud desktop app next to Photoshop CC. More detailed instructions for updating

 

Regards,

Sahil
Photo of simon unwin

simon unwin

  • 3 Posts
  • 3 Reply Likes
Early days, but the update (PS20.0.1) seems to have worked for me. No spinning cursor when painting with rulers showing. Thanks!
(Using Mojave 10.14.1.)
Photo of chris mcgrath

chris mcgrath

  • 11 Posts
  • 6 Reply Likes
Give it time!   It still doesn't work after all the updates.  At least for me.   It took about a minute before the wheel came back
Photo of chris mcgrath

chris mcgrath

  • 11 Posts
  • 6 Reply Likes
Hi Sahil, it still has the same issues after all the updates. I have the latest Wacom driver, Mojave and this mornings PS update and I still get the spinning cursor.
Photo of Pere Larrègula

Pere Larrègula

  • 9 Posts
  • 5 Reply Likes
Hi Sahil, continues to happen, even with the 20.0.1 of Photoshop, it takes longer but ends up happening the same. The delay in painting, erasing, clone (all tools drawing) has been reduced, but the "think" still appears
Photo of Pere Larrègula

Pere Larrègula

  • 9 Posts
  • 5 Reply Likes
Sahil... There is some interim solution to minimize the impact. It is frankly very annoying when I am retouching photographs.
Photo of Ian Webster

Ian Webster

  • 6 Posts
  • 0 Reply Likes
Running latest version of Mojave (10.14.1) and latest Photoshop update. Cursor still lags with brush tools – WHEN THE RULERS ARE VISIBLE  <– this is key. When you hide the rulers the spinning stops (for me). I could not begin to think why this would be. But I like having rulers visible so please please fix this!
Photo of Pere Larrègula

Pere Larrègula

  • 9 Posts
  • 5 Reply Likes
Hi Ian... I do not have the visible rules and the same thing happens.
Photo of Ian Webster

Ian Webster

  • 6 Posts
  • 0 Reply Likes
oof, I'm sorry that workaround isn't working for you! I assume you've tried the permissions trick of allowing Photoshop 2019 permission to run your machine in the Security settings? Doing that, and hiding the rulers worked for me. 
Photo of Pere Larrègula

Pere Larrègula

  • 9 Posts
  • 5 Reply Likes
Not doing everything, that does not work ...
Photo of Ed Baile

Ed Baile

  • 3 Posts
  • 1 Reply Like
Same thing here. Brush lag on pc windows 10
Photo of simon unwin

simon unwin

  • 3 Posts
  • 3 Reply Likes
Yes Chris, you are right. I gave it time! The dreaded spinning curse (cursor) has returned. The update has not worked. Still solved by turning off rulers though.
Photo of Stephen Newport

Stephen Newport

  • 278 Posts
  • 85 Reply Likes
Same here, update did not fix. Delayed brush and pinwheel still occurring, even when rulers are hidden.... crazy
Photo of Ian Webster

Ian Webster

  • 6 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled spinning cursor while painting.

Hey all, I'm running PS 2019 and just installed Mojave. Getting the dreaded spinning cursor while painting/cloning all of the sudden. Did all the tricks suggested (allowing PS access in Security and Privacy –> accessibility –> privacy) That worked for a minute and then it was back. I am currently painting with rulers hidden, which seems to be working for now, but I frequently use rulers.  This seems like a fixable bug, so I wanted to let you all know about it! Best, Ian
Photo of chris mcgrath

chris mcgrath

  • 11 Posts
  • 6 Reply Likes
Just did the update.  Running the latest version of Mojave and the new PS 2019 with todays update to fix the bug of the spinning cursor.  Guess what?......it doesn't work!!!!!  It starts off fine for about a minute and as you keep painting the cursor kicks in and then becomes just like the way it was before.  Unusable.     This really is upsetting.   I don't know what went wrong, but this is such a fundamental tool and I can't believe Adobe didn't notice this while working on PS.    I'm sure they had copy of Mojave way back in the summer at the very least while developing this new version of PS. For now I'll just keep using PS 2018.     Bummer.
Photo of Pere Larrègula

Pere Larrègula

  • 9 Posts
  • 5 Reply Likes
Hi Chris, with PS CC 2018 (Mojave) I have delays in the stroke with all the drawing tools, does not it happen to you?
Photo of chris mcgrath

chris mcgrath

  • 11 Posts
  • 6 Reply Likes
Hi Pere, I got 2018 running on Mojave decently.  The brushes work fine.  But first you have to go into System Preferences, then security&privacy, select privacy and you'll have to add 2018 to the list and check the box.    Restart and then all should be good.  Allowing PS access to your computer should fix it.  Unfortunately 2019 does not work even when doing this
Photo of Ian Webster

Ian Webster

  • 6 Posts
  • 0 Reply Likes
Just to make sure you guys know the workaround that worked for me and some others in 2019: hide your rulers. We shouldn't have to do this but it currently is keeping me from going insane from spinning cursor brush. 
Photo of Pere Larrègula

Pere Larrègula

  • 9 Posts
  • 5 Reply Likes
Hi Chris... I already have those changes with 2018 (in privacy), but it has a slow behavior with the brushes ... I'm a photographer and I need fast performance, we go like CC2018 and High Sierra ... By the way, do you use the Wacom graphics tablet? I say this because I am also in contact with them and by discarding possible problems.
Photo of chris mcgrath

chris mcgrath

  • 11 Posts
  • 6 Reply Likes
Hi Pere,  Yes, I use a Wacom for doing my illustrations..so you can see this is a huge problem for me....and yes I updated to the latest driver.    2018 is a bit slow but since I updated the security preference, it has worked.  no problems at all panting, blurring, cloning.   and my files are huge with 100 plus layers at 3gigs.    
Photo of Stephen Newport

Stephen Newport

  • 278 Posts
  • 85 Reply Likes
Same here, update did not fix. Delayed brush and pinwheel still occurring. Mojave and PS2019
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
After applying the 20.0.1 update, you will need to do the following for macOS 10.14.1:

Run the following command from the Terminal:
defaults write -g PhotoshopForceLegacyPaintMode -bool Yes
Then you have to enable Photoshop in System Preferences > Security > Accessibility

See: https://helpx.adobe.com/photoshop/kb/photoshop-and-macosmojave.html#Penpressuredoesnotworkandbusycursordisplayswhilepainting
(Edited)
Photo of Alicia Teixeira

Alicia Teixeira

  • 3 Posts
  • 0 Reply Likes
Can you please clarify?  Should we run the first command and then run the "revert to default..." command? 
Photo of Pere Larrègula

Pere Larrègula

  • 9 Posts
  • 5 Reply Likes
Hi Jeffrey... I am doing tests and at this moment it is going well ... thank you very much.
What is the problem? and should the command be applied every time the system is rebooted or is it permanent?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
Run the first command and leave it.
Photo of Pere Larrègula

Pere Larrègula

  • 9 Posts
  • 5 Reply Likes
Ok, will we have to revert the command, that is, use the second, when there is an update?
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
Possibly. There's an unexpected interaction with Mojave. We're working with Apple on a longer term solution. May be a PS change, might be an OS change. TBD.
Photo of Jordan Bartee

Jordan Bartee

  • 12 Posts
  • 3 Reply Likes
megalike. this resolved all my problems, thank you
Photo of Justin Elledge

Justin Elledge

  • 30 Posts
  • 2 Reply Likes
This resolved the issue for me.
Photo of Michael

Michael

  • 1 Post
  • 1 Reply Like
When Adobe finally resolves the issue, then what? Does the DEFAULTS edit need to be undone somehow? And if so, how?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
We'll update the tech doc if any changes are necessary: Pen pressure does not work and busy cursor displays while painting
Photo of Mark Bellus

Mark Bellus

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Photoshop 20.0.1 pen tool and brush tool lag - MAC OS MOJAVE.

Hey guys!

After I have updated my Photoshop to 20.0.1 my pen tool and brush tool started to lag a lot. I had no issues like this in the former 2018 CC PS. It is really annoying as I can not work with the new PS CC... have no 3rd party apps to PS only "rightfont" (font manager)

any idea? :( 
Photo of Ori Vermell

Ori Vermell

  • 3 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled problems con PS 19 y mojave 10.14.2.

problems con PS 19 y mojave 10.14.2, el curso se muestra ocupado mientras pinta y me parecen artefactos de colores despues de un licuado. como se soluciona esto? cada vez photoshop va peor version a version
Photo of Станислав Подоба

Станислав Подоба

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Photoshop: "load" cursor instead usual brush (example) cursor (macOS 10.14 Mojave....



I noticed, that "load" cursor uses during I draw. It makes it difficult to see boundaries.

MacBook Pro 2013
MacOS Mojave 10.14
Photo of Mégan Lortie Fortin

Mégan Lortie Fortin

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled SOLUTION TO PHOTOSHOP BRUSH SPINNING WHEEL.

For everyone struggling with the BRUSH too turning into a SPINNING WHEEL, I found a solution! DISABLE THE RULERS (I have MacOS Mojave and Photoshop CC 2019)
Photo of Deh André

Deh André

  • 3 Posts
  • 0 Reply Likes
That solution was above before, and it works for some...Thanks anyway
Photo of Łukasz Ziola

Łukasz Ziola

  • 1 Post
  • 0 Reply Likes
Going back to PS2018 worked best for solving Mac/mohave/wacom/clone stamp lag problem. Useless update so far...
Photo of Becky Barnicoat

Becky Barnicoat

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Spinning/busy symbol when using Cintiq Wacom brush – Photoshop CC 2019 + Mac Moja....

When I use the brush on my Wacom Cintiq 13HD I get the busy/spinning symbol. This makes it really hard to see my work, and is very distracting. I have latest Mojave update and latest Photoshop. 

I am not really IT fluent enough to use Terminal to get around this. 

Please can someone update on when this bug will be fixed?? Wondering whether to return my Wacom Cintiq as it's kind of unusable like this.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
Official Response
Please update to 20.0.2 and let us know if you're still seeing the lag/spinning cursor while/after brushing. This issue should be fixed in 20.0.2. Thanks for reporting this issue!

The issue where there's a lag with Rulers showing is a separate issue that is still being worked on.
(Edited)
Photo of Alexander DiMauro

Alexander DiMauro

  • 9 Posts
  • 5 Reply Likes
How do we update? I'm on 20.0.1 but it doesn't show any updates as being available.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
Photo of Alexander DiMauro

Alexander DiMauro

  • 9 Posts
  • 5 Reply Likes
Thank you, that worked! I was selecting Help>Updates... in Photoshop not realizing that it doesn't automatically sync until you select 'Check for app updates' in the CC app.
Photo of Matt Greenslade

Matt Greenslade

  • 36 Posts
  • 5 Reply Likes
Jeffrey, Are you sure this is fixed? Mine is still running painfully slowly with the rulers off. I'm working in 16-bit. As I have mentioned before, these bugs seem to happen on every update and are a huge problem for working pros with deadlines.
Photo of Alexander DiMauro

Alexander DiMauro

  • 9 Posts
  • 5 Reply Likes
I agree. Photoshop seems to be permanently broken now. The fact that these issues have gone on for so long is inexcusable. Even simple issues like the save for web settings not saving each time you close Photoshop. Not fixed. It's been what, 3 months now? And now Photoshop has started randomly crashing in the middle of Select & Mask. Happened 3 times already. So much time lost. 
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
@Matt Sounds like you might be seeing a different issue. Is the performance just as bad or worse with Rulers on? Are you using a Wacom tablet or another input device? We may want to break your issue off into a different thread to address.
@Alexander The Save For Web issue was caused by a change in Mojave. These OS issues sometimes take longer to address, sorry. In terms of your crashing issue, I'm not finding a crash log submitted with your email address. If you can submit a crash log with your email address, it could help me track down what might be wrong: https://helpx.adobe.com/photoshop/kb/submit-crash-reports.html
Photo of Matt Greenslade

Matt Greenslade

  • 36 Posts
  • 5 Reply Likes
Hi Jeffrey, I'm using a Wacom tablet. I'm not sure the rulers are affecting it much.
Photo of Matt Greenslade

Matt Greenslade

  • 36 Posts
  • 5 Reply Likes
Hi Jeffrey, I'm using a Wacom tablet. I'm not sure the rulers are affecting it much.
Photo of Rossi

Rossi

  • 8 Posts
  • 8 Reply Likes
I've updated PS to 20.0.2 and the sticking brush stroke is still happening when rulers are visible. Once I hide rulers from the GUI, the problem goes away.

When I paint, I don't have a need for rulers so it's fine. Just wanted to let you all know that even with the latest update the brush/clone lag issue persists.

There will never be a PS as stable as version 7!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15622 Posts
  • 2366 Reply Likes
What OS/version are you running on?
(Edited)
Photo of Rossi

Rossi

  • 8 Posts
  • 8 Reply Likes
MacOS Mojave v10.14.2

Mac Pro  :  3.5 GHz 6-Core Intel Xeon E5  :  32 GB 1866 MHz DDR3  :  Dual AMD FirePro D700
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15622 Posts
  • 2366 Reply Likes
There's two parts to this issue. The Mojave specific part with the spinning cursor and lag is fixed. The part with rulers shown (cross-platform issue) is still being worked on.
Photo of Rossi

Rossi

  • 8 Posts
  • 8 Reply Likes
Thanks for the heads-up and hard work, Jeffrey! I never had a spinning cursor ... why do I miss all of the fun stuff? Could have been like a Photoshop Disco with all that spinning. 

Good luck with the cross-platform issue!
Photo of Alexander DiMauro

Alexander DiMauro

  • 9 Posts
  • 5 Reply Likes
Photoshop seems to be permanently broken now. The fact that these issues have gone on for so long is inexcusable. Even simple issues like the save for web settings not saving each time you close Photoshop. Not fixed. It's been what, 3 months now? And now Photoshop has started randomly crashing in the middle of Select & Mask. Happened 3 times already. So much time lost.

It just crashed for me again, and every time I submit a crash report. And every time I include my email address. So no idea why you don't see them.
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15409 Posts
  • 2260 Reply Likes
Crash is separate issue being worked on with Apple

Please reference the new conversation here: Photoshop: Crash macOS (bucket 4438168)
Photo of Matt Greenslade

Matt Greenslade

  • 36 Posts
  • 5 Reply Likes
Jeffrey, In the last update my settings were reset and now when I go to a tool (e.g. lasso), the focus doesn't automatically go to the tool preset panel / window, and also when I click on a curves adjustment layer the "Adjustments" panel doesn't automatically come to the foreground. Can you let me know if I can change a setting to fix this please? I have these windows / panels open all the time in one tab group (Properties, Adjustments, Tool presets).
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15586 Posts
  • 2344 Reply Likes
Separating out to its own issue

Please reference the new conversation here: Photoshop CC 2019: Painting lag (with and without rulers show) and tool focus iss...