Photoshop CC 2019: Black border automatically being added to canvas

  • 1
  • Problem
  • Updated 3 weeks ago
  • (Edited)
Photoshop CC 2019 has a very annoying bug whereby a black border is automatically being added to my canvas. Or rather, just how I *SEE* my canvas.

And curiously, it's not an even thickness all around the four edges: it is most prominent on the top and right edges, where it is 2px thick (on a retina display), and only 1px thick on the left edge. The bottom edge has no border at all.

As I said, it's not actually adding a border, it's just how Photoshop is displaying it – so no matter what zoom level I am at, 100% or 12800%, those borders are displayed at the same thicknesses.

This becomes really annoying because quite apart from it just being very visually distracting, it actually starts to become a serious interference when I am *ACTUALLY* trying to manually add my own border to my artwork.

See the attached screenshots to see what I mean. I have taken a screenshot, and then zoomed into that screenshot so you can see it clearer.

It's most noticeable when the background is in the mid-tones. Try it with a 50% grey to see.

Note that this has got nothing do with my preferences: I have already got Preferences > Interface > screen modes set to Border: None.

















Photo of Brett Archibald

Brett Archibald

  • 16 Posts
  • 2 Reply Likes

Posted 3 weeks ago

  • 1
Photo of Kukurykus

Kukurykus

  • 611 Posts
  • 139 Reply Likes
When you set your Full Screen to black, and set Transparency to black colours, then open / create document and press F twice, do you see margin on right and top edges?
Photo of Brett Archibald

Brett Archibald

  • 16 Posts
  • 2 Reply Likes
You're asking me if I can see a black border against a black background??
Well, no, of course I can't, because it's black on black.
And are you asking me this as a *test* or as a *solution*? Because if you meant as a solution, then this is not suitable: Firstly, I do not like working in fullscreen mode (as then images disappear under my palettes!), and secondly, I do not like a black background, I prefer the default grey.

Although, curiously, testing this has revealed another quirk of this particular bug:
If I start out with the situation listed above in the original post, with the black border showing, and then I press F three times to cycle through the screen modes and return to my original Standard screen mode, now the black border has disappeared! But it's only temporary, because as soon as I zoom in again, the border returns!
Photo of Kukurykus

Kukurykus

  • 526 Posts
  • 111 Reply Likes
In CS6 Extended you had completely black screen when only one document layer was transparent. In CC 2018 right-top border was about one pixel wide in other gray colour. That was annoying, but maybe somehow related to this issue. In CC 2019 I can't check right now.
(Edited)
Photo of Brett Archibald

Brett Archibald

  • 16 Posts
  • 2 Reply Likes
No, this would have been dependent on your settings – as you can see in my Preferences screenshot above (the last one), I have set my Border to None. This was the same in CC 2018 as well.
Photo of Kukurykus

Kukurykus

  • 526 Posts
  • 111 Reply Likes
Okey I checked in CC 2019 now, there is no shadow when none is set. But I remember in CC 2018 it didn't work. At least this one thing is working from now on.
(Edited)