Photoshop CC 2018: Floating document windows in fullscreen w/menu bar causes window to jump to center

  • 55
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
With the new release, the zooming mechanism has changed and it always behaves as if "Zoom Clicked Point to Center" was turned on when I am using keyboard shortcut (mapped to Wacom Pen). It works as expected when I'm zooming with scroll wheel.
Photo of Pawel

Pawel

  • 16 Posts
  • 2 Reply Likes
  • irritated

Posted 2 years ago

  • 55
Photo of alexandre becquet

alexandre becquet

  • 18 Posts
  • 4 Reply Likes
Hello! have a look at the preferences, tools ans see if "focus on the location of the click " is on ;)
Photo of Pawel

Pawel

  • 16 Posts
  • 2 Reply Likes
(Edited)
Photo of Diego Sanches

Diego Sanches

  • 5 Posts
  • 7 Reply Likes
Having the same problem and the "zoom clicked..." is not checked.
The issue only happens in the "fullscreen with Menu bars" mode. In fullscreen (the second "F") in works as it should.
Photo of Jens Claessens

Jens Claessens

  • 1 Post
  • 0 Reply Likes
I second Diego above, but you can go fullscreen (second F) and press tab and get your tools back.
Hopefully this goes back to the way it was.
Photo of Diego Sanches

Diego Sanches

  • 5 Posts
  • 7 Reply Likes
that's what I'm doing atm, but it is annoying. It looks like it's not a configuration issue, but a bug.
Photo of Alex

Alex

  • 5 Posts
  • 4 Reply Likes
Same issue
Photo of Chris Shelby

Chris Shelby

  • 3 Posts
  • 4 Reply Likes
Also having this problem.  It's a problem!
Photo of Tom Lin

Tom Lin

  • 82 Posts
  • 32 Reply Likes
Mine snaps the canvas to the center of the document. Happens in all view modes. The option is unchecked.
(Edited)
Photo of Diego Scalise

Diego Scalise

  • 6 Posts
  • 3 Reply Likes
Same here! Only with "Full Screen Mode With Menu Bar", impossible to work.
Photo of Michael Turda

Michael Turda

  • 5 Posts
  • 5 Reply Likes
Guys, it works okay when you are working on TABS. I know it takes time to adjust but that's how i solved the problem.
(Edited)
Photo of Zander

Zander

  • 9 Posts
  • 7 Reply Likes
This has worked for me so far. Thanks!
Photo of Michael Turda

Michael Turda

  • 5 Posts
  • 5 Reply Likes
You're welcome.
Photo of Ryan Ewers

Ryan Ewers

  • 1 Post
  • 2 Reply Likes
Same problem.

I noticed that if I have "enable floating document window docking" checked in preferences, and I actually then have the file docked, all 3 view modes when hitting "F" key do not show this problem.

When I drag the file to be "un-docked" or "floating", then use the 2nd view mode when toggling "F"(full screen while still showing toolbar and other panels), this issue appears when doing opt/shift zoom many use.  This happens with both wacom pen and using non-wacom mouse.  Using the space bar feature to drag any direction over document, does not present this problem & seem to be fine.
Photo of Paul Jespers

Paul Jespers

  • 2 Posts
  • 2 Reply Likes
Same problem!
I still can't find a sollution.. It's really ruining my workflow!
Photo of Pawel

Pawel

  • 16 Posts
  • 2 Reply Likes
Thanks, guys. It seems like you need to have Application Frame turned on, which is really annoying on the Mac. Hopefully, the update with a fix is imminent.
Photo of Zander

Zander

  • 9 Posts
  • 7 Reply Likes
Having the same problem on a 2016 MacBook Pro on MacOS High Sierra 10.13. Removing application frame does not resolve the issue for me.
Photo of Leo

Leo

  • 3 Posts
  • 4 Reply Likes
Same here. it happens in the full screen mode with menu bar for me. I can't figure out how to make it stop center when zoom out or selecting an object. Really frustratiting. Didn't happened before the 2018 update. Im working in a mac pro computer with macOs Sierra.
Photo of Fredrik

Fredrik

  • 6 Posts
  • 4 Reply Likes
I cannot work with this. THIS IS REALLY ANNOYiNG.
Photo of Zander

Zander

  • 9 Posts
  • 7 Reply Likes
I had to revert back to the old version of Photoshop and now I'm always going to wait at least 6 months before upgrading to new versions because Adobe has glitches with every new version they release. I can't deal with the flaws and poor beta testing.
Photo of Paolo Domeniconi

Paolo Domeniconi

  • 14 Posts
  • 8 Reply Likes
Solved setting in Preferences/Workspace “Open documents as tabs”
and Window/Application frame. After reopening the file all the 3 view "F" modes are working fine.
I’m on Mac Pro with El Capitan. 
(Edited)
Photo of Diego Scalise

Diego Scalise

  • 6 Posts
  • 3 Reply Likes
Capo!!
Photo of Tom Lin

Tom Lin

  • 82 Posts
  • 32 Reply Likes
Seems like Application Frame is enough to prevent the center snapping. This will have to do for now, even though now I can't float any other app's window behind Photoshop for reference. Thanks Paolo!
Photo of Paolo Domeniconi

Paolo Domeniconi

  • 14 Posts
  • 8 Reply Likes
In my experience also the document in tab is necessary.
I agree, Tom, Application frame is uncomfortable but I put a key shortcut to switch off it when I want.
Hoping Adobe is fixing all this.
Photo of Tom Lin

Tom Lin

  • 82 Posts
  • 32 Reply Likes
Did some work just now with both up and it seems to still snap when in Full Screen mode. Sigh.
(Edited)
Photo of Fredrik

Fredrik

  • 6 Posts
  • 4 Reply Likes
I did not work for me. I tried the document tabs and application frame. But it still snaps to center.
Photo of Sam

Sam

  • 11 Posts
  • 5 Reply Likes
Probably the same issue here. Mac Pro 2013, Sierra OS, tabs swiched off.

When zooming, the image suddently centers. It happens at a certain zoom level, when the width of the image is being shown smaller than the width of display. This happens only in the second 'F' (no windows but menus), and doesn't happen in the third 'F', without menus.  It seems the windowed mode is fine.

I have Scrubby Zoom switched off, but tried to switch it on and this still happens.

I don't want to use tabs - which do indeed help it. Tried ticking and unticking 'Zoom Clicked Point to center', doesn't work. Having application frame doesn't help.
Photo of Tom Lin

Tom Lin

  • 82 Posts
  • 32 Reply Likes
This reply was created from a merged topic originally titled (PS 2018) How to disable new zoom center snap when in Full Screen Mode.

In the newest update (2018), there's this new zoom center snap that moves my canvas to the center of the document window anytime I resize the window. I can't seem to find the option to disable it. It is especially irritating in Full Screen Mode because it just does it anytime I pan without resizing the window (since it's full screen). I can't seem to find the option to disable this.

I'm an artist/illustrator and very often am panning/zooming around the page while I draw/paint. This snap is very irritating as it shifts me off the spot I'm working on.
Photo of Dale Headrick

Dale Headrick

  • 3 Posts
  • 1 Reply Like
Thanks for staying on this topic, Tom!  I hope they resolve this soon!
Photo of Neal Stillman

Neal Stillman

  • 5 Posts
  • 1 Reply Like
ya this is giving me a headache - cmon adobe!
Photo of Michael Turda

Michael Turda

  • 5 Posts
  • 5 Reply Likes
As of now there is no solution but to use TABS. Better get used to it, guys.
In "Preferences," click "Workspace," then tick "Open documents as tabs."
Press F or "View," "Screen Mode," tick "Full screen mode with Menu Bar."
And VIOLA!
Photo of Alessandro Cornia

Alessandro Cornia

  • 1 Post
  • 3 Reply Likes
The best solution for me was to re-install Photoshop CC 2017.
Adobe Creative Cloud -> Photoshop CC -> Other Versions -> CC 2017. 
Photo of Fredrik

Fredrik

  • 6 Posts
  • 4 Reply Likes
I also re-installed The 2017 version. I have tried The tab/application fix but it is not working on my Mac.
Photo of Baadtaste

Baadtaste

  • 14 Posts
  • 6 Reply Likes
Tabs does not work - no matter what I do - snap centre is always on. THIS IS INSANE !
(Edited)
Photo of Leo

Leo

  • 3 Posts
  • 4 Reply Likes
This piece of s!!!t, no working neither with tabs. Went back to the older version 2017 until this stupid bug is fixed. Its frustrating and annoying. Lets see how many months of subscription goes to the trash.
Photo of Paolo Domeniconi

Paolo Domeniconi

  • 14 Posts
  • 8 Reply Likes
This is so strange, I'm working from several days with Tabs + Application frame and the problem is completely solved. OS X El capitan.
Photo of Tom Lin

Tom Lin

  • 82 Posts
  • 32 Reply Likes
Maybe the OS matters? I'm on Sierra (10.12.6)
Photo of Baadtaste

Baadtaste

  • 14 Posts
  • 6 Reply Likes
I'm also on Capitan. Have solved the problem by downgrading since the bug makes it totally impossible to work.
Photo of Leo

Leo

  • 3 Posts
  • 4 Reply Likes
Also I'm on OS Sierra. Anyways, i chose to downgrade the photoshop rather than the Operating System. The older version of photoshop (cc 2017) works fine.
Photo of Matthew Thomas

Matthew Thomas

  • 6 Posts
  • 7 Reply Likes
The only thing worked to resolved this issue is going back to Photoshop 2017