Photoshop CC 2018: "Save" (Cmd-S) is forcing a "Save As" (macOS)

  • 2
  • Problem
  • Updated 2 weeks ago
  • (Edited)
I think this is a bug, but am not sure. I certainly don't think this is intended behavior, but frequently, when I try to do a normal save (Cmd-S) on a Photoshop file I've created (and on which I've already done a "Save As"), it'll bring up the "Save As" dialog box instead of just doing a regular save over the document.

I had recently added a couple responses in the Adobe Community forums (https://forums.adobe.com/thread/2283725) and was directed here.

I made a quick YouTube video of this behavior in action (also found in one of my Adobe Community forum posts). It can be found here:

https://www.youtube.com/watch?v=qI0BJOMGwjM&feature=youtu.be

Just wondering if anyone has any ideas on this one.

Thank you!
Photo of brian

brian

  • 6 Posts
  • 1 Reply Like

Posted 9 months ago

  • 2
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1599 Posts
  • 647 Reply Likes
I can't reproduce this, but I noticed the 'Maximum compatibility' warning came up at the first save with layers. Maybe that's causing it. You clicked it away without looking at it, and you didn't check the 'Don't show again' box either. If you ignore it anyway, then click that 'Don't show again' box and see if that's what causing this.
Photo of Stephen Newport

Stephen Newport

  • 276 Posts
  • 74 Reply Likes
I can't reproduce this either, everything is working as expected with up to date Mac + PS
Photo of Cristen Gillespie

Cristen Gillespie

  • 1426 Posts
  • 409 Reply Likes
The only time I've had this problem I was printing, then trying to save (since printing always puts the file in an unsaved state) and got the Save As dialog for an already saved file. It hasn't happened at all lately, probably not since sometime in 2017.  It came and went as a problem in earlier versions, too. But never under the conditions you demonstrated, and I even set my prefs for Max Compatibility to Ask, instead of Always, and still couldn't get it to bring up the Save As dialog.

Sorry. from what the others have said, you seem to have found an odd one.  But if it could happen to me through using the Print dialog, I'm sure something else can trigger it.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1599 Posts
  • 647 Reply Likes
I don't know why the OP hasn't reacted yet, but I'm quite sure that this 'Maximum compatibility' warning is the culprit. Because the OP hasn't checked 'Don't show again', Photoshop will show that box each time he added a layer to a flat document. But because 'Save' does not give you any options to change a setting, Photoshop has to bring up the 'Save as' dialog box to enable you to do that.
Photo of Stephen Newport

Stephen Newport

  • 276 Posts
  • 74 Reply Likes
I tried it checked and unchecked and I didn't have any problem either way. I believe once you "maximize compatibility" that is baked into the file for future saves... but I could be wrong.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1426 Posts
  • 408 Reply Likes
From my experience, it is baked in for future saves. The first time he says OK, or unchecks Max Compatibility, is the last he'll see it for that document. Of course it will pop up if he's saved a background layer, then adds a layer (or creates a Layer 0). But after that, it shouldn't cause a problem like he's experiencing once he's saved the file in a particular state. 

Personally, I couldn't stand responding to it every document, but perhaps he sometimes needs it on, sometimes off, so he doesn't set it to on or off, but always ask.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1599 Posts
  • 647 Reply Likes
Yes, it's future saved, but that confirms what I suspect. If you look at the video, you see that the 'Save as' box only comes up the first time a layer is added. After that, he can add more layers and does not get the 'Save as' box again.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1426 Posts
  • 408 Reply Likes
I think I can now understand the confusion. He's saved a PSD, he expects to be able to simply add any layers since it IS a PSD, but he's not taking into account, as you pointed out, the need for Maximize Compatibility to know what it's supposed to do. Yet another reason for me to never, ever leave  the preference on Ask.<G> I've always thought the default should be Always, but I've heard good arguments why people don't want that, and Never is a bad default, so I guess it's what's known as a compromise—no one is happy. LOL
Photo of Andrew Croft

Andrew Croft

  • 2 Posts
  • 0 Reply Likes
THIS IS A BUG. PLAIN AND SIMPLE. I have never ever ever ever had Photoshop force me to Save As when all I have done is create a new layer, and I just tested this by hiding a layer. It didn't force Save As when I hid an adjustment layer. But it did force Save As when I hid an artwork layer. THIS IS A BUG. YET ANOTHER BUG IN A LONG LINE OF BUGS. AND I'M GETTING SICK AND TIRED OF ADOBE INCREASING THE COST OF THESE APPS WHILE FLUSHING THE QUALITY DOWN THE CRAPPY. AFFINITY PHOTO IT WILL BE IN THE NEAR FUTURE.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14551 Posts
  • 1917 Reply Likes
Hi Andrew, do you have steps to consistently reproduce this problem? I could not reproduce the problem as demonstrated in the OPs video (neither could Johan or Stephen). Could you post steps or a video demonstrating the issue?
Photo of Joel Delgado

Joel Delgado

  • 1 Post
  • 1 Reply Like
I HAD THIS PROBLEM, I SOLVED IT !!!!
In my case I had cropped the image with the option  DELETE CROPPED PIXELS "UNTICKED" so, those extra pixels that were not "lost" were forcing me to save as PSD, that's why I was always getting the SAVE AS dialog when choosing FILE > SAVE or pressing CTRL + S
Solution:  Choose the CROP tool, Tick-ON the DELETE CROPPED PIXELS checkbox and  VOILA!
Photo of Erik

Erik

  • 9 Posts
  • 1 Reply Like
I tried this and it did nothing. Still having the problem.
Photo of eartho

eartho

  • 860 Posts
  • 236 Reply Likes
Does it go away if you change your preference to Always Save with Max Compatibility? 
Prefs/File Handling/Max PSD/Always.
Photo of Erik

Erik

  • 9 Posts
  • 1 Reply Like
Command-S is forcing me to "Save AS"
We were just upgraded to Adobe photoshop CC 19.0
So far 3 of us here have been having this glitch where we go to save the file with Command "S" and it is bringing up the "Save as" option.
This could be a simple flat tiff file converting from RGB to CMYK. Some work fine and some become "save as"
Sometimes your working on a layered file and have save 20 times already but that 21st time becomes a "Save As" for no reason.
And sometimes the destination for the "save as" can be somewhere totally random on your local drive.
Makes no sense.
I son't see this problem being fixed on the Adobe Fixed issues even for version 20.
Is anyone even checking this out on Adobes side?
Thanks.


Photo of JEFF LAMBERT

JEFF LAMBERT

  • 20 Posts
  • 2 Reply Likes
I have the same problem as Erik, since updating to CC2019, Command+S does a save as randomly. I have the bug on two machine, one running High Sierra 10.13.6 and the other running Mojave 10.14.1. I'm saving the file localy so not a server issue. It doesn't happen all the time either, and all with psd file that I have already saved many times, but at random, it will just popup with save as dialog and I have to overwrite the file with the same name to continue working. VERY annoying.
Photo of eartho

eartho

  • 860 Posts
  • 236 Reply Likes
Does it go away if you change your preference to Always Save with Max Compatibility? 
Prefs/File Handling/Max PSD/Always.

Photo of JEFF LAMBERT

JEFF LAMBERT

  • 20 Posts
  • 2 Reply Likes
@eartho, yes, this is what I have, Max compatibility is set as Always. Been that way from the beginning of times;-)
Photo of Paul Thompson

Paul Thompson

  • 4 Posts
  • 0 Reply Likes
I'm having exactly the same issue.

The first 'save' works normally, any subsequent 'save' initiates a 'save as'.

I have edited the keyboard shortcuts. I have re-done the shortcuts. I have made the 'save as' shortcut very different. I have deleted the 'save as' shortcut.

I have quit Photoshop after the changes to ensure it has 'stuck' and the edit menu shows the changed shortcut.

All to no avail.

Having experimented on various files, new or opened, it does not happen on all files, just random files.

Has anyone from Adobe actually seen these comments?
Photo of Erik

Erik

  • 9 Posts
  • 1 Reply Like
doesn't look like it's high on their "to do list"
I have tried all these so called fixes that people are listing and nothing help.
It is very frustrating and a waste of time!
Photo of Paul Thompson

Paul Thompson

  • 4 Posts
  • 0 Reply Likes
Is there a direct-contact route to Adobe?

I'd love to tell them about this issue. Plus another one :

I've gone back to CC2018, as CC2019 has changed the Transform tool, to make the use of the shift button the opposite to how it has worked for years. Just so frustrating! I hope they return that back to the way it was...
Photo of JEFF LAMBERT

JEFF LAMBERT

  • 19 Posts
  • 2 Reply Likes
Paul, you can revert the transform behavior. Look here
Photo of Paul Thompson

Paul Thompson

  • 4 Posts
  • 0 Reply Likes
Hi Jeff,

I tried that, but unfortunately it didn't work for me. There was some other discussions about exactly where the line of code should actually be placed. If there is something absolutely definitive, I'd give it another go.

But it's another example of breaking something that didn't need fixing! Infuriating...
Photo of Paul Thompson

Paul Thompson

  • 4 Posts
  • 0 Reply Likes
Hey Jeff!

I just tried that fix again - and it worked this time!

(There was some hidden extra bits in the txt file that when deleted made the fix work)

Thanks very much for reminding me!