Photoshop CC 2018: Imacon 3F plugin not working

  • 3
  • Problem
  • Updated 4 months ago
  • In Progress
My Imacon 3F plugin (1.4) doesn't work in Photoshop 2018 (19.1.1) on MacOS Sierra (10.12.6). The plugin works fine in Photoshop 2017. 

When attempting to open a 3F file in PS 2018, the fileformat is preselected as Imacon 3F, whichis not the case in  PS 2017. 

Photoshop System Info shows no error in loading the plugin.

Any suggestions on how to get the Plugin to work in PS2018? 

Photo of Michael Bothager

Michael Bothager

  • 14 Posts
  • 1 Reply Like

Posted 1 year ago

  • 3
Photo of Michael Bothager

Michael Bothager

  • 14 Posts
  • 1 Reply Like
If anyone is interested, Hasselblad Support have reproduced the issue, and have reported it to Adobe.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15225 Posts
  • 2188 Reply Likes
Still being investigated. Best to use the workaround in the meantime.
Photo of Michael Bothager

Michael Bothager

  • 14 Posts
  • 1 Reply Like
So, any progress?
Photo of PECourtejoie

PECourtejoie, Champion

  • 795 Posts
  • 286 Reply Likes
Is it still the case in PS CC19.1.4?
Photo of Michael Bothager

Michael Bothager

  • 14 Posts
  • 1 Reply Like
Unfortunately, yes :/
Photo of Michael Bothager

Michael Bothager

  • 14 Posts
  • 1 Reply Like
So, latest update (PS CC 19.1.5 & ACR 10.4.0.976) – the issue still exists.

I guess that this is a very low-priority issue for Adobe, which is unfortunate.

Jeffrey Tranberry, can you please comment on what is being done to fix the issue?
Photo of Michael Bothager

Michael Bothager

  • 14 Posts
  • 1 Reply Like
The latest update (19.1.2) didn't fix this issue.

Adobe, are you working on this problem?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15327 Posts
  • 2222 Reply Likes
Sorry for the late reply. I was out of town the past two weeks. Eric from the ACR team looked at this back in 2014: https://feedback.photoshop.com/photoshop_family/topics/support_of_hasselblad_3f_files

fff files are essentially 16-bit RGB TIFF files with some custom/proprietary tags in them for the Hasselblad software to access.

Do you use the Hasselblad software to edit your the original fff images?

If not, the simplest thing to do is rename the files from <myfilename>.fff to <myfilename>.tiff and Photoshop will open them without any extra hoops. If you want them to open directly in Camera Raw, then set the ACR pref to automatically open TIFFs after you rename the files.
Photo of Michael Bothager

Michael Bothager

  • 14 Posts
  • 1 Reply Like
When removing dust/scratches before converting the file, I can make different conversions without having to remove dust/scratches more than once. This is explained in more depth here: https://www.knowhowtransfer.com/how-to/resources/3f-system-revolutionary-pro-scanning-system-by-hass... (under the section Retouching 3F originals)
Photo of Michael Bothager

Michael Bothager

  • 14 Posts
  • 1 Reply Like
Mr. Jeffrey Tranberry, will there be any solution to this bug? There has been a couple of updates, but none of them have solved this issue.
Photo of Adam Long

Adam Long

  • 2 Posts
  • 0 Reply Likes
FYI same problem persists in CC2019. There is an "options" button at the lower left of the "open" dialog box - it brings up the "enable" and "format" options to open a file. The "format" drop down is able to find the 3F plugin but upon trying to open the file a dialog box says to update ACR and includes a weblink. The link shows supported cameras and under the Hasselblad cameras there is an * (** Hasselblad FFF files created by the Hasselblad Phocus software for currently supported models are also supported. FFF files created using the FlexColor software are not supported.) Regardless, I too want to open my scanner 3F files in Photoshop (not ACR) the way I used to. Is this possibly a plugin problem now?
Photo of Adam Long

Adam Long

  • 2 Posts
  • 0 Reply Likes
Did a little more digging and found that in the PS Open dialog box, in the Options change “Enable: All Documents” to “Enable: All Readable Documents”, then back to “Enable: All Documents”; also, set “Format: Imacon 3f” to something else, then back to “Format: Imacon 3f”. It is "the secret handshake" but it does work. PS loaded my 3f as a grayscale sRGB image. I assigned "don't color manage", did some cloning and saved. Went over to Flexcolor and was able to open the color scan. All is well... kinda http://www.davidebarranca.com/2013/02/how-to-open-and-retouch-hasselblad-3f-scanner-files-in-photosh...
Photo of Michael Bothager

Michael Bothager

  • 14 Posts
  • 1 Reply Like
Adam, the bug was introduced in PS CC 2018, and the workaround you mention was described by mristuccia at the Yahoo Imacon Users forum.

Hasselblad and Adobe have spoken to each other, and the bug was in Photoshop.

Its just to bad that Adobe will not reply and fix this bug. The workaround works, but it is annoying, just like if your car only starts if you had to get out to open and close the hood/bonnet before turning the ignition ;o)